Installation von Code Typhoon von Pit Logic

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Installation von Code Typhoon von Pit Logic gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Installation von Code Typhoon von Pit Logic

    Hallo Leute,

    ich habe folgendes Problem:

    Ich möchte das Paket "Code Typhoon" von Pit Logic installieren, welches es mir ermöglicht (erheblich weiter als Lazarus ;) ) unter Pascal, systemübergreifend zu programmieren.

    Nun soll ich dem User, also mir, Root Privilegien erteilen, um das Paket zu installieren. Laut Anweisung soll ich dann in der Datei /etc/sudoers folgende Zeile am Ende einfügen

    Quellcode

    1. username ALL=(ALL) NOPASSWD: ALL

    Nun lade ich das kostenlose Paket (aktuell Version 6.70) von der Pit Logic Seite herunter und entpacke es in meinem Home Verzeichnis. Wechsle in das entpackte Verzeichnis
    und soll folgendes Skript über die Konsole ausführen ausführen:

    Quellcode

    1. sh ./install.sh
    Jetzt bekomme ich jedoch eine Fehlermeldung:


    Brainfuck-Quellcode

    1. ====================================================
    2. CodeTyphon Studio
    3. Version 6.70 (GEN 6)
    4. Installation for: Linux-Solaris-FreeBSD-MacOS
    5. ====================================================
    6. -----ERROR------ ERROR ----ERROR--------------
    7. Current user can NOT run the sudo command
    8. To correct this problem:
    9. 1) Install sudo
    10. 2) Add current user to sudo list
    11. with root privileges
    12. -----ERROR------ ERROR ----ERROR--------------
    Alles anzeigen

    Auf Nachfrage sagt man mir, die Installation sei mit Leap 42 getestet worden, und genau so, ohne Probleme durchgelaufen...

    Weiss einer von Euch Rat :?:
    --
    openSUSE Tumbleweed KDE Plasma + Windows 10 Professional (64-Bit)

    Mein Hardware-Profil auf YOUR-IT-WORLD

    Für den Inhalt des Beitrages 130770 haftet ausdrücklich der jeweilige Autor: mookwi1

  • Hi,

    erst einmal Danke für die schnelle Antwort :D . Unter Mint und Manjaro hatte die Installation vorzüglich geklappt. Code Typhoon erweitert "Lazarus" ganz immens. Jedoch kann ich auch erst einmal mit "Lazarus" in der Original Version arbeiten, so ist es nicht. Ich weiss jedoch nicht, warum die Installation bei openSUSE so ein Problem macht und weiterhin kann ich auch nicht verstehen, warum im Wiki von Code Typhoon die Installation unter Leap 42 bzw. 15 als problemlos beschrieben wird, wenn man vorab die Datei "/etc/sudoers" um diese eine Zeile erweitert? :huh:
    --
    openSUSE Tumbleweed KDE Plasma + Windows 10 Professional (64-Bit)

    Mein Hardware-Profil auf YOUR-IT-WORLD

    Für den Inhalt des Beitrages 130814 haftet ausdrücklich der jeweilige Autor: mookwi1

  • Hi,
    im Forum von Code Typhoon hatte man mir ja gesagt, dass die Installation an Leap 42 und Leap 15 ausprobiert
    und ohne Fehler getestet worden ist. Auch hier wurde nur die "/etc/sudoers" angepasst ;( ...
    Na gut, erst einmal vielen Dank...
    --
    openSUSE Tumbleweed KDE Plasma + Windows 10 Professional (64-Bit)

    Mein Hardware-Profil auf YOUR-IT-WORLD

    Für den Inhalt des Beitrages 130835 haftet ausdrücklich der jeweilige Autor: mookwi1

  • mookwi1 schrieb:

    Hi,
    im Forum von Code Typhoon hatte man mir ja gesagt, dass die Installation an Leap 42 und Leap 15 ausprobiert
    und ohne Fehler getestet worden ist. Auch hier wurde nur die "/etc/sudoers" angepasst ;( ...
    Na gut, erst einmal vielen Dank...
    ich habe die Software eben mal testweise unter Leap 15 installiert.
    sudors hab ich nicht angepackt. Ich habe einfach nur
    - die Zip-datei in meinem User-Verzeichnis gespeichert
    - den enthaltenen Ordner ins User-Verzeichnis entpackt
    - mich als root angemeldet

    - in den Programmordner navigiert
    - dort die install.sh ausführbar gemacht
    . einfach

    Quellcode

    1. ./install.sh
    und die Installation lief glatt durch und die Software war nutzbar

    Wo und mit welcher Fehlermeldung hakt es bei dir, wenn du DIESEM Ablauf folgst?
    There's no place like 127.0.0.1

    Für den Inhalt des Beitrages 130836 haftet ausdrücklich der jeweilige Autor: wurzel99