Laptop fährt nicht wie gewünscht runter

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Laptop fährt nicht wie gewünscht runter gibt es 13 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Laptop fährt nicht wie gewünscht runter

    Hallo alle,

    Grundproblem: Klappe ich den Bildschirm runter, geht der Rechner auf Standby. Klappe ich den Bildschirm wieder hoch, fährt der Rechner ganz runter und geht dann aus.

    Gleich nach der Installation von openSuse (42.3) habe ich unter den Systemeinstellungen > Energieverwaltung den Läppi so einstellen wollen, dass er auf Knopfdruck (Ereignisknopf) runterfährt und bei Bildschirm runter in zuerst hybriden Standby geht. Letzteres habe ich später (15.0) auf ganz normal Standby geändert. Heute ist mir das zu blöd und ich habe es geändert: Bildschirm runter, Rechner runterfahren und Knopf drücken Standby. Beide Einstellungen gelten für Netz- und Akkubetrieb.

    Die letzte Einstellung funktioniert aber nicht. Klappe ich den Bildschirm runter, zuerst Standby und nach erneuten Aufklappen ganz runter. Ich wüsste auch nicht, wo ich unter Yast nachschauen sollte; und leider habe ich auch keine Idee, welche Infos ihr noch braucht =O .

    Danke euch

    unpluged

    Kleiner Nachtrag: Standby auf Knopfdruck (Ereignisknopf funktioniert bestens
    Laptop


    Proz.: 8 mal Intel Core i7-4810MQ CPU@2,8 GHZ
    RAM: 16 GB
    HDD: 512 GB Samsung Envy
    Graka: 2GB NVIDIA Quadro K1100M Graphic

    OS: openSuse 15.0 Leap
    KDE Plasma: 5.12.6
    QT-Version: 5.9.4
    Kernelversion: 4.12.14-lp, 64 Bit

    Für den Inhalt des Beitrages 131714 haftet ausdrücklich der jeweilige Autor: unpluged

  • Moin zusammen,

    äh, was ist denn das für ein Unsinn, den Bildschirm AUFzuklappen und damit ein System RUNTERzufahren?

    Runterfahren --> sudo shutdown -h 0 (Das kannste dir auch als ClickiMicki Shortcut auf den Desktop legen) Klappe zu, Ende.
    Schlafenlegen --> sudo systemctl hibernate|hybrid-sleep|suspend (Das kannste dir auch als ClickiMicki Shortcut auf den Desktop legen), Klappe zu, Ende.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 131717 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • evtl. hilft Dir folgendes: prüfen ob der Advanced Configuration and Power Interface event daemon läuft mit:

    Quellcode

    1. systemctl status acpid.service


    wenn der service nicht aktiv ist:

    Quellcode

    1. systemctl start acpid.service
    2. systemctl enable acpid.service
    (enable damit der service zukünftig gestartet wird.)
    Falls acpid noch noch installiert ist:

    Quellcode

    1. zypper in acpid
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 131719 haftet ausdrücklich der jeweilige Autor: Boreas

  • Tamerlain schrieb:

    äh, was ist denn das für ein Unsinn, den Bildschirm AUFzuklappen und damit ein System RUNTERzufahren?
    und genau diesen Unsinn wollte upplugged ja nicht, er schrieb ja vom Grundproblem...

    unpluged schrieb:

    Grundproblem: Klappe ich den Bildschirm runter, geht der Rechner auf Standby. Klappe ich den Bildschirm wieder hoch, fährt der Rechner ganz runter und geht dann aus.
    Das will er wohl irgendwie anders haben...

    @unpluged, leider kann ich heute auch nichts mehr dazu sagen :)

    Für den Inhalt des Beitrages 131723 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Moin zusammen,

    Thomas, das habe ich dann wohl falsch verstanden.

    BTW. von der commandline ein simpler kleiner Befehl, den man sich in der Bash auch noch als alias legen kann ... das tut es doch, da braucht es nix Anderes.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 131738 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Hallo,

    so, ich musste acpid installieren und gemäß den Befehlen starten und auf Autostart setzen. Laut Konsole hat alles geklappt.

    Morgen sollte ich erste Ergebnisse bringen.

    Danke euch, besonders Boreas

    unpluged
    Laptop


    Proz.: 8 mal Intel Core i7-4810MQ CPU@2,8 GHZ
    RAM: 16 GB
    HDD: 512 GB Samsung Envy
    Graka: 2GB NVIDIA Quadro K1100M Graphic

    OS: openSuse 15.0 Leap
    KDE Plasma: 5.12.6
    QT-Version: 5.9.4
    Kernelversion: 4.12.14-lp, 64 Bit

    Für den Inhalt des Beitrages 131750 haftet ausdrücklich der jeweilige Autor: unpluged

  • So Leits,

    ich scheine noch irgendwas falsch zu machen. Eben nochmals in der Systemeinstellung > Energieverwaltung nachgesehen. Dort ist alles so eingestellt, wie ich es möchte (Bildschirm runter = Herunterfahren, Ereingnisknopf drücken = (nur) Standby). Am Verhalten hat sich nichts geändert. Dazu diese Ausgabe:

    Quellcode

    1. :~> systemctl status acpid
    2. ● acpid.service - ACPI Event Daemon
    3. Loaded: loaded (/usr/lib/systemd/system/acpid.service; enabled; vendor>
    4. Active: active (running) since Fri 2019-04-12 16:44:43 CEST; 2h 6min a>
    5. Main PID: 1249 (acpid)
    6. Tasks: 1 (limit: 4915)
    7. CGroup: /system.slice/acpid.service
    8. └─1249 /usr/sbin/acpid -n -f
    Einzige Neuerung ist, dass das Herunterfahren etwas später beginnt. Immerhin kann ich noch z. B. auf Neustart klicken, damit der Läppi nach Herunterfahren gleich wieder startet.

    What's wrong?

    unpluged
    Laptop


    Proz.: 8 mal Intel Core i7-4810MQ CPU@2,8 GHZ
    RAM: 16 GB
    HDD: 512 GB Samsung Envy
    Graka: 2GB NVIDIA Quadro K1100M Graphic

    OS: openSuse 15.0 Leap
    KDE Plasma: 5.12.6
    QT-Version: 5.9.4
    Kernelversion: 4.12.14-lp, 64 Bit

    Für den Inhalt des Beitrages 131800 haftet ausdrücklich der jeweilige Autor: unpluged

  • Ich halte es für ziemlich unsinnig beim Schließen des Deckels herunterfahren zu wollen, und beim Drücken eines "Ereignisknopfes" (was auch immer das meinen mag) aber nur einen Hibernate-modus anzuschalten. (Was passiert, wenn du das Ding schlafen legst, und dann den Deckel zuklappst? Das wäre ein ziemlich normales Szenario.)

    Ich weiß nicht wirklich, wo du da schrauben musst, (weil ich sowas irgendwie einfach gar nicht wollen will), aber machbar ist es auf jeden Fall.
    Zuerst würde ich die systemd Infrastruktur sorgfältig durchgehen und alle Links und Dienste entsprechend ummodeln.

    Falls das nicht hilft, solltest du prüfen, ob nicht die Hardware selbst implizit die "vernünftige Konfig" sicherstellt, was deiner Konfig doch etwas widerspricht.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 131802 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Neu

    O.k. eine kleine Korrektur: Es geht um die "Knopf-Ereignisbehandlung", also um den Knopf, der am Rechner oder Laptop gedrückt wird, um den Rechner einzuschalten.

    Ansonsten interessiert es mich, warum du es unsinnig findest, einen Laptop über Bildschirm auszuschalten.

    unpluged
    Laptop


    Proz.: 8 mal Intel Core i7-4810MQ CPU@2,8 GHZ
    RAM: 16 GB
    HDD: 512 GB Samsung Envy
    Graka: 2GB NVIDIA Quadro K1100M Graphic

    OS: openSuse 15.0 Leap
    KDE Plasma: 5.12.6
    QT-Version: 5.9.4
    Kernelversion: 4.12.14-lp, 64 Bit

    Für den Inhalt des Beitrages 131857 haftet ausdrücklich der jeweilige Autor: unpluged

  • Neu

    Wenn ich irgendwo mit einem Notebuch hacke, will ich nicht, nur weil ich mal kurz für kleine Jungs weg muss, die Kiste runterfahren.
    Ich klappe den Deckel einfach zu, er legt sich suspend-to-ram ein wenig Stromsparen, und bin ich zurück arbeite ich nach Hochklappen (des Notbuchdeckels) sofort wieder weiter.
    statt -wie bei dir- nach dem Pinkeln komplett booten müssen.
    Bei Hochgeklapptem Deckel (des Notbuchs) dafür aber ein Knöpfchen drücken zu müssen, wenn ich muss, scheint mir ziemlich widersinnig.

    Ich meine, was mache ich, wenn ich mal länger weg muss? Drücke ich dann das Knöpfchen, und muss das Deckelchen danach zuklappen, dann den Rechner bei Heruntergeklapptem Deckel wieder aufwecken, damit er auch mitkriegt, dass ich nach dem Deckelrunterklappen und dem dadurch sofort erfolgtem Einschlafen noch das Ich-bin-mal-länger-weg-Köpfchen gedrückt habe?

    Ich denke, man erledigt seine Geschäfte am besten wach bei hoch- oder runtergeklappten Deckel.
    Und ist man mit allem fertig, schaltet man (das Licht) aus.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 131861 haftet ausdrücklich der jeweilige Autor: Berichtigung