Tastaturlayoutwechsel führt zu Einfrieren

Hinweis: In dem Thema Tastaturlayoutwechsel führt zu Einfrieren gibt es 78 Antworten auf 8 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,
    ich wollte auf meinem Laptop unter OpenSuse Tumbleweed (Gnome) die Japanische (Anthy) Spracheinstellung für die Eingabe einrichten. Wenn ich das Tastaturlayout aber umstelle, friert die GUI ein, lediglich der Mousezeiger funktioniert noch. Wenn ich den Laptop neu starte, kann ich mich anmelden, wonach aber direkt wieder alles (bis auf die Mouse) einfriert (das Mousezeiger-Theme wird noch geladen, der Rest nicht mehr). Da ich mir nicht anders zu helfen wusste, habe ich den Rechner jetzt schon das zweite mal mit Clonezilla wieder auf den Status vor der Umstellung auf das andere Tastatur-Layout gesetzt.
    Bei der Anmeldung (nach Hard-Reset und Boot) habe ich versucht, andere DE-Sessions auszuprobieren, aber auch die frieren sofort ein. Mir gelang ein Einloggen mit einem älteren Kernel in der Terminal-Version. Dort konnte ich auch durch die Dateien browsen. Meine Vermutung ist daher, dass aus irgendwelchen Gründen die Desktop-Umgebung abstürzt.
    Zusätzlich ist noch zu berichten, dass auf meinem anderen, älteren Laptop, ebenfalls mit OpenSuse Tumbleweed und Gnome der Wechsel der Layouts ohne Probleme möglich ist. Beim zweiten Versuch der Installation der Sprachpakete auf dem Problem-Rechner habe ich auch extra drauf geachtet, dass genau dieselben japanischen Sprachpakete installiert sind. Mir ist noch aufgefallen, dass auf dem einfrierenden Rechner hinsichtlich der Sprachpakete noch zusätzlich Fcitx installiert ist (blockieren sich hier die Pakete eventuell?).
    Ich habe so ein Einfrieren unter Linux noch nie erlebt. Es wäre für mich sehr hilfreich, wenn ich das Sprachpaket installieren und das Tastaturlayout ohne Probleme wechseln könnte.
    Hat hier jemand eine Idee, was die Ursache des Problems sein könnte und wie man es lösen kann?
    Vielen Dank im Voraus, ありがと。 :smilie_school_012:

    Für den Inhalt des Beitrages 132349 haftet ausdrücklich der jeweilige Autor: elranjit

  • Poste doch mal:

    Code
    /sbin/lspci -nnk | grep -EiA3 "vga|3d|disp|graphic"
    Code
    dmesg | grep -E -i "error|fail|crit"
    Code
    zypper se -s ibus-mozc anthy

    Für den Inhalt des Beitrages 132351 haftet ausdrücklich der jeweilige Autor: sterun

  • Poste doch mal

    Von welchem Laptop? Von dem bei dem es geht oder bei dem es einfriert?
    Im Falle von Letzterem: Soll ich die Pakete installieren aber nicht wechseln? Oder ist das für den Schritt noch nicht nötig?

    Für den Inhalt des Beitrages 132354 haftet ausdrücklich der jeweilige Autor: elranjit

  • Ausgaben vom "Problem-Rechner", wenn es denn geht und er nicht sofort einfriert.

    Für den Inhalt des Beitrages 132355 haftet ausdrücklich der jeweilige Autor: sterun

  • zypper in susepaste Danach kannst du aus der Konsole posten.
    someCommand | susepaste legt dir die Ausgabe von someCommand auf paste.opensuse.org


    Netzwerk sollte da längst aktiv sein.
    Ggf. mit nmcli networking on einschalten (falls NetworkManager, sonst systemctl verwenden)

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 132357 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Code
    elranjit@linux-z088:~> /sbin/lspci -nnk | grep -EiA3 "vga|3d|disp|graphic"
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c20] (rev a1)
    Subsystem: CLEVO/KAPOK Computer Device [1558:65a2]
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia_drm, nvidia

    Das ist von dem Problemrechner, der gerade mit dem Backup vor den Zeitpunkt des Problems zurückversetzt wurde. Das Sprachpaket, so wie ich es hatte ist in der Form noch nicht installiert. Das System friert nicht ein.

    Für den Inhalt des Beitrages 132359 haftet ausdrücklich der jeweilige Autor: elranjit

  • "Anthy" ist ja schon bzw. noch installiert.
    1. Bedeutet das jetzt, wenn du einfach auf "Japan" umstellst, friert der Rechner ein?
    2. Oder friert er ein, wenn du zusätzliche Pakete installiertst? Wenn ja, welche?


    Wenn auf Frage 1. ein "ja" kommt, installiere das Paket:

    Code
    zypper in ibus-mozc

    Bei einer Umstellung auf "Japan" sollte der Rechner neu gestartet werden.
    Ob bei dem Nvidia Treiber alles ok ist, können andere hier besser beurteilen.

    Für den Inhalt des Beitrages 132361 haftet ausdrücklich der jeweilige Autor: sterun

  • Ja, genau das meinte ich.
    Da sieht man leichter, was schief läuft.


    Ein journalctl -b wäre dann auch nicht verkehrt.

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 132362 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • 1. Bedeutet das jetzt, wenn du einfach auf "Japan" umstellst, friert der Rechner ein?

    Im Moment kann ich noch nicht umstellen, siehe Bild (Einstellungsfenster von Gnome). Übrigens kann ich jetzt noch nicht das Japanisch (Anthy) einstellen, dass ich auf dem anderen Rechner habe. Auch komisch, oder? Ich poste im Anschluss ein Bild, wie es auf dem funktionierenden Gerät aussieht.
    Zumindest beim ersten Versuch habe ich erst einmal keine weiteren Pakete installiert, das würde also eher Richtung 1 deuten.
    Muss ich es versuchen umzustellen? :/