YAST Startprobleme unter Wayland und Tumbleweed

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema YAST Startprobleme unter Wayland und Tumbleweed gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • YAST Startprobleme unter Wayland und Tumbleweed

    Guten Tag,

    jüngst habe ich meine DE von KDE zu GNOME gewechselt. Jetzt habe ich das Problem, das Yast unter der Gnome Wayland session nicht mehr startet. Jedoch unter X tut es.

    Über das Terminal bekomme ich die Meldung, das etwas von QT fehlt, aber ich weiß nicht was. Scheint keine automatische dependency zu sein, da Neuinstallation von Yast keine Veränderung bringt. Weiß da jemand Rat?

    Quellcode

    1. gnomesu yast2
    2. (gnomesu:6538): Gtk-WARNING **: 07:06:48.727: gtk_window_set_titlebar() called on a realized window
    3. Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyqt.qpa.xcb: could not connect to display :0
    4. qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    5. Failed to create wl_display (No such file or directory)
    6. qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
    7. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
    8. Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
    9. /sbin/yast2: Zeile 461: 6568 Abgebrochen (Speicherabzug geschrieben) $y2ccbin $Y2UI_ARGS "$@"
    Alles anzeigen

    Für den Inhalt des Beitrages 132818 haftet ausdrücklich der jeweilige Autor: Scytale

  • Since the introduction of the Plasma/Wayland session we set the QT_QPA_PLATFORM variable to wayland by default. After a long and hard discussion we decided to no longer do this with Plasma 5.13. This was a hard decision and unliked by everyone involved.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 132825 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Darf ich mich hier mit einem sehr ähnlichen Problem, allerdings NVidia proprietär einhaken?
    Meine Ausgabe hat lediglich den Unterschied, dass QT wayland nicht findet:

    Quellcode

    1. Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: qt.qpa.xcb: could not connect to display :0
    2. Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    3. Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
    4. Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix>
    5. Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
    Meiner Ansicht nach ist die Lösung für das Problem aber dieselbe wie für das Setting des Themenerstellers.
    Dem Blogpost folgend kommt entweder das Update auf QT5.11 oder sehe ich das richtig und man muss die Einstellung QT_QPA_PLATFORM auf default setzen?

    Für den Inhalt des Beitrages 132828 haftet ausdrücklich der jeweilige Autor: elranjit

  • Sauerland schrieb:

    Since the introduction of the Plasma/Wayland session we set the QT_QPA_PLATFORM variable to wayland by default. After a long and hard discussion we decided to no longer do this with Plasma 5.13. This was a hard decision and unliked by everyone involved.


    For now we implemented a change in Plasma 5.13 so that we don’t need to set the env variable any more. Plasma is able to select the appropriate platform plugin based on XDG_SESSION_TYPE environment variable. Non-Plasma processes will use the default platform plugin.
    Ich hab Gnome und nicht Plasma und ich weiß schon seit der Fehlermeldung, dass das Platform Plugin nicht richtig geladen wird. Ich verstehe nicht, was du mir sagen willst.

    Für den Inhalt des Beitrages 132842 haftet ausdrücklich der jeweilige Autor: Scytale