YAST Startprobleme unter Wayland und Tumbleweed

Hinweis: In dem Thema YAST Startprobleme unter Wayland und Tumbleweed gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Guten Tag,


    jüngst habe ich meine DE von KDE zu GNOME gewechselt. Jetzt habe ich das Problem, das Yast unter der Gnome Wayland session nicht mehr startet. Jedoch unter X tut es.


    Über das Terminal bekomme ich die Meldung, das etwas von QT fehlt, aber ich weiß nicht was. Scheint keine automatische dependency zu sein, da Neuinstallation von Yast keine Veränderung bringt. Weiß da jemand Rat?


    PRAISE THE OMNISSIAH

    Für den Inhalt des Beitrages 132818 haftet ausdrücklich der jeweilige Autor: Scytale

  • Du hast aber nicht den Nvidia Treiber installiert?

    Nein, ich habe keine Nvidia Treiber installiert, wenigstens nicht wissentlich. Ich habe hier ein komplettes AMD System.

    PRAISE THE OMNISSIAH

    Für den Inhalt des Beitrages 132820 haftet ausdrücklich der jeweilige Autor: Scytale

  • Zitat

    Since the introduction of the Plasma/Wayland session we set the QT_QPA_PLATFORM variable to wayland by default. After a long and hard discussion we decided to no longer do this with Plasma 5.13. This was a hard decision and unliked by everyone involved.

  • Darf ich mich hier mit einem sehr ähnlichen Problem, allerdings NVidia proprietär einhaken?
    Meine Ausgabe hat lediglich den Unterschied, dass QT wayland nicht findet:

    Code
    Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: qt.qpa.xcb: could not connect to display :0
    Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
    Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix>
    Mai 19 11:16:54 linux-l7ok YaST.desktop[3345]: Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

    Meiner Ansicht nach ist die Lösung für das Problem aber dieselbe wie für das Setting des Themenerstellers.
    Dem Blogpost folgend kommt entweder das Update auf QT5.11 oder sehe ich das richtig und man muss die Einstellung QT_QPA_PLATFORM auf default setzen?


  • Zitat

    For now we implemented a change in Plasma 5.13 so that we don’t need to set the env variable any more. Plasma is able to select the appropriate platform plugin based on XDG_SESSION_TYPE environment variable. Non-Plasma processes will use the default platform plugin.

    Ich hab Gnome und nicht Plasma und ich weiß schon seit der Fehlermeldung, dass das Platform Plugin nicht richtig geladen wird. Ich verstehe nicht, was du mir sagen willst.

    PRAISE THE OMNISSIAH

    Für den Inhalt des Beitrages 132842 haftet ausdrücklich der jeweilige Autor: Scytale