Gnome bleibt nach dem Start schwarz

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Gnome bleibt nach dem Start schwarz gibt es 32 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Gnome bleibt nach dem Start schwarz

    Hallo zusammen,
    nach dem Bug ist vor dem Bug: Nach dem Update zwischen dem Kernel 5.0.9 und 5.0.13 (das nur als Angabe des Zeitraums, benutzt wird momentan der Kernel 5.1.x) ist wohl etwas arg schief gelaufen: Meine Gnome-Desktop Umgebung zeigt nach dem Login nichts weiter als einen schwarzen Bildschirm und später das Fenster des Nextcloud-Clients (allerdings mit korrekt dargestellten Theme, ebenso wie beim Mousezeiger), das sich nicht verschieben lässt.
    Nach dem Absetzen von journalctl -b meine ich zu lesen, dass die Gnome Shell abgestürzt ist:

    Quellcode

    1. Mai 19 11:14:04 linux-z088 gnome-shell[1877]: meta_kms_resources_init failed: Calling drmModeGetResources() failed, assuming we have no outputs
    2. Mai 19 11:14:04 linux-z088 gnome-shell[1877]: Failed to create backend: No GPUs with outputs found
    3. Mai 19 11:14:04 linux-z088 gnome-session[1856]: gnome-session-binary[1856]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
    4. Mai 19 11:14:04 linux-z088 gnome-session-binary[1856]: Unrecoverable failure in required component org.gnome.Shell.desktop
    5. Mai 19 11:14:04 linux-z088 gnome-session-binary[1856]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
    (Das vollständige Protokoll habe ich in den Anhang gepackt, weil ich mir nicht sicher bin ob ich tatsächlich den wunden Punkt erwischt habe)
    Hat jemand eine Idee, was das sein könnte und wie man es beheben kann?
    Ich benutze OpenSuse Tumbleweed auf dem aktuellsten Stand mit einem proprietären NVidia Grafiktreiber.
    Edit: Im Computer ist eine Hybrid-Grafikkarte (Geforce 1060) verbaut.
    Edit Edit: Der Modus der Grafikkarte war zum Zeitpunkt des Protokolls "Discrete", also getrennt. Habe jetzt im UEFI auf "MSHybrid" umgestellt, was dazu führt dass ich bei korrekter Passwort-Eingabe wieder auf den Anmeldebildschirm geworfen werde* (es gibt also einen Unterschied zwischen den beiden Modi).
    *und zwar bei allen möglichen Varianten, also sowohl Gnome als auch z. B. ICE WM. Wähle ich den Discreet-Modus, so kann ich mich in ICE WM grafisch einloggen.
    Dateien
    • 48285686.txt

      (346,87 kB, 3 mal heruntergeladen, zuletzt: )

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von elranjit () aus folgendem Grund: Wichtiges Grafikkarten-Detail eingefügt.

    Für den Inhalt des Beitrages 132830 haftet ausdrücklich der jeweilige Autor: elranjit

  • Könnte an deiner Nvidia-Karte bzw. an deren Treiber liegen.
    Falls diese Datei bei dir vorhanden ist, könntest du deren Inhalt bitte einmal posten mit:

    Quellcode

    1. cat /etc/gdm3/custom.conf
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 132832 haftet ausdrücklich der jeweilige Autor: sterun

  • sterun schrieb:

    Falls diese Datei bei dir vorhanden ist
    Dem ist tatsächlich nicht so.
    Hätte eine /etc/gdm/custom.conf im Angebot.

    Quellcode

    1. elranjit@linux-z088:~> cat /etc/gdm/custom.conf
    2. # GDM configuration storage
    3. #
    4. # Note: settings from /etc/sysconfig/displaymanager have a higher priority
    5. #
    6. [daemon]
    7. # Uncoment the line below to force the login screen to use Xorg
    8. #WaylandEnable=false
    9. [security]
    10. [xdmcp]
    11. [chooser]
    12. [debug]
    13. # Uncomment the line below to turn on debugging
    14. #Enable=true
    Alles anzeigen

    Für den Inhalt des Beitrages 132835 haftet ausdrücklich der jeweilige Autor: elranjit

  • Zum Zeitpunkt des Protokolls war zwar ein externer Monitor angesteckt aber ausgeschalten (also ganz aus, nicht nur Standby). Falls das einen Unterschied zu "nein" macht.

    Für den Inhalt des Beitrages 132846 haftet ausdrücklich der jeweilige Autor: elranjit

  • Brainfuck-Quellcode

    1. elranjit@linux-z088:~> zypper lr -d
    2. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    3. --+----------------------------------------+---------------------------------+-----------+-----------------+----------------+-----------+--------+---------------------------------------------------------------------------+-------
    4. 1 | download.nvidia.com-tumbleweed | nVidia Graphics Drivers | Ja | (r ) Ja | Ja | 99 | rpm-md | https://download.nvidia.com/opensuse/tumbleweed |
    5. 2 | isv_TUXEDO | isv:TUXEDO (openSUSE_Leap_15.0) | Ja | (r ) Ja | Nein | 99 | rpm-md | http://download.opensuse.org/repositories/isv:/TUXEDO/openSUSE_Leap_15.0/ |
    6. 3 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/ |
    7. 4 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository | Ja | (r ) Ja | Ja | 20 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/ |
    8. 5 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
    9. 6 | repo-nvidia-tuxedo | TUXEDO Computers - 15.0 NVIDIA | Ja | (r ) Ja | Ja | 99 | rpm-md | http://nvidia.tuxedocomputers.com/opensuse/15.0 |
    10. 7 | repo-oss | openSUSE-Tumbleweed-Oss | Ja | (r ) Ja | Ja | 70 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
    11. 8 | repo-update | openSUSE-Tumbleweed-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/
    Alles anzeigen

    Für den Inhalt des Beitrages 132864 haftet ausdrücklich der jeweilige Autor: elranjit