openSuse 11.3 und Nvidia-Treiber

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema openSuse 11.3 und Nvidia-Treiber gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • openSuse 11.3 und Nvidia-Treiber

    Nach einem Update von openSuse 11.2 auf 11.3 musste ich leider Feststellen das der neuste Nvidia-Treiber (260.19.12)
    einfach nicht zum laufen zu kriegen ist und der ältere Treiber (256.35) welcher auch unter 11.3 Tadellos läuft
    nicht über die Repo's zu Installieren ist,muss man diesen von "Hand" Installieren.

    ACHTUNG:Wenn es Probleme bei der Installation gibt sollte man entweder einige Grundkenntnisse in der Shell haben oder eine Möglichkeit haben sich Hilfe im Forum zu holen!!

    Als erstes ladet euch den Treiber von Nvidia herunter
    und macht ihn Ausführbar (Rechtsklick-->Eigenschaften-->Berechtigungen).

    Öffnet jetzt Yast und geht auf
    System --> Editor für Sysconfig

    hier geht ihr jetzt auf
    System --> Kernel --> NO_KMS_IN_INITRD

    und stellt den Wert (wenn noch nicht vorhanden) auf Yes


    Danach gehts (auch wieder in Yast) nach
    System --> Bootloader

    und geht hier auf Bearbeiten und fügt unter Optionaler Parameter für Kernel-Befehlszeile folgende
    Zeile ein (getrennt von den anderen Befehlen mit einem Leerzeichen!!)
    nouveau.modeset=0



    Jetzt Öffnen wir mit einem Texteditor (z.b. Kwrite) die Datei (mit root Rechten!!)
    /etc/modprobe.d/50-blacklist.conf

    und fügen am Ende folgenden Eintag an
    blacklist nouveau

    und Speichert ab.

    Startet jetzt den Rechner neu und gebt als Bootparameter in Grub
    init 3

    ein.Logt euch ein und erlangt mittels su root Rechte.
    Wechselt jetzt (nur nötig wenn der Treiber nicht direkt im Home Verzeichnis liegt!) mit
    cd Verzeichnis/wo der Treiber/liegt

    in das entsprechende Verzeichnis.Danach einfach
    ./NVIDIA-Linux-x86-256.35.run (bzw. den Treiber den ihr habt)

    eingeben und einfach den Anweisungen folgen und auch eine xorg.conf Erstellen lassen.

    Ich habe eine geschlagene Woche (umsonst!!) versucht den neuen Nvidia Treiber zum laufen zu kriegen......
    aber den alten Treiber zum laufen zu kriegen hat mich keine Stunde gekostet :smilie_pc_012:

    Für den Inhalt des Beitrages 25774 haftet ausdrücklich der jeweilige Autor: D_Dau

  • Hallo D_Dau,

    Vielen Dank für die Anleitung!

    Selber habe ich den 256 NVidia Driver schon mehrmals im Runlevel 3 installiert:

    -----
    Falls noch nicht vorhanden: zuerst die notwendigen Tools installieren: kernel headers (kernel-devel), gcc und make.

    Mit YaST, oder zypper:

    # zypper in gcc make kernel-devel
    -----

    Runlevel 3, als root, dann:

    # cd <wo das NVidia Script ist>
    # sh NVIDIA-Linux-x86-256.53.run
    ...
    # switch2nvidia

    Dann mache ich hier ein:

    # shutdown -r now

    und alles ist gut :)

    Gruss,
    Roland

    Nachtrag:
    Wenn mit der Grafik etwas wirklich schief geht -- nur noch Text Modus -- dann ist die YaST Methode wohl für die meisten User (oder alle?) unzumutbar... :)

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von rme ()

    Für den Inhalt des Beitrages 25783 haftet ausdrücklich der jeweilige Autor: rme

  • Mal ganz abgesehen welches die einfache oder bessere Methode sein könnte:

    Ich habe bisher auch jeden Update Zirkus mit Grafik Treibern mitgemacht.

    Mein Fazit: Ich habe noch niemals nie einen Unterschied bemerkt zwischen den propritären NVIDIA Treiber der Suse 9.0 oder dem jetzigen.
    Man braucht den Quatsch nicht. Der Rechner läuft und ihr solltet wirklich mal still verharren und Euch Euren Update Wahn genauer betrachten.

    Installiert Euch eine funktionierende Suse, richtet sie ein mit aller Software die ihr so zum Arbeiten braucht und deinstalliert die Yast Softwareverwaltung.
    Das würde ich als Distributionsersteller schon per default machen, denn was die Leute mit ihrem Linux System ständig machen kann man nur noch als irre bezeichnen.

    Für den Inhalt des Beitrages 25790 haftet ausdrücklich der jeweilige Autor: thomas23

  • Hi

    Das Kernel Mode Setting ist per Default eh nicht Aktiv und das Blacklisten von Nouveau ist eigentlich
    nur zur Sicherheit,da es ansonsten Schwierigkeiten geben kann.

    thomas23 schrieb:

    ...nie einen Unterschied bemerkt zwischen den propritären NVIDIA Treiber der Suse 9.0 oder dem jetzigen.


    Dem muss ich leider Widersprechen.Bei mir war der Nouveau Treiber (jedenfalls bei meiner Hardware) nicht zu gebrauchen.
    Die gesamte Grafische Darstellung war teilweise Verzerrt (Vorschaubilder im Dolphin) und extremen Ruckeln bzw. langsamer
    Reaktion (ein Scrollen in Dolphin oder im Firefox wurden zum Geduldsspiel) unterworfen.

    Mit dem Proprietären Treiber von Nvidia läuft alles wieder Reibungslos.

    Für den Inhalt des Beitrages 25821 haftet ausdrücklich der jeweilige Autor: D_Dau

  • Dem muss ich leider Widersprechen.


    Ich meine ja auch das ständige updaten des propritären Treibers.

    Zumindest bei mir hat noch kein neuer Treiber (propritär) siknifikant etwas an der Grafikleistung geändert oder verbessert.
    Mein erster propritärer war 3D-fähig und alle Nachfolger waren es auch. :D

    Für den Inhalt des Beitrages 25825 haftet ausdrücklich der jeweilige Autor: thomas23

  • Hallo openSuse-Community,

    danke D_Dau. Durch deine Anleitung hab ich es nun erfolgreich geschafft :)

    Mir fehlten nur genau die ersten beiden Schritte der Installation, den Rest hab ich selbst hinbekommen.
    Für mich war die Installation ein bisschen aufwendiger, weil ich openSuse mit Gnome nutze. Mir fehlten einige, wichtige Pakete ala kernel-devices, gcc und make.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Vize ()

    Für den Inhalt des Beitrages 25963 haftet ausdrücklich der jeweilige Autor: Vize

  • thomas23 schrieb:

    Ich meine ja auch das ständige updaten des propritären Treibers.

    Das mache ich normalerweise auch nicht.Allerdings habe ich einmal mit Zypper dup einen Wechsel von
    11.2 auf 11.3 ausprobiert.Und obwohl das Nvidia Repo Deaktiviert war wurde hierbei
    der neuste Treiber Installiert ?(
    Darum leider auch der ganze Aufwand :smilie_pc_012:

    Für den Inhalt des Beitrages 25988 haftet ausdrücklich der jeweilige Autor: D_Dau

  • Alos bis hirhin habe ich das hinbekommen aber weiter verstehe ich das nicht.

    .....
    und Speichert ab.

    Startet jetzt den Rechner neu und gebt als Bootparameter in Grub



    Zitat


    init 3

    ein.Logt euch ein und erlangt mittels su root Rechte.
    Wechselt jetzt (nur nötig wenn der Treiber nicht direkt im Home Verzeichnis liegt!) mit



    Zitat


    cd Verzeichnis/wo der Treiber/liegt

    in das entsprechende Verzeichnis.Danach einfach



    Zitat


    ./NVIDIA-Linux-x86-256.35.run (bzw. den Treiber den ihr habt)

    eingeben und einfach den Anweisungen folgen und auch eine xorg.conf Erstellen lassen.

    Ich habe eine geschlagene Woche (umsonst!!) versucht den neuen Nvidia Treiber zum laufen zu kriegen......
    aber den alten Treiber zum laufen zu kriegen hat mich keine Stunde gekostet :smilie_pc_012:

    Für den Inhalt des Beitrages 26084 haftet ausdrücklich der jeweilige Autor: ManuelBDW

  • ----- Zitat -----
    Alos bis hirhin habe ich das hinbekommen aber weiter verstehe ich das nicht.
    --- Ende Zitat ---

    ----- Zitat -----
    Startet jetzt den Rechner neu und gebt als Bootparameter in Grub
    --- Ende Zitat ---

    Gruss,
    Roland
    Bilder
    • 11_3_boot_splash.png

      86,71 kB, 550×412, 46 mal angesehen

    Für den Inhalt des Beitrages 26087 haftet ausdrücklich der jeweilige Autor: rme