Mit Pin-gesichertem Netzwerk-Drucker verbinden

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Mit Pin-gesichertem Netzwerk-Drucker verbinden gibt es 6 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Mit Pin-gesichertem Netzwerk-Drucker verbinden

    Guten Tag,

    ich möchte unter Leap 15.0 einen Netzwerk-Drucker (Konica Minolta, bizhup C458) einrichten. Ich habe die passende ppd-Datei runtergeladen und installiert und in Yast über die IP-Adresse den Drucker eingetragen. Um auf dem Drucker irgendwas machen zu können, muss man einen PIN eingeben (ohne Nutzername). Nun ist es so, dass die Windows-Nutzer hier beim Drucken ein Fensterchen kriegen, das sie nach besagtem PIN fragt. Dieses erscheint bei mir jedoch nicht, meine Druckaufträge verschwinden instantan von der Druckerliste, ohne Fehlermeldung. Was muss ich tun, damit ich auch jedes Mal beim Drucken ein solches Login-Fenster kriege? Ich will den PIN auch nicht speichern, weil wir zwei unterschiedliche PINs mit jeweils anderem Abrechnungskonto zur Verfügung haben.

    Der entsprechende Eintrag aus /etc/cups/printers.conf: (IP-Adresse maskiert)

    Quellcode

    1. <Printer Konika_Minolta>
    2. UUID urn:uuid:7c2fcd88-3969-37a3-6f5a-e37fe1295fd8
    3. Info Kinoca Minolta
    4. Location 0.111
    5. MakeModel KONICA MINOLTA C759SeriesPS(P)
    6. DeviceURI socket://IP.IP.IP.IP:9100
    7. State Idle
    8. StateTime 1561024549
    9. ConfigTime 1561022483
    10. Type 8401100
    11. Accepting Yes
    12. Shared Yes
    13. JobSheets none none
    14. QuotaPeriod 0
    15. PageLimit 0
    16. KLimit 0
    17. OpPolicy default
    18. ErrorPolicy retry-job
    19. Attribute marker-colors \#00FFFF,#FF00FF,#FFFF00,#000000,#00FFFF,#00FFFF,#FF00FF,#FF00FF,#FFFF00,#FFFF00,#000000,#000000,none,none,none,none,none,none
    20. Attribute marker-levels 72,78,76,46,86,98,86,98,86,98,52,89,-1,89,78,87,84,-1
    21. Attribute marker-names Toner (Cyan),Toner (Magenta),Toner (Yellow),Toner (Black),Drum Cartridge (Cyan),Developer Cartridge (Cyan),Drum Cartridge (Magenta),Developer Cartridge (Magenta),Drum Cartridge (Yellow),Developer Cartridge (Yellow),Drum Cartridge (Black),Developer Cartridge (Black),Waste Toner Box,Fusing Unit,Image Transfer Belt Unit,Transfer Roller Unit,Toner Filter,Staple Cartridge
    22. Attribute marker-types toner,toner,toner,toner,opc,developer,opc,developer,opc,developer,opc,developer,waste-toner,fuser,transfer-unit,transfer-unit,cleaner-unit,staples
    23. Attribute marker-change-time 1561024549
    24. </Printer>
    Alles anzeigen

    Bitte sagt Bescheid, welche weiteren Informationen ihr braucht. Ich hab leider keinerlei hilfreiche Treffer ergoogeln können (vlt. hab ich die falschen Begriffe verwendet), und bin für jede Hilfe dankbar.

    Grüße, Eldrad

    Für den Inhalt des Beitrages 133884 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Danke für den Link, aber ich verstehe da noch nicht alles, gerade die kryptischen Optionen des lp-Befehls. Wenn ich es richtig verstehe, kann mit mit lp -o nicht nur allgemeine lp-Optionen, sondern auch druckerspezifische Optionen angeben, richtig? Und eigentlich müsste man auch mit lpoptions -p Konica_Minolta alle Druckeroptionen finden, oder?
    Wenn ich lpoptions eingebe, ist die Liste aber definitiv nicht komplett, es fehlen zahlreiche Optionen, die ich z.B. über CUPS einstellen kann. Die im Blog erwähnten Optionen, die mit JCLKM anfangen, tauchen bei mir in der Liste auch nicht auf.

    Für den Inhalt des Beitrages 133978 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Moin zusammen,

    Eldrad der Link ist zwar ganz nett, für Deine Zwecke aber unpassend.
    Ich muss mich derzeit auch mit diesem Problem rumschlagen und im Web habe ich bis dato absolut nichts Hilfreiches gefunden wie man Cups oder den lpd dazu bekommt, einen PIN zu akzeptieren/abzufragen.

    Das scheint in der Linuxwelt leider nicht Usus zu sein, dass man nicht Hinz und Kunz auf nem Drucker drucken lässt, sondern einen Pin noch abfragt _zusätzlich_ zur Authentifizierung mit User und Passwort.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 134007 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Moin zusammen,

    Eldrad ich habe gestern noch an dem Problem getüftelt. Fazit: Du musst den richtigen Druckertreiber installieren, der explizit die Funktion PIN als Druckoption bereitstellt.
    Diese kann nach dem Installieren dann in den Druckoptionen ausgewählt werden im Cups.

    Zwingend hierzu erforderlich ist aber ein Druckertreiber, der die Funktion auch anbietet.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 134020 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Tamerlain schrieb:

    Moin zusammen,

    Eldrad ich habe gestern noch an dem Problem getüftelt. Fazit: Du musst den richtigen Druckertreiber installieren, der explizit die Funktion PIN als Druckoption bereitstellt.
    Diese kann nach dem Installieren dann in den Druckoptionen ausgewählt werden im Cups.

    Zwingend hierzu erforderlich ist aber ein Druckertreiber, der die Funktion auch anbietet.
    Guten Morgen,

    mehr als die korrekte ppd-Datei von der Herstellerseite kann ich aber nicht installieren, oder? Alle anderen zahlreichen Funktionen des Druckers (Falten, Lochen, Tackern und was weiß ich noch alles) werden mir korrekt angezeigt.
    Bei uns ist der Drucker so eingerichtet, dass er ausschließlich nach einem Pin fragt, ohne Nutzername oder Passwort.

    Für den Inhalt des Beitrages 134038 haftet ausdrücklich der jeweilige Autor: Eldrad Ulthran

  • Moin zusammen,

    Eldrad unserer auch. Ich könnte über den Printserver gehen mit Samba, aber macht absolut keinen Sinn.
    Ich gehe direkt auf unseren Netzwerkdrucker mit dem Pin. Der Treiber muss dieses Feature aber anbieten, sonst geht es nicht.

    Wenn er dieses Feature anbietet, ist es in der CUPS Oberfläche in den Druckoptionen vermerkt (Häkchen setzen bei PIN Verwendung zulassen) und in der nächsten Lasche dann den in der Regel 5stelligen Pin Code eingeben.

    Also wenn du den Drucker samt Treiber eingerichtet hast, gehst Du auf den Drucker, dann --> Administration --> set default options
    Wenn dort keine Lasche Printing Modes mit der Auswahl Department code Disabled Enabled steht, hast Du verloren.

    Ggf. bei dem Drucker Hersteller im Support nachfragen (lassen) ob der Drucker, den Ihr verwendet einen entsprechenden Linux Treiber hat und ggf. nach einem Einrichtungshandbuch für die verschiedenen Clients fragen.
    Viele Grüße,
    T.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Tamerlain ()

    Für den Inhalt des Beitrages 134040 haftet ausdrücklich der jeweilige Autor: Tamerlain