es starten Apps nicht wie z.B.:Firefox

Hinweis: In dem Thema es starten Apps nicht wie z.B.:Firefox gibt es 34 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo Leute :)


    Ich habe gestern das System aktualisiert, und viel Programme installiert.


    Heute starten viel Programme nicht mehr, wie zum Beispiel Firefox (alle installierte Webbrowser starten nicht). :smilie_pc_057:


    Per Konsole kommt folgende Meldungen:


    Es scheinen störende Dateien vorhanden zu sein.



    Hoffentlich kann mir hier Jemand helfen.


    Schon Mal Dank für Eure Mühe.


    Wooty :)



  • Dann poste bitte in Codetags ...

    Code
    zypper lr -d
    Code
    uname -a
    Code
    /sbin/lspci -nnk | grep -iA3 vga
  • Moin zusammen,


    Wooty, warum schaust Du nicht einfach mal nach ob libpango-1.0.so. im System überhaupt vorhanden ist? Das ist doch das Allererste und Einfachste was man auf dem Wege des Debugging tun kann.


    Übliche verdächtige Verzeichnisse für Libraries wären


    Code
    /lib, /lib64, /usr/lib,/lib64

    dort dann mit find nach dem pango suchen.



    Alternativ

    Code
    zypper se pango

    Da sollte bei libpango-1_0-0 mindestens ein i davor stehen.


    Ich vermute, dass Du den pango nicht oder nicht sauber installiert hast und daraus alle nachgelagerten Browserprobleme resultieren.

    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 134214 haftet ausdrücklich der jeweilige Autor: Tamerlain


  • @ Tamerlain



    libpango-1.0.so ist vorhanden im Ordner /lib64/

  • @ Alero







    Code
    wootsdock@linux-xsrm:~> uname -a
    Linux linux-xsrm 5.1.15-1-default #1 SMP Tue Jul 2 10:39:52 UTC 2019 (cb24bc9) x86_64 x86_64 x86_64 GNU/Linux



    Code
    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Sumo [Radeon HD 6520G] [1002:9647]
    DeviceName: AMD Radeon(TM) HD 6520G
    Subsystem: Hewlett-Packard Company Device [103c:3567]
    Kernel driver in use: radeon
    --
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] [1002:6760]
    DeviceName: AMD Radeon HD 6470M
    Subsystem: Hewlett-Packard Company Radeon HD 6470M [103c:3567]
    Kernel driver in use: radeon



    Vielen Dank für Eure Antworten


    Wooty

  • Das ist mal wieder der Klassiker: gemischte Repositories.


    Neben den Leap 15.0 Repositories tummeln sich da noch

    • eines aus Factory (Nummer 1)
    • eines aus Tumbleweed (Nummer 2)
    • und eines auf Leap 15.1 (Nummer 3)

    Das kann nicht zusammenpassen. Nummer 2 und 3 müssen definitiv raus, bzw. durch die passenden Alternativen für Leap 15.0 ersetzt werden. Was widehat ist? Ich hab keine Ahnung, aber das können dir hier sicher noch andere sagen, was du mit diesem Repository machen sollst, aber Factory passt sicher auch nicht. Ich hätte da lieber sowas wie https://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_15.0/ genommen.

  • Code
    1 | gnome-apps | gnome-apps | Ja | ( p) Ja | Nein | 99 | NONE | http://widehat.opensuse.org/opensuse/repositories/GNOME:/Apps/openSUSE_Factory/
    |2 | http-download.opensuse.org-42093fc6 | openSUSE:Factory | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/
    |3 | http-download.opensuse.org-aa0427b3 | home:ecsos | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/home:/ecsos/openSUSE_Leap_15.1/

    Naja, da kannst du an libs weiter basteln bis du blau wirst, besser wäre es, die Repos rauszuwerfen und ein


    Code
    zypper dup --allow-vendor-change

    zu machen.



    Dann wärest du wieder bei Leap 15.0 und nicht bei einem Mischmasch aus Leap 15.0, Leap 15.1 und Tumbleweed.......

  • Ok Repos müssen raus.


    Hier in Screenshot von Dicover (ander wie Yast starten nicht).


    Welchen müssen jetzt weg?


    Ich wiess net wie ich zum Tumbleweed gekommen bin?! Leap 15.1 habe beim installieren von software vermutlich aktiviert.




    gnome-apps muss weg


    und


    Leap 15.0.1 muss auch weg


    Ist dieses richtig? Muss noch was anderes weg?



    Danke für Eure Mühe.


    p.s.: Ich komme von Ubuntu und bin bei openSuse noch ein voller Neuling. Linux ist nicht Linux Hochmütig dachte ich das mache ich mit links 8o LOOOOOL

  • mach es als root (su -l nicht sudo) per zypper:

    Code
    zypper rr 1 2 3


    Danach:


    Code
    zypper dup --allow-vendor-change


    Und discover ist eh fehleranfällig, würde ich nicht benutzen, lieber zypper oder yast.....
    Wobei yast auch noch als ncurses Version funktionieren sollte........


    PS:
    Niemand hat irgendwas installiert, niemand hat hier hingelangt, die Repos sind alle automatisch eingeflogen......