Thunderbird kann nach Neuinstallation nicht mehr auf alte Emails zugreifen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Thunderbird kann nach Neuinstallation nicht mehr auf alte Emails zugreifen gibt es 12 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Wie ein Thunderbird-Backup zurück kopiert wird, ist ja bekannt und wurde hier auch noch mal beschrieben.
    Allerdings kann es auch sein, dass Dateien, beim Erstellen des Backups, beschädigt wurden.
    Aus diesem Grund bietet Thunderbird eine Raparatur-Funktion, welche hier näher erklärt wird:
    Index-Datei reparieren - Thunderbird Mail DE
    Vielleicht hilft es :)
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 134711 haftet ausdrücklich der jeweilige Autor: sterun

  • sterun schrieb:

    Allerdings kann es auch sein, dass Dateien, beim Erstellen des Backups, beschädigt wurden.
    Aus diesem Grund bietet Thunderbird eine Raparatur-Funktion, welche hier näher erklärt wird:
    Index-Datei reparieren - Thunderbird Mail DE
    Vielleicht hilft es :)
    Das ist richtig.
    Allerdings glaube ich nicht, dass die Index-Datei einen Fehler hat, denn

    DistroDesaster schrieb:

    Nun hat Thunderbird aber keine meiner alten Email Konten erkannt bzw es wird gar nichts mehr davon angezeigt.
    auch die Konten an sich sind ja nicht vorhanden.
    Meine Vermutung von Anfang an: Sie sind vorhanden, DistroDesaster arbeitet aber mit dem neu erstellten Profil und nicht mit dem Profil des Backups.

    Ich frage mich nur, warum er es nicht wenigstens mal ausprobieren will und das neu erstellte Profil einfach mal löscht oder meinetwegen umbenennt.
    Thunderbird ist ja auf dem System neu aufgesetzt und beinhaltet damit keine aufbewahrungswürdigen Daten!

    Das Ausprobieren mit dem .thunderbird aus dem Backup wäre bestimmt schneller gegangen als Virtualbox, Ubuntu und Windows 7 zu installieren.




    Das Backup selber scheint auch in Ordnung zu sein, da:

    DistroDesaster schrieb:

    KMail findet auch den Thunderbird Ordner und die ganzen Email Konten und kann auch Sachen importieren.

    Für den Inhalt des Beitrages 134715 haftet ausdrücklich der jeweilige Autor: win2linux

  • caroline schrieb:

    Einfach in den .Thunderbird Ordner die ***.default Datei kopieren, umbenennen in den Namen den Mozilla auf dem NeuSystem erstellt.
    dabei nicht vergessen: .parentlock löschen. Sonst geht es nicht. Diese Datei wird beim Starten neu erstellt.
    Ist auf allen Betriebssystemen bei den Mozillaprogrammen so. Also auch beim Füchslein!!

    Wie schon gesagt, wo die Profilordner sind und wie man sie kopiert weiß ich ja :)
    Hat auch immer reibungslos funktioniert.

    Nur dieses Mal funktioniert es nicht.
    Da ich es auf verschiedenen OS versucht habe scheint beim Backup was schief gegangen zu sein.

    Ich habe dann mal weiter geforscht und have bemerkt daß im Backup Ordner vom Thunderbird Profil keine prefs.js vorhanden war.
    Hab also die prefs-8.js einfach in prefs.js umbenannt und schon wurden alle Email Konten wieder angezeigt.

    caroline schrieb:

    Das ganze mit "User"-Rechten !! Kann es sein, das Du zuviel mit "Root" -Rechten arbeitest?
    Nein, arbeite ansich gar nicht mir Root Rechten.
    Halt nur wenn es sein muss, zum Beispiel beim Software installieren.
    Ansonsten nur mit User Rechten.

    Sauerland schrieb:

    Normalerweise sollte man zum Speichern von Linux Dateien auch Dateisysteme nehmen, die Rechteverwaltung unterstützen.
    Ja, da magst Du wohl recht haben.
    Hab damals NTFS genommen fall ich auch mal von Windows darauf zugreifen muss.
    Hatte auch nie drüber nachgedacht daß es mal wichtig sein könnte mit den Nutzerrechten.

    Bis jetzt :whistling:
    Auch wenn die ganzen Emailkonten jetzt wieder vorhanden sind fuktionieren die ganzen Filter nicht mehr.

    Thunderbird Meldung schrieb:

    Die Nachricht konnte nicht in den Ordner "KlickStuffer" gefiltert werden, weil das Schreiben in diesen Ordner fehlgeschlagen ist. Stellen Sie sicher, dass Sie genug Speicherplatz und Schreibberechtigungen auf dem Dateisystem haben, und probieren Sie es nochmals
    Ich denke mal das hat mit der Rechteverwaltung zu tun.

    Naja, die Emailkonten sind wieder vorhanden.
    Das ist schon mal gut, jetzt werde ich mich mal schlau machen wie ich das mit den Rechten hinbekomme.

    win2linux schrieb:

    Hast du es wenigstens mal probiert, /home/user/.thunderbird zu löschen und dann einfach dieses aus dem Backup zurückzuspielen?
    Ja habe ich probiert.
    Ich habe den .thunderbird Ordner gelöscht und den aus dem Backup rüberkopiert, ich habe den Inhalt des neuen Profils gelöscht und den Inhalt des alten Profils rüberkopiert, ich habe den alten Profilordner rüberkopiert und den Eintrag in der profiles.ini angepasst.

    Das hätte für sich auch alles funktioniert, der Fehler war halt wie oben geschrieben die fehlende prefs.js :)

    win2linux schrieb:

    Welchen Sinn hat es, Programme erst zu konfigurieren, um dann das Backup "rüberzukopieren" (was immer das heißen mag)?
    Hab die Programme installiert, nicht konfiguriert.
    Und rüberkopieren = von einer Location (externe Platte wo das Backup ist) auf eine andere Location (Desktop mit der Opensuse Installation) rüberkopieren ;)

    win2linux schrieb:

    Meine Vermutung von Anfang an: Sie sind vorhanden, DistroDesaster arbeitet aber mit dem neu erstellten Profil und nicht mit dem Profil des Backups.
    Nein, ich habe von Anfang an NICHT mit dem neu erstellten Profil gearbeitet.
    Da kann ja logischerweise nichts von meinen Daten vorhanden sein da neuerstellt.

    win2linux schrieb:

    Ich frage mich nur, warum er es nicht wenigstens mal ausprobieren will und das neu erstellte Profil einfach mal löscht oder meinetwegen umbenennt.
    Thunderbird ist ja auf dem System neu aufgesetzt und beinhaltet damit keine aufbewahrungswürdigen Daten!


    Das Ausprobieren mit dem .thunderbird aus dem Backup wäre bestimmt schneller gegangen als Virtualbox, Ubuntu und Windows 7 zu installieren.
    Hat er doch schon ganz am Anfang ausprobiert bevor er den Thread eröffnet hat.
    Bin ja die naheliegensten Sachen erst durch gegangen.

    Nachdem aber alle ausprobierten Sachen keinen Erfolg gebracht haben habe ich es halt mit anderen Betriebssystemen probiert.

    Naja, wie gesagt sind alle Konten wieder da und ich mach mich schlau über die Rechtevergabe damit die Filter wieder funktionieren.

    Bei Chromium sind auch meine ganzen gespeicherten Passwörter nicht mehr vorhanden, da werd ich also auch mal nachforschen :)

    Für den Inhalt des Beitrages 134716 haftet ausdrücklich der jeweilige Autor: DistroDesaster