cifs als user

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema cifs als user gibt es 14 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • cifs als user

    Seit einer Ewigkeit mounte ich einen an der Fritzbox angeschlossenen Stick in mein Home.

    Die /etc/fstab sieht dementsprechend so aus:

    Quellcode

    1. //192.168.2.1/Freigabe/ /home/USER/FritzBox cifs vers=1.0,credentials=/home/USER/.smbcredentials,noauto,user,soft,noserverino,uid=1000,gid=1000 0 0




    Seit neuem ergibt ein


    Quellcode

    1. USER@Desktop:~> mount /home/USER/FritzBox/
    2. free(): double free detected in tcache 2
    3. Child process terminated abnormally.
    4. USER@Desktop:~>


    Allerdings funktioniert:

    Quellcode

    1. sudo mount /home/USER/FritzBox/
    problemlos!

    Weiß jemand, warum das neuerdings so ist?
    Ich möchte den Stick nicht ständig eingebunden haben, sondern ihn nur bei Bedarf als User mounten!



    Vielleicht hilft wieder einfach nur warten und Tee trinken (Tumbleweed). ;)
    Vielleicht kann man aber auch irgendwas drehen....... ;)



    _______________

    PS:

    Quellcode

    1. sudo chmod +s /sbin/mount.cifs
    habe ich ausgeführt!

    Für den Inhalt des Beitrages 135543 haftet ausdrücklich der jeweilige Autor: win2linux

  • Bei mir das selbe Problem... OpenSuse Tumbleweed (aktueller Stand 3.9.2019)...
    Ich kann mit sudo die mounts einbinden aber nicht als Benutzer (selbe Fehlermeldung wie bei "win2linux".

    Für den Inhalt des Beitrages 135552 haftet ausdrücklich der jeweilige Autor: alfaflo

  • Hallo zusammen,

    das ist eine Sicherheitseinstellung!
    /sbin/mount.cifs hat aus Sicherheitsgründen nicht das SUID root flag gesetzt. Damit ist der Mount als normaler User mit normalen Rechten untersagt --> und das ist auch gut so.

    Was hindert Euch, sudo zu nutzen und ein kleines mountscript zu schreiben und Euch in der sudoers für justament DIESEN Mount für euren User das NOPASSWD Recht zu setzen?

    Hab ich auf meinem SuSE justament so gemacht und das tutet einwandfrei. Ein kleiner cronjob unter meinem User checkt ob das Share gemountet ist, wenn nein --> mountscript und gut is.

    Für den Boot ein systemd Script schreiben was das Share nach dem Boot automatisch mounted mit den entsprechenden Rechten dass der User drauf zugreifen darf.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 135556 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Tamerlain schrieb:

    das ist eine Sicherheitseinstellung!
    /sbin/mount.cifs hat aus Sicherheitsgründen nicht das SUID root flag gesetzt.
    Ich weiß. Deshalb wies ich ja im ersten Post darauf hin, dass ich dieses Bit gesetzt habe.
    Bis vor kurzem hat es auch funktioniert. Jetzt nicht mehr.

    Tamerlain schrieb:

    --> und das ist auch gut so.
    Mag sein. Bestimmt ist das so!
    In meinem Fall habe ich aber keine große Gefahr gesehen.

    Aber gut,
    ich habe nun mein kleines Script (das ich eh schon hatte, damit die Freigabe erst gemountet wird, nachdem das Wlan steht) in die /etc/sudors eingetragen.

    Fazit: Geht wieder. Danke.

    Für den Inhalt des Beitrages 135558 haftet ausdrücklich der jeweilige Autor: win2linux

  • Hallo,

    ich habe bisher von einem NAS diverse Laufwerke über CIFS gemountet. Dazu habe ich in der fstab die Shares mit der Option "noauto" angelegt, z.B.:

    Quellcode

    1. //diskstation/home /home/florian/Diskstation cifs vers=3.0,user,credentials=/home/florian/.smbcredentials,noauto 0 0

    Gemounted wird dann mittels Shell-Skript nach dem Start von KDE:

    Shell-Script

    1. #! /bin/sh
    2. #
    3. mount /home/florian/Diskstation
    Führe ich den mount jetzt mit sudo aus, habe ich kein Schreibrecht mehr als "normaler" Benutzer im gemounteten Verzeichnis... Einen Tipp, was ich da falsch mache?


    Gruß
    Florian

    Für den Inhalt des Beitrages 135581 haftet ausdrücklich der jeweilige Autor: alfaflo

  • alfaflo schrieb:

    Hallo,

    ich habe bisher von einem NAS diverse Laufwerke über CIFS gemountet. Dazu habe ich in der fstab die Shares mit der Option "noauto" angelegt, z.B.:

    Quellcode

    1. //diskstation/home /home/florian/Diskstation cifs vers=3.0,user,credentials=/home/florian/.smbcredentials,noauto 0 0
    Gemounted wird dann mittels Shell-Skript nach dem Start von KDE:

    Shell-Script

    1. #! /bin/sh
    2. #
    3. mount /home/florian/Diskstation
    Führe ich den mount jetzt mit sudo aus, habe ich kein Schreibrecht mehr als "normaler" Benutzer im gemounteten Verzeichnis... Einen Tipp, was ich da falsch mache?


    Gruß
    Florian
    Anderes Problem, neuer Beitrag.

    Bitte keine Beiträge kapern.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 135582 haftet ausdrücklich der jeweilige Autor: Sauerland

  • alfaflo schrieb:

    Führe ich den mount jetzt mit sudo aus, habe ich kein Schreibrecht mehr als "normaler" Benutzer im gemounteten Verzeichnis... Einen Tipp, was ich da falsch mache?
    Du mountest jetzt als root, also gehören die Dateien/Verzeichnisse auch root.

    Gib mal in der fstab die "uid" (setzt den Eigentümer) und die "gid" (setzt die Gruppen) mit.

    Siehe mein Beispiel oben im Post 1: "uid=1000,gid=1000"

    In der Konsole kannst du mit

    Quellcode

    1. id
    die passende uid und gid herausfinden.

    Für den Inhalt des Beitrages 135583 haftet ausdrücklich der jeweilige Autor: win2linux

  • Sauerland schrieb:

    Anderes Problem, neuer Beitrag.

    Bitte keine Beiträge kapern.
    Stimmt!

    @alaflo
    Schreib einen eigenen (neuen) Beitrag, dort kann dir sicher jemand besser helfen / das Problem besser erklären, als ich das als Anfänger kann!

    Für den Inhalt des Beitrages 135584 haftet ausdrücklich der jeweilige Autor: win2linux

  • Kapern war nicht meine Absicht - Mein "Problem" bzw. die Ursache ist ja das selbe wie bei "win2linux":

    Quellcode

    1. sudo chmod +s /sbin/mount.cifs
    funktioniert nicht mehr - vor ein paar Tagen konnte ich mein NAS noch als Benutzer mounten. Dolphin hat das sogar selbst erledigt (zeigt ja anscheinend die fstab Einträge an), wenn die Laufwerke beim anmelden nicht verfügbar waren.
    Jetzt muss ich mit "sudo" basteln und verliere noch dazu den "Komfort" das Dolphin "selbst mounted".

    Trotzdem Danke.

    Für den Inhalt des Beitrages 135585 haftet ausdrücklich der jeweilige Autor: alfaflo

  • Moin zusammen,

    was ist daran so schwer, dem Mountbefehl einen uid=<uid Deines Users>, gid=<gid Deines Users> mitzugeben und das Script dann per cron laufen zu lassen?
    Das Script muss dann erweitert werden um: wenn schon gemountet, tue nix, wenn nicht gemounted --> mount.
    Der Cron startet dann alle x Minuten/Stunden/Tage das script und gut is.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 135600 haftet ausdrücklich der jeweilige Autor: Tamerlain