Fritz WLAN-Stick AC 860 bei Opensuse installieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Fritz WLAN-Stick AC 860 bei Opensuse installieren gibt es 27 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Fritz WLAN-Stick AC 860 bei Opensuse installieren

    Hallo
    vielleicht kann mir jemand helfen.
    Ich habe bisher den WLAN-Stick D-Link DWL-G122 verwendet. Nur der macht inzwischen Probleme. Zeitweise kann ich 'Kaffeekochen' beim Aufrufen von Webseiten. Daher habe ich mir den FritzWLAN-Stick AC 860 besorgt. Leider bekomme ich ihn nicht installiert. Beim Einstecken leuchtet der Stick nur kurz grün auf, und ab dann nicht mehr. Bei lsusb wird der Stick unter 057c:8503 AVM GmbH gelistet. Den Stick habe ich, wie es in der Anleitung vorgeben, erst mit der FritzBox verbunden. Dort leuchtete er erst grün, später gelb auf. Dann sollte man ihn mit dem Computer verbinden. Da leuchtete der Stick kurz grün auf und dann tat sich nichts mehr. Das in der Anleitung angegebene automatische Aufrufen der Installation fand nicht statt. Unter Yast - Hardware wird der Stick als Fritz!WLAN AC 860 erkannt, wird allerdings nur unter USB gelistet und die Angabe des Treibers fehlt, während der D-Link zusätzlich noch unter Netzwerkkarte gelistet ist.
    Ich habe im Internet immer nur die Anleitung mit ndiswrapper gefunden und die waren meist mehrere Jahre alt. Nur für Opensuse Leap 15 gibt es keinen ndiswrapper mehr. Bei Ubuntu habe dich dann herausbekommen, dass der Chipsatz mit Ralink mt6552u identisch sein soll. Nur kann ich diesen Treiber nicht herunterladen, soll im Ralink mt65x2u-Paket sein. Beides habe ich jedoch als Download nicht gefunden. Beim D-Link war das kein Problem,
    Für AVM scheint es nur Windows zu geben, nur ganz selten findet man da Anleitungen für Linux. Und Treiber gibt es nur für Windows. Mit Wine läßt sie sich nicht installieren.
    Als Betriebssystem habe ich Opensuse Leap 15.1 64 bit.
    Für Hilfe wäre ich sehr dankbar.

    Für den Inhalt des Beitrages 135797 haftet ausdrücklich der jeweilige Autor: ingesendler

  • Funktioniert ab Kernel 4.20 out of the Box......
    Linux Kernel Driver DataBase: CONFIG_MT76x2U: MediaTek MT76x2U (USB) support
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 135799 haftet ausdrücklich der jeweilige Autor: Sauerland

  • qed

    Quellcode

    1. linux64:~ # modprobeid 057c:8503
    2. Kernelmodulname mt76x2u
    3. filename: /lib/modules/5.3.0-2.ga541a6c-default/kernel/drivers/net/wireless/mediatek/mt76/mt76x2/mt76x2u.ko.xz
    4. license: Dual BSD/GPL
    5. author: Lorenzo Bianconi <lorenzo.bianconi83@gmail.com>
    6. firmware: mt7662_rom_patch.bin
    7. firmware: mt7662.bin
    8. suserelease: openSUSE Tumbleweed
    9. srcversion: 90B28DC6B25999EA1150B56
    10. alias: usb:v045Ep02E6d*dc*dsc*dp*ic*isc*ip*in*
    11. alias: usb:v0846p9053d*dc*dsc*dp*ic*isc*ip*in*
    12. alias: usb:v7392pB711d*dc*dsc*dp*ic*isc*ip*in*
    13. alias: usb:v057Cp8503d*dc*dsc*dp*ic*isc*ip*in*
    14. alias: usb:v0E8Dp7612d*dc*dsc*dp*ic*isc*ip*in*
    15. alias: usb:v0B05p180Bd*dc*dsc*dp*ic*isc*ip*in*
    16. alias: usb:v0B05p17EBd*dc*dsc*dp*ic*isc*ip*in*
    17. alias: usb:v0B05p1833d*dc*dsc*dp*ic*isc*ip*in*
    18. depends: mt76x02-lib,mt76x2-common,mt76,mt76-usb,mac80211,mt76x02-usb,usbcore
    19. retpoline: Y
    20. intree: Y
    21. name: mt76x2u
    22. vermagic: 5.3.0-2.ga541a6c-default SMP mod_unload modversions
    23. sig_id: PKCS#7
    24. signer: Kernel OBS Project
    Alles anzeigen
    Also den Kernel aus kernel-stable benutzen.....
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 135802 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo,
    danke für die Hilfe.
    ich habe den Kernel auf 5.3.0 aktualisiert und mit modprobe mt7662u installiert. Das System habe ich neu gestartet. Der WLAN-Stick blinkt nur einmal grün und dann nichts mehr. Weiterhin wird der Stick unter 057c:8505 AVM GmbH angeben. modeprobeid funktioniert nicht. Unter Yast Hardware wird der Stick unter USB mit Treiber mt76x2u angegeben. Weiterhin wird der unter Netzwerkkarte nicht gelistet. Unter CD-rom Mode wird der Stick unter 057c:62ff gelistet. Eine Installation mit Wine wird abgebrochen.
    Für weitere Hilfe wäre ich dankbar.

    Für den Inhalt des Beitrages 135812 haftet ausdrücklich der jeweilige Autor: ingesendler

  • Poste als User ausgeführt:

    Quellcode

    1. /sbin/modprobe -c | grep -i "057c.*8503"

    Quellcode

    1. lsmod | grep -i mt76

    Und als root ausgeführt:

    Quellcode

    1. journalctl -b | grep -Ei 'firm|broad'
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 135813 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Bitte Code-Tags benutzen.
    Wenn man dann die komplette Eingabezeile mitpostet, braucht man nicht zu schreiben:

    als user
    Sauerland
    --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    als user

    Quellcode

    1. /sbin/modprobe -c | grep -i "057c.*8503"
    2. alias usb:v057Cp8503d*dc*dsc*dp*ic*isc*ip*in* mt76x2u





    Quellcode

    1. lsmod | grep -i mt76
    2. mt76x2u 28672 0
    3. mt76x2_common 20480 1 mt76x2u
    4. mt76x02_usb 20480 1 mt76x2u
    5. mt76_usb 36864 2 mt76x02_usb,mt76x2u
    6. mt76x02_lib 81920 3 mt76x02_usb,mt76x2u,mt76x2_common
    7. mt76 57344 5 mt76_usb,mt76x02_lib,mt76x02_usb,mt76x2u,mt76x2_common
    8. mac80211 978944 8 mt76,mt76_usb,ath9k,mt76x02_lib,rt2x00lib,mt76x02_usb,rt2x00usb,mt76x2u
    9. cfg80211 831488 8 mt76,ath9k_common,ath9k,mt76x02_lib,rt2x00lib,ath,mac80211,mt76x02_usb
    10. usbcore 307200 16 xhci_hcd,rt73usb,ehci_pci,usbhid,mt76_usb,rtsx_usb,usb_storage,uvcvideo,ehci_hcd,ath3k,btu
    11. sb,xhci_pci,mt76x02_usb,uas,rt2x00usb,mt76x2u
    Alles anzeigen


    als root

    Quellcode

    1. journalctl -b | grep -Ei 'firm|broad'
    2. Sep 17 12:41:00 linux-pgio kernel: Spectre V2 : Enabling Restricted Speculation for firmware calls
    3. Sep 17 12:41:00 linux-pgio kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    4. Sep 17 12:41:00 linux-pgio kernel: psmouse serio1: elantech: assuming hardware version 3 (with firmware version 0x450f03)
    5. Sep 17 12:41:01 linux-pgio kernel: psmouse serio1: elantech: assuming hardware version 3 (with firmware version 0x450f03)
    6. Sep 17 12:41:29 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    7. Sep 17 12:41:41 linux-pgio NetworkManager[1494]: <info> [1568716901.8085] manager[0x55b2993a0070]: monitoring kernel firmw
    8. are directory '/lib/firmware'.
    9. Sep 17 12:41:44 linux-pgio kernel: ieee80211 phy2: rt2x00lib_request_firmware: Info - Loading firmware file 'rt73.bin'
    10. Sep 17 12:41:44 linux-pgio kernel: ieee80211 phy2: rt2x00lib_request_firmware: Info - Firmware detected - version: 1.7
    11. Sep 17 12:43:07 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    12. Sep 17 12:57:40 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    13. Sep 17 12:57:46 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    14. Sep 17 13:10:29 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    15. Sep 17 13:45:30 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    16. Sep 17 13:45:49 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    17. Sep 17 13:48:50 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    18. Sep 17 13:52:20 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    19. Sep 17 13:52:34 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    20. Sep 17 14:04:28 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    21. Sep 17 14:04:29 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    22. Sep 17 14:06:08 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    23. Sep 17 14:06:10 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    24. Sep 17 14:06:14 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    25. Sep 17 14:06:18 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    26. Sep 17 14:06:38 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    27. Sep 17 14:06:40 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    28. Sep 17 14:06:57 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    29. Sep 17 14:06:58 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    30. Sep 17 14:07:07 linux-pgio kernel: usb 1-1: Firmware Version: 0.0.00
    31. Sep 17 14:07:26 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    32. Sep 17 14:07:28 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    33. Sep 17 14:08:34 linux-pgio kernel: ieee80211 phy10: rt2x00lib_request_firmware: Info - Loading firmware file 'rt73.bin'
    34. Sep 17 14:08:34 linux-pgio kernel: ieee80211 phy10: rt2x00lib_request_firmware: Info - Firmware detected - version: 1.7
    35. Sep 17 14:08:40 linux-pgio kdeconnectd[2277]: kdeconnect.core: Broadcasting identity packet
    Alles anzeigen

    Für den Inhalt des Beitrages 135820 haftet ausdrücklich der jeweilige Autor: ingesendler

  • Sep 17 14:08:34 linux-pgio kernel: ieee80211 phy10: rt2x00lib_request_firmware: Info - Loading firmware file 'rt73.bin'
    Hast du beim Kernel 5.3 auch versucht, irgend einen Treiber per make selber zu bauen?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 135822 haftet ausdrücklich der jeweilige Autor: Sauerland

  • dazu fehlt mir die Erfahrung.
    Ich habe mich nur in Linux eingearbeitet und bei Problemen im Internet nach Lösungen gesucht. Meist habe ich dann das Problem irgendwie gelöst bekommen.
    Ich kann etwas in Java programmieren, zu mehr reichts nicht.

    Für den Inhalt des Beitrages 135824 haftet ausdrücklich der jeweilige Autor: ingesendler

  • Yast----System----Netzwerkeinstellungen---Übersichtöffnen
    Dort müssen alle Netzwerkarten auf Nicht konfiguriert stehen. Wenn nicht, Netzwerkkarte markieren und löschen.

    Globale Einstellungen----Methode für den Netzwerkaufbau auf Netzwerkmanager-Dienst umstellen.

    Dann sollte unten rechts ein kleines Applet erscheinen, in dem du das Netzwerk einrichten kannst.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 135825 haftet ausdrücklich der jeweilige Autor: Sauerland

  • ich habe versucht ihn so einzurichten, er funktioniert immer noch nicht.
    wenn ich modinfo 057c:8503 eingebe, bekomme ich die Ausgabe 'Module 057c:8503 nicht gefunden'. Die Ausgabe von modprobeid 057c:8503 (oben) bekomme ich nur, wenn ich modinfo mt76x2u eingebe.
    Ich habe daraufhin in Yast /etc/sysconfig-Editor unter System / kernel nachgesehen. Dort fehlt der Befehl MODULE_LOADED_ON_BOARD. Könnte das die Ursache sein, wenn ja, wie kann ich ihn nachinstallieren?
    Ich habe den Kernel noch einmal übers Terminal installiert. Nach dem reboot sieht alles noch so aus, wie vorher.

    Für den Inhalt des Beitrages 135833 haftet ausdrücklich der jeweilige Autor: ingesendler