Aktualisierung von GLIBC auf Leap 15.1

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Aktualisierung von GLIBC auf Leap 15.1 gibt es 2 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Aktualisierung von GLIBC auf Leap 15.1

    Hallo zusammen!

    Ich habe zuletzt versucht, ein Modul namens VicPy in Python 3.7 einzubinden (Kompatibilität des Moduls zu Python 3.7 habe ich gecheckt). Problematisch hierbei ist, dass ich einen ImportError erhalte, in dem mir angezeigt wird, dass /lib64/libm.so.6 die GLIBC Version 2.27 nicht findet. Ich habe jetzt auch schon mal ein bisschen gesucht und bin auf das Problem gestoßen, dass Leap 15.1 von offizieller Seite bisher anscheinend nur GLIBC 2.26 unterstützt. Das liefert mir letztendlich auch die Abfrage ldd --version.

    So weit so schlecht: Updates von Conda, libc6, etc. helfen mir alle also nicht weiter, wenn ich VicPy zum Laufen bekommen möchte... Jetzt stehe ich da wie der Ochse vorm Karren und weiß nicht so recht, wie ich jetzt weiter verfahren soll. Gibt es hier vielleicht den einen oder anderen, der schon einmal ähnliche Probleme hatte und mir gegebenenfalls weiterhelfen kann?

    Ich bedanke mich schon mal recht herzlich bei euch! Als relativer Neuling in Linux bin ich leider solche Probleme nicht gewöhnt.

    Für den Inhalt des Beitrages 136452 haftet ausdrücklich der jeweilige Autor: pbr

  • Dagegen spricht wenig bis nichts, ich bin leider sowohl in Python als auch Linux noch ein Neuling und habe immer ein bisschen Bammel, irgendwas umzustellen und mir damit im Zweifel irgendwas zu zerschießen. Wenn ich das richtig verstehe, muss ich dafür ja eigene Environments erstellen, richtig?

    Für den Inhalt des Beitrages 136459 haftet ausdrücklich der jeweilige Autor: pbr