Nvidia-Beta-Treiber 440.26 lässt sich unter Kernel 5.3.5 nicht kompilieren.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Nvidia-Beta-Treiber 440.26 lässt sich unter Kernel 5.3.5 nicht kompilieren. gibt es 29 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Ich hänge hier noch die installer.log für den Treiber 435.21 als Anhang dran (als Ergänzung: Inzwischen ist Kernel 4.3.7-1 installiert).
    Dateien

    Für den Inhalt des Beitrages 136663 haftet ausdrücklich der jeweilige Autor: matbhm

  • Poste einmal:

    Quellcode

    1. cd ~/bin/nvidia/
    2. cat 440.patch

    Mach und poste komplett incl. der kompletten Eingabezeile:

    Quellcode

    1. rm NVIDIA-Linux-x86_64-440.26-custom.run
    2. ./NVIDIA-Linux-x86_64-440.26.run --apply-patch 440.patch
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 136664 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hier:

    Quellcode

    1. xxxxxx@linux-xxxxx:~> cd ~/bin/nvidia/
    2. xxxxxx@linux-xxxxx:~/bin/nvidia> cat 440.patch
    3. diff -Naur kernel/conftest.sh kernel/conftest.sh
    4. --- kernel/conftest.sh 2019-10-18 19:40:32.256867243 +0200
    5. +++ kernel/conftest.sh 2019-10-17 23:51:22.206328310 +0200
    6. @@ -70,7 +70,7 @@
    7. CODE="#include <$file>"
    8. echo "$CODE" > conftest_headers$$.c
    9. - $CC $CFLAGS -c conftest_headers$$.c > conftest_headers$$.log 2>&1
    10. + LANG=C $CC $CFLAGS -c conftest_headers$$.c > conftest_headers$$.log 2>&1
    11. if [ -f conftest_headers$$.o ]; then
    12. rm -f conftest_headers$$.o
    13. xxxxxx@linux-xxxxx:~/bin/nvidia>
    Alles anzeigen
    Und als Dateianhang:
    Dateien

    Für den Inhalt des Beitrages 136666 haftet ausdrücklich der jeweilige Autor: matbhm

  • Keine Ahnung, was bei dir schief läuft, hier mit kernel 5.3 aus kernel:stable und Leap 15.1 funktioniert der Treiber.

    Warte einfach auf den nächsten Treiber, der sollte schon gepatched sein.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 136677 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Vielen Dank für die Mühe!

    Für den Inhalt des Beitrages 136690 haftet ausdrücklich der jeweilige Autor: matbhm

  • So, der Nvidia-Treiber 440.26 beta läuft bei mir! Kleiner Fehler, große Auswirkung :)!

    Hallo, Sauerland, in Zeile 9 Deines Patches steht zu Beginn "LANG=C ..."

    Wer aus "LANG" "LANGUAGE" macht, hat Erfolg. War ein Hinweis auf dem von mir mit dem Eingangspost verlinkten Nvidia-Forum, letzter Beitrag!

    Für den Inhalt des Beitrages 136742 haftet ausdrücklich der jeweilige Autor: matbhm

  • Den Hinweis gab es aber nachdem ich dort geschaut habe......

    Trotzdem
    Schön das es jetzt funktioniert.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 136743 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Patch in Beitrag #2 geändert.
    440.patch auf dem Server geändert.
    Patch bei mir auf dem Rechner geändert......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 136749 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Den Hinweis gab es aber nachdem ich dort geschaut habe......
    Habe ich jetzt nicht so ganz verstanden.

    Für den Inhalt des Beitrages 136789 haftet ausdrücklich der jeweilige Autor: matbhm

  • Alles Makulatur: Der Treiber 440.31 ist raus und behebt alle Probleme auch ohne Patch!

    Für den Inhalt des Beitrages 136825 haftet ausdrücklich der jeweilige Autor: matbhm