Browser kann nicht auf *.js dateien zugreifen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Browser kann nicht auf *.js dateien zugreifen gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Browser kann nicht auf *.js dateien zugreifen

    Hallo,

    ich habe auf einen Server Leap15.1 installiert. Start war ein Minimal Base System, wo ich ua die noch benötigte Pakete für einen LAMP Server nachinstalliert habe.
    Danach habe ich versucht Nextcloud einzurichten (nach diesem Link: SDB:Nextcloud - openSUSE Wiki) .
    Hat auch soweit geklappt, dass ich über die Nextcloud Android App darauf zugreifen kann.
    Aber auf meinem Desktoprechner (Leap 15.1 mit KDE), stellt mein Webbrowser (Firefox) die Loginseite nicht richtig dar und der Button <LogIn> funktioniert nicht. Mache ich im Browser die Entwickler-Werkzeuge auf und gehe zur Konsole, sehe ich Warnungen dass mehre *.js Dateien nicht geöffnet werden können.
    Beispiel diese:

    Quellcode

    1. loading failed for the <script> with source “http://192.168.178.30/nextcloud/core/js/backgroundjobs.js?v=41101509-0”.
    Diese Datei finde ich aber im Apache Wurzel Verzeichnis und müsste für den Apacheserver auch lesbar sein (von Dateirechten her).
    Das gleiche Problem (Fehlerhafte Darstellung der Webseite) tritt unter Chromium auf oder unter Windows in einem Internet Explorer.

    Ich glaube nicht, dass es ein Nextcloudproblem ist, da das Programm phpMyAdmin auch die Loginseite nicht anzeigt:


    Quellcode

    1. Loading failed for the <script> with source “http://192.168.178.30/phpMyAdmin/js/vendor/jquery/jquery-migrate.js?v=4.9.1”.

    Daher Vermute ich das Apache die Seiten falsch aussliefert, sodass Brwoser die *.js Dateien nicht verarbeiten können.
    Einfache Seiten wie die index.html (Inhalt:"Es funktioniert" oder phpinfo.php (anzeigen des Versionsnr und geladene PHP-Module) werden richtig angezeigt.

    Zusammenfassung:
    • Einfache Seiten Werden ausgeliefert

    • Seiten mit *.js Dateien machen Schwierigkeiten

    • Betrifft verschiedene Webbrowser und verschiedene Betriebssysteme


    Habe ich vielleicht ein Modul im Apache Server nicht richtig aktiviert? Oder fehlen Pakete?

    Vielen Dank schon voraus!

    Grüße
    DeltaMy

    Für den Inhalt des Beitrages 136560 haftet ausdrücklich der jeweilige Autor: DeltaMy

  • Kann es sein, dass du ein Plugin im Browser hast, das Skripts blockiert? Siehe z.B. hier: javascript - Only on Firefox "Loading failed for the <script> with source" - Stack Overflow
    Und viele andere Fundstellen für diese Fehlermeldung gehen auch in diese Richtung...

    Sonst würde ich in den Developer Tools auch mal den Network Monitor anwerfen und mit den Request mit allen Headern und den Reply dazu anschauen.

    Für den Inhalt des Beitrages 136571 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Ich habe im Broswer alle Plugins/Addons deaktiviert. Habe Firefox auch im Abgesicherten Modus gestartet um alles Unötige zu deaktivieren - kein Erfolg. Kann es sein, dass Apache irgendetwas fehlt? Oder in einer Art Sicherheitsmodus läuft?
    Deinen zweiten Vorschlag werde ich mir mal anschauen und dann hier Feedback geben.

    Für den Inhalt des Beitrages 136579 haftet ausdrücklich der jeweilige Autor: DeltaMy

  • Ob es auf der Anfrageseite (Browser) liegt oder auf der Serverseite (Apache), darüber könnte das Netzwerkprotokoll Auskunft geben. Ich will wissen, ob der Browser überhaupt die Anfrage absendet, wenn ja, wie sie aussieht und was die Antwort ist.

    Du greifst auf den Server schon über die URL http://192.168.178.30/nextcloud zu oder benutzt du da einen Hostnamen?

    Für den Inhalt des Beitrages 136581 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • er versucht viele Sachen zu laden, ich habe einen Anfragen_kopf mal rauskopiert:

    Quellcode

    1. GET /nextcloud/core/js/backgroundjobs.js?v=41101509-0 HTTP/1.1
    2. Host: 192.168.178.30
    3. User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
    4. Accept: */*
    5. Accept-Language: en-US,en;q=0.5
    6. Accept-Encoding: gzip, deflate
    7. Connection: keep-alive
    8. Cookie: nc_sameSiteCookielax=true; nc_sameSiteCookiestrict=true; ocph7f5foj1m=kph6tfpmsr91b4m9kn0fch3cdt; oc_sessionPassphrase=oWdmfnQr7pHGHPzgMmbYjIwcFmnjkzCkveqoTpwCqIgzRib892g2knwSOQy1csfStL4y4yqQf1REp%2FnEoGKjGIQelieuD2RQJB%2FcZer8ftWm1RZ%2BoaK%2BnRbVD9o5LC57




    Zudem Header gibt es keine Antwort.

    zu dieser Anfrage schon:
    Rauskopierter Kopf:

    Quellcode

    1. GET /nextcloud/index.php/apps/accessibility/js/accessibility?v=0 HTTP/1.1
    2. Host: 192.168.178.30
    3. User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
    4. Accept: */*
    5. Accept-Language: en-US,en;q=0.5
    6. Accept-Encoding: gzip, deflate
    7. Connection: keep-alive
    8. Cookie: nc_sameSiteCookielax=true; nc_sameSiteCookiestrict=true; ocph7f5foj1m=kph6tfpmsr91b4m9kn0fch3cdt; oc_sessionPassphrase=oWdmfnQr7pHGHPzgMmbYjIwcFmnjkzCkveqoTpwCqIgzRib892g2knwSOQy1csfStL4y4yqQf1REp%2FnEoGKjGIQelieuD2RQJB%2FcZer8ftWm1RZ%2BoaK%2BnRbVD9o5LC57
    9. Cache-Control: max-age=0


    Die Antwort dazu:

    Quellcode

    1. HTTP/1.1 200 OK
    2. Date: Wed, 23 Oct 2019 16:57:52 GMT
    3. Server: Apache
    4. X-Powered-By: PHP/7.2.5
    5. Expires: Wed, 23 Oct 2019 17:57:54 +0000
    6. Cache-Control: max-age=3600, must-revalidate
    7. Pragma: public
    8. Content-Security-Policy: default-src 'none';base-uri 'none';manifest-src 'self';script-src 'nonce-SmJGK3ZsOVBnK2Z3L0M1NlZ6V0FNTytoYUR5MmdQcW1mYU5aNXJyaDQwcz06Zk4wNStqQXU1TCtha2x0RFBFMnZCYXZUVUZQVDZNUEJITzhvc0pHbDBEdz0=';style-src 'self' 'unsafe-inline';img-src 'self' data: blob:;font-src 'self' data:;connect-src 'self';media-src 'self';frame-ancestors 'self';worker-src 'self' blob:
    9. X-Frame-Options: SAMEORIGIN
    10. X-XSS-Protection: 1; mode=block
    11. X-Content-Type-Options: nosniff
    12. X-Robots-Tag: none
    13. X-Download-Options: noopen
    14. X-Permitted-Cross-Domain-Policies: none
    15. Referrer-Policy: no-referrer
    16. Content-Disposition: attachment; filename="javascript"
    17. Content-Length: 65
    18. Keep-Alive: timeout=15, max=100
    19. Connection: Keep-Alive
    20. Content-Type: text/javascript;charset=UTF-8
    Alles anzeigen


    Es sind ja sehr viele Anfragen, so dass ich nicht alle hier einzeln reinkopieren wollte, sondern nur zwei exemplarisch gewählt habe.
    Aber ich schicke mal ein Screenshot mit:
    Da sieht man die js Dateien wo js in der "Typ" Spalte steht haben auch eine Antwort erhalten (4 an der Zahl), bei den anderen wo es nicht erkannt wird, diese haben keine Antwort erhalten.



    letsfindaway schrieb:

    Ob es auf der Anfrageseite (Browser) liegt oder auf der Serverseite (Apache), darüber könnte das Netzwerkprotokoll Auskunft geben. Ich will wissen, ob der Browser überhaupt die Anfrage absendet, wenn ja, wie sie aussieht und was die Antwort ist.

    Du greifst auf den Server schon über die URL http://192.168.178.30/nextcloud zu oder benutzt du da einen Hostnamen?
    genau über: tt]nextcloud[/tt] greife ich drauf zu.

    Für den Inhalt des Beitrages 136591 haftet ausdrücklich der jeweilige Autor: DeltaMy

  • Hmm, interessanterweise steht der GET /nextcloud/core/js/backgroundjobs.js?v=41101509-0 trotzdem mit 200 OK im Protokoll, aber mit 0 Bytes. Dann würde ich erwarten, dass du diese leere Antwort auch im Netzwerklog siehst. Trotzdem: Das würde mir nun in der Tat eher nach Server als nach Client riechen.

    Alle fehlgeschlagenen haben außerdem einen ?v=41101509-0 Query Parameter. Der wird typischerweise verwendet, um das Caching zu steuern, wenn sich der Inhalt einer Datei unter der abgefragten URL ändert. Kannst du mal versuchen, die URL http://192.168.178.30//nextcloud/core/js/backgroundjobs.js?v=41101509-0 direkt aufzurufen, am besten mit Shift-Enter, um das Neuladen zu erzwingen? Ich erwarte entweder einen Timeout oder eine Antwort oder ein "Connection closed". Mich würde interessieren, was da kommt.

    Und dann wäre es noch interessant, die Apache access_log und error_log Files zum gleichen Zeitpunkt anzuschauen. Findest du da einen Anhaltspunkt?

    Für den Inhalt des Beitrages 136593 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • hmm, den Link habe ich eingetragen und da passiert nichts bzw ein leerer Bildschirm wird angezeigt. in der Netzwerkanalyse ist nach 2ms alles geladen mit Status 200. Allerdings keine Antwort verfügbar (keine Antwortdaten für diese Anfrage verfügbar).. Also kein timeout oder connection refused aufgetreten.. cache habe ich gelöscht.

    in der acess_log Datei steht nichts drin
    in der error Datei steht ein alter Fehler, aber vielleicht weist er ja in der die richtige Richtung:

    Quellcode

    1. [Mon Sep 09 21:14:26.174399 2019] [ssl:warn] [pid 10778] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]

    allerdings habe ich nach diesem Datum apache gelöscht und neu eingerichtet -> zypper rm apache2 und danach alle Konfigurationsdateien gelöscht und dann wieder neu installiert. von daher ist dieses Problem anscheinend nicht mehr wieder aufgetreten, sonst würde es ja mit einem aktuellerem Datum wieder auftauchen.

    Für den Inhalt des Beitrages 136594 haftet ausdrücklich der jeweilige Autor: DeltaMy

  • ich habe den Dateibesitzer von /var/log/apache2/* auf wwwrun geändert und apache neugestartet, die oben genannte Fehlermeldung ist immer noch aktuell, ich poste mal alles was der server mir mitteilt:

    Quellcode

    1. [Wed Oct 23 22:01:24.518984 2019] [mpm_prefork:notice] [pid 30381] AH00170: caught SIGWINCH, shutting down gracefully
    2. AH00558: httpd-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
    3. [Wed Oct 23 22:01:24.571314 2019] [ssl:warn] [pid 30407] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    4. [Wed Oct 23 22:01:24.572207 2019] [mpm_prefork:notice] [pid 30407] AH00163: Apache/2.4.33 (Linux/SUSE) OpenSSL/1.1.0i-fips configured -- resuming normal operations
    5. [Wed Oct 23 22:01:24.572231 2019] [core:notice] [pid 30407] AH00094: Command line: '/usr/sbin/httpd-prefork -D SYSCONFIG -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -D SYSTEMD -D FOREGROUND'

    Für den Inhalt des Beitrages 136595 haftet ausdrücklich der jeweilige Autor: DeltaMy

  • Moin zusammen,

    mich beschleicht da eine Idee dass da irgendwo eine versteckte .htaccess Datei rumfuhrwerkt, die das Laden bestimmter Dateien/Dateitypen unterbindet.

    ggf. sind aber auch nicht alle benötigten Apachemodule geladen.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 136620 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Könnte auch eine falsch konfigurierte/verwendete "Content-Security-Policy" sein.

    Da ist eine "nonce ID" in der script-src in der Policy definiert - wird diese "nonce ID" denn auch im <script> Aufruf verwendet?

    Lies mal diesen Artikel dazu:
    Content Security Policy - Wie schwer kann es sein?

    Ansonsten wenn es geht die CSP in der Apachekonfiguration mal weglassen und schauen ob es so mit dem Script funktioniert. Ich hatte in der Vergangenheit auch schon JavaScripts die wegen einer CSP nicht mehr funktionierten.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von wn48z ()

    Für den Inhalt des Beitrages 136626 haftet ausdrücklich der jeweilige Autor: wn48z