KDE startet unsichtbar

Hinweis: In dem Thema KDE startet unsichtbar gibt es 31 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo liebe OpenSuseaner,


    aktueller Status
    Mein System startet, es erscheint ein Login, dort kann ich die KDE's, Gnome und andere einstellen
    Nach Login lässt sich der Gnome starten und damit arbeiten.
    KDE startet zwar auch, es bleibt aber beim schwarzen Bildschirm, mit Tab-Alt laeszt sich zwischen Anwendungen umschalten,
    Man kann Text eingeben, so dass eine Auswahl von Programmen (auch Feuerfuchs) und Dateien angezeigt wird.
    Beim letzten Login ging aber nichts, auch ALT-STRG-ENTF zeigte keine Abmeldung


    mein System ist entsprechend der Ausgabe von Gnome 3.26.2:
    6,7 GiB
    AMD® Ryzen 5 2400g with radeon vega graphics × 8
    AMD® Raven
    openSUSE Leap 15.1
    64-bit


    641,4 GB


    Ich hatte, wegen der Grafik, auf irgendeine Weise einen aktuellen Kernel 5.5 anstelle des alten 4.12 er eingebaut. Die Anzeige (30" mit 2560x1600) funktioniert damit gut.
    Die Festplatten sind verschlüsselt, werden aber über PAM beim Login eingebunden.


    Ich hatte vor dem Dupdate von leap 15.0 einige KDE Erweiterungen fürs Design geladen und nacheinander ausprobiert. Dabei gab es Fehler. Die Loginmaske war kaum zu benutzen. Die Programme liefen sehr langsam. Löschen konnte ich die Designs nicht. Inzwischen habe ich mit erneuter Installation und gleich wieder löschen alle heraus genommen und den Standard Breeze überall eingestellt.
    Dateien wurden sehr langsam geladen. Videos bei VLC mussten 2x gestartet werden, bis etwas sichtbar wurde.


    Beim Dup wollte ich Zypper verwenden, habe mich an eine Opensuse Anleitung gehalten. mit sudo zypper -refresh, update, dup. Leider erfolglos. Dann habe ich in den URLs der Repos 15.0 durch 15.1 ersetzt und zypper update losgelassen. Das ging dann nachdem ich Speicher mit snapper freigegeben habe. Snapper braucht ja wirklich viel Platz. Hatte auch /var/tmp/* gelöscht.
    Das Problem trat dann auf, womit ich dann alle auffindbaren KDE und Plasmadateien des Nutzers gelöscht habe. Danach KDE neu installiert. Ohne Erfolg.


    Eigentlich hatte ich Gnome nicht installiert. EIn paar Gnome-Bibliotheken kamen sicherlich für einzelne Programme mit. Nach einem Update wurde das aber ohne Umstellung geladen.
    Ich kann mit Gnome nicht gut. Ich möchte so gern zu KDE Plasma zurück.



    Kann mir da jemand helfen?


    Gruß und Dank



    zypper se -si waylandRepository-Daten werden geladen...Installierte Pakete werden gelesen...

    S | Name | Typ | Version | Arch | Repository ---+--------------------------+-------+---------------------+--------+-----------------------i+ | kwayland | Paket | 5.55.0-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Ossi | kwayland-32bit | Paket | 5.55.0-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | kwayland-integration | Paket | 5.12.8-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libQt5WaylandClient5 | Paket | 5.9.7-lp151.1.4 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libQt5WaylandCompositor5 | Paket | 5.9.7-lp151.1.4 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libgstwayland-1_0-0 | Paket | 1.12.5-lp151.4.8 | x86_64 | Packman Repository i+ | libqt5-qtwayland | Paket | 5.9.7-lp151.1.4 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libva-wayland2 | Paket | 2.3.0-lp151.1.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-client0 | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-client0-32bit | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-cursor0 | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-cursor0-32bit | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-egl1 | Paket | 99~1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-egl1-32bit | Paket | 99~1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libwayland-server0 | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi | libwayland-server0-32bit | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | plasma5-session-wayland | Paket | 5.12.8-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-server-wayland | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss


    zypper se -si xf86 xorgRepository-Daten werden geladen...Installierte Pakete werden gelesen...

    S | Name | Typ | Version | Arch | Repository ---+-------------------------+-------+------------------+--------+-----------------------i+ | libXxf86dga1 | Paket | 1.1.4-lp151.2.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libXxf86misc1 | Paket | 1.0.3-lp151.2.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libXxf86vm-devel | Paket | 1.1.4-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libXxf86vm1 | Paket | 1.1.4-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libXxf86vm1-32bit | Paket | 1.1.4-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | libxcb-xf86dri0 | Paket | 1.13-lp151.3.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-evdev | Paket | 2.10.6-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-joystick | Paket | 1.6.3-lp151.2.4 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-keyboard | Paket | 1.9.0-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-libinput | Paket | 0.28.1-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-mouse | Paket | 1.9.2-lp151.3.4 | x86_64 | openSUSE-Leap-15.1-Ossi | xf86-input-synaptics | Paket | 1.9.0-lp151.2.4 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-vmmouse | Paket | 13.1.0-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-void | Paket | 1.4.1-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-input-wacom | Paket | 0.34.2-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-video-amdgpu | Paket | 18.1.0-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-video-ati | Paket | 18.1.0-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-video-fbdev | Paket | 0.5.0-lp151.1.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-video-mach64 | Paket | 6.9.6-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-video-r128 | Paket | 6.11.0-lp151.1.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86-video-vesa | Paket | 2.4.0-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86dga | Paket | 1.0.3-lp151.2.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xf86vidmodeproto-devel | Paket | 2.3.1-lp151.2.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xorg-scripts | Paket | 1.0.1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11 | Paket | 7.6_1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-Xvnc | Paket | 1.9.0-lp151.3.2 | x86_64 | openSUSE-Leap-15.1-Ossi | xorg-x11-Xvnc-module | Paket | 1.9.0-lp151.3.2 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xorg-x11-driver-input | Paket | 7.6_1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-driver-video | Paket | 7.6_1-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xorg-x11-essentials | Paket | 7.6_1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-fonts | Paket | 7.6-lp151.3.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-fonts-core | Paket | 7.6-lp151.3.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-libX11-ccache | Paket | 7.6-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-libs | Paket | 7.6.1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Ossi+ | xorg-x11-server | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xorg-x11-server-extra | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Ossi+ | xorg-x11-server-wayland | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss

    Für den Inhalt des Beitrages 138244 haftet ausdrücklich der jeweilige Autor: ansegisel

  • Ich hatte, wegen der Grafik, auf irgendeine Weise einen aktuellen Kernel 5.5 anstelle des alten 4.12 er eingebaut

    Der 5.5er ist nur als Release-Candidate verfügbar. Siehe kernel.org.
    Poste doch mal

    Code
    uname -a

    Beim Dup wollte ich Zypper verwenden, habe mich an eine Opensuse Anleitung gehalten. mit sudo zypper -refresh, update, dup. Leider erfolglos. Dann habe ich in den URLs der Repos 15.0 durch 15.1

    Da hast du aber die Anleitung (welche denn?) nicht richtig gelesen...
    Zuerst sollen die URLs der Repos von 15.0 auf 15.1 umgestellt werden. Erst dann

    Code
    zypper clean -a && zypper ref && zypper dup


    Und da du anscheinend Wayland nutzt, nach meinem Wissensstand ist es noch nicht ganz ausgereift.
    Ich habe es mal in einer VM probiert. Die Darstellung ist zwar korrekt, aber die Handhabung ist zäh.


    Ich würde dir schon fast eine Neuinstallation empfehlen...
    Aber mal abwarten, hier gibt es ein paar richtig gute!

    Für den Inhalt des Beitrages 138245 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Poste mal innerhalb von KDE in einer Konsole/Terminal als User ausgeführt (zielt ebenso wie ThomasS auf wayland ab)

    Code
    echo $XDG_SESSION_TYPE

    Zur Benutzung von Code-Tags:


    Bitte den Text in der Konsole markieren, kopieren, hier im Editor auf den Button </> klicken und erst in dem jetzt erscheinenden neuen Fenster den Text einfügen----ok klicken.


    Ergibt dann nicht so ein Kuddel-Muddel wie oben, welches entsteht, wenn man den Text direkt in den Beitrag einfügt, komplett wieder Markiert und dann erst auf </> klickt......

  • Und da du anscheinend Wayland nutzt, nach meinem Wissensstand ist es noch nicht ganz ausgereift.
    Ich habe es mal in einer VM probiert. Die Darstellung ist zwar korrekt, aber die Handhabung ist zäh.

    Sehe ich auch so :-)


    Also mal nicht Wayland auswählen (am Login Screen, wo du auch Gnome usw. siehst), sondern Plasma (ohne die Wayland-Bezeichnung).
    Sollte bei dir diese Auswahl nicht zu sehen sein, installierst du es einfach nach:

    Code
    zypper install -t pattern kde kde_plasma

    Für den Inhalt des Beitrages 138247 haftet ausdrücklich der jeweilige Autor: sterun

  • sudo funktioniert schon.
    Man findet es sogar auf diversen Seiten von OpenSuse.


    Ich halte es eher für eine philosophische Frage...
    Hier hatte mal jemand ein längeres Referat darüber abgehalten.
    War trotzdem interessant, wegen der technischen Hintergründe.


    Auch wenn ein sudo in den aller meisten Fällen genau so gut ist,
    hier bitte ein richtiges su - + Passwort (blind eingeben) verwenden, um volle Root-Rechte zu erhalten.

    Für den Inhalt des Beitrages 138250 haftet ausdrücklich der jeweilige Autor: ThomasS

  • jetzt erstmal der Reihe nach


    ThomasS:


    Code
    bureau@OSRitz35:~> uname -a
    Linux OSRitz35 5.5.0-rc4-1.g7e31c5e-default #1 SMP Mon Dec 30 06:30:53 UTC 2019 (7e31c5e) x86_64 x86_64 x86_64 GNU/Linux
    bureau@OSRitz35:~>


    In der Anleitung stand Udaterepo des aktuellen Leap, Danke wird geändert de.opensuse.org/SDB:Distribution-Upgrade

    ...muss die Adresse http://download.opensuse.org/update/leap/15.1/oss/ existieren (ersetzen Sie 15.1 durch die vorhandene Version) und aktiviert sein:

    also die vorhandene (?), das war 15.0


    ich habe beides in der Auswahl, Wayland ging nie richtig und nun gar nicht, daher habe ich ohne Wayland angemeldet


    Sauerland

    Code
    bureau@OSRitz35:~> sudo echo $XDG_SESSION_TYPE
    bureau@OSRitz35:~>

    da kam nichts


    sterun:

    beim Update hatte ich die überzähligen Repos inaktiv


    Petert:
    bei mir geht sudo


    ich hoffe, alle Fragen richtig beantwortet zu haben


    ich habe einen MariaDB server und sabra-katana, digikambackend auf MariaDB, ein zwar noch ungenutztes aber fertiges Wiki ...,
    das wäre schon krass, wenn ich das nochmal erneuern müsste
    ich habe die Laufwerke mit Luks, cryptsetup, pam_mount eingehängt, auch viel Schreibkram


    Danke

    Für den Inhalt des Beitrages 138251 haftet ausdrücklich der jeweilige Autor: ansegisel

  • @ansegisel, woher hast du diesen Kernel? Für OpenSuse ist der 5.4.8 gerade veröffentlicht worden. Und das auch nur im Repo Kernel:stable.
    Selbst reingebastelt? 5.5rc4

    Release-Candidat 4

    Kernel.org bietet den in der Version RC5 an. Also auch noch nichts finales.
    Also, wie hast du den denn da installiert und warum?

    Einmal editiert, zuletzt von ThomasS ()

    Für den Inhalt des Beitrages 138253 haftet ausdrücklich der jeweilige Autor: ThomasS

  • 1. Kernel 5.4.8......
    2. Index of /repositories/Kernel:/HEAD/standard
    Und der ist experimentell...........





    Sauerland

    Code
    bureau@OSRitz35:~> sudo echo $XDG_SESSION_TYPE
    bureau@OSRitz35:~>


    Poste mal innerhalb von KDE in einer Konsole/Terminal als User ausgeführt (zielt ebenso wie ThomasS auf wayland ab)

    Code
    echo $XDG_SESSION_TYPE

    sudo ist nicht User.....




    Poste einmal (kannst du auch als User machen):


    Code
    zypper se -si kernel session wayland
    Code
    zypper lr -d