KDE startet unsichtbar

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema KDE startet unsichtbar gibt es 31 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • KDE startet unsichtbar

    Hallo liebe OpenSuseaner,

    aktueller Status
    Mein System startet, es erscheint ein Login, dort kann ich die KDE's, Gnome und andere einstellen
    Nach Login lässt sich der Gnome starten und damit arbeiten.
    KDE startet zwar auch, es bleibt aber beim schwarzen Bildschirm, mit Tab-Alt laeszt sich zwischen Anwendungen umschalten,
    Man kann Text eingeben, so dass eine Auswahl von Programmen (auch Feuerfuchs) und Dateien angezeigt wird.
    Beim letzten Login ging aber nichts, auch ALT-STRG-ENTF zeigte keine Abmeldung

    mein System ist entsprechend der Ausgabe von Gnome 3.26.2:
    6,7 GiB
    AMD® Ryzen 5 2400g with radeon vega graphics × 8
    AMD® Raven
    openSUSE Leap 15.1
    64-bit

    641,4 GB

    Ich hatte, wegen der Grafik, auf irgendeine Weise einen aktuellen Kernel 5.5 anstelle des alten 4.12 er eingebaut. Die Anzeige (30" mit 2560x1600) funktioniert damit gut.
    Die Festplatten sind verschlüsselt, werden aber über PAM beim Login eingebunden.

    Ich hatte vor dem Dupdate von leap 15.0 einige KDE Erweiterungen fürs Design geladen und nacheinander ausprobiert. Dabei gab es Fehler. Die Loginmaske war kaum zu benutzen. Die Programme liefen sehr langsam. Löschen konnte ich die Designs nicht. Inzwischen habe ich mit erneuter Installation und gleich wieder löschen alle heraus genommen und den Standard Breeze überall eingestellt.
    Dateien wurden sehr langsam geladen. Videos bei VLC mussten 2x gestartet werden, bis etwas sichtbar wurde.

    Beim Dup wollte ich Zypper verwenden, habe mich an eine Opensuse Anleitung gehalten. mit sudo zypper -refresh, update, dup. Leider erfolglos. Dann habe ich in den URLs der Repos 15.0 durch 15.1 ersetzt und zypper update losgelassen. Das ging dann nachdem ich Speicher mit snapper freigegeben habe. Snapper braucht ja wirklich viel Platz. Hatte auch /var/tmp/* gelöscht.
    Das Problem trat dann auf, womit ich dann alle auffindbaren KDE und Plasmadateien des Nutzers gelöscht habe. Danach KDE neu installiert. Ohne Erfolg.

    Eigentlich hatte ich Gnome nicht installiert. EIn paar Gnome-Bibliotheken kamen sicherlich für einzelne Programme mit. Nach einem Update wurde das aber ohne Umstellung geladen.
    Ich kann mit Gnome nicht gut. Ich möchte so gern zu KDE Plasma zurück.


    Kann mir da jemand helfen?

    Gruß und Dank


    zypper se -si wayland Repository-Daten werden geladen... Installierte Pakete werden gelesen... S | Name | Typ | Version | Arch | Repository ---+--------------------------+-------+---------------------+--------+----------------------- i+ | kwayland | Paket | 5.55.0-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Oss i | kwayland-32bit | Paket | 5.55.0-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | kwayland-integration | Paket | 5.12.8-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libQt5WaylandClient5 | Paket | 5.9.7-lp151.1.4 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libQt5WaylandCompositor5 | Paket | 5.9.7-lp151.1.4 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libgstwayland-1_0-0 | Paket | 1.12.5-lp151.4.8 | x86_64 | Packman Repository i+ | libqt5-qtwayland | Paket | 5.9.7-lp151.1.4 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libva-wayland2 | Paket | 2.3.0-lp151.1.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-client0 | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-client0-32bit | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-cursor0 | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-cursor0-32bit | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-egl1 | Paket | 99~1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-egl1-32bit | Paket | 99~1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libwayland-server0 | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i | libwayland-server0-32bit | Paket | 1.16.0-lp151.4.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | plasma5-session-wayland | Paket | 5.12.8-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-server-wayland | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss

    zypper se -si xf86 xorg Repository-Daten werden geladen... Installierte Pakete werden gelesen... S | Name | Typ | Version | Arch | Repository ---+-------------------------+-------+------------------+--------+----------------------- i+ | libXxf86dga1 | Paket | 1.1.4-lp151.2.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libXxf86misc1 | Paket | 1.0.3-lp151.2.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libXxf86vm-devel | Paket | 1.1.4-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libXxf86vm1 | Paket | 1.1.4-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libXxf86vm1-32bit | Paket | 1.1.4-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | libxcb-xf86dri0 | Paket | 1.13-lp151.3.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-evdev | Paket | 2.10.6-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-joystick | Paket | 1.6.3-lp151.2.4 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-keyboard | Paket | 1.9.0-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-libinput | Paket | 0.28.1-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-mouse | Paket | 1.9.2-lp151.3.4 | x86_64 | openSUSE-Leap-15.1-Oss i | xf86-input-synaptics | Paket | 1.9.0-lp151.2.4 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-vmmouse | Paket | 13.1.0-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-void | Paket | 1.4.1-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-input-wacom | Paket | 0.34.2-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-video-amdgpu | Paket | 18.1.0-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-video-ati | Paket | 18.1.0-lp151.1.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-video-fbdev | Paket | 0.5.0-lp151.1.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-video-mach64 | Paket | 6.9.6-lp151.1.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-video-r128 | Paket | 6.11.0-lp151.1.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86-video-vesa | Paket | 2.4.0-lp151.2.3 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86dga | Paket | 1.0.3-lp151.2.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xf86vidmodeproto-devel | Paket | 2.3.1-lp151.2.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xorg-scripts | Paket | 1.0.1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11 | Paket | 7.6_1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-Xvnc | Paket | 1.9.0-lp151.3.2 | x86_64 | openSUSE-Leap-15.1-Oss i | xorg-x11-Xvnc-module | Paket | 1.9.0-lp151.3.2 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xorg-x11-driver-input | Paket | 7.6_1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-driver-video | Paket | 7.6_1-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xorg-x11-essentials | Paket | 7.6_1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-fonts | Paket | 7.6-lp151.3.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-fonts-core | Paket | 7.6-lp151.3.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-libX11-ccache | Paket | 7.6-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-libs | Paket | 7.6.1-lp151.2.1 | noarch | openSUSE-Leap-15.1-Oss i+ | xorg-x11-server | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xorg-x11-server-extra | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss i+ | xorg-x11-server-wayland | Paket | 1.20.3-lp151.3.1 | x86_64 | openSUSE-Leap-15.1-Oss

    Für den Inhalt des Beitrages 138244 haftet ausdrücklich der jeweilige Autor: ansegisel

  • ansegisel schrieb:

    Ich hatte, wegen der Grafik, auf irgendeine Weise einen aktuellen Kernel 5.5 anstelle des alten 4.12 er eingebaut
    Der 5.5er ist nur als Release-Candidate verfügbar. Siehe kernel.org.
    Poste doch mal

    Quellcode

    1. uname -a

    ansegisel schrieb:

    Beim Dup wollte ich Zypper verwenden, habe mich an eine Opensuse Anleitung gehalten. mit sudo zypper -refresh, update, dup. Leider erfolglos. Dann habe ich in den URLs der Repos 15.0 durch 15.1
    Da hast du aber die Anleitung (welche denn?) nicht richtig gelesen...
    Zuerst sollen die URLs der Repos von 15.0 auf 15.1 umgestellt werden. Erst dann

    Quellcode

    1. zypper clean -a && zypper ref && zypper dup

    Und da du anscheinend Wayland nutzt, nach meinem Wissensstand ist es noch nicht ganz ausgereift.
    Ich habe es mal in einer VM probiert. Die Darstellung ist zwar korrekt, aber die Handhabung ist zäh.

    Ich würde dir schon fast eine Neuinstallation empfehlen...
    Aber mal abwarten, hier gibt es ein paar richtig gute!

    Für den Inhalt des Beitrages 138245 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Poste mal innerhalb von KDE in einer Konsole/Terminal als User ausgeführt (zielt ebenso wie ThomasS auf wayland ab)

    Quellcode

    1. echo $XDG_SESSION_TYPE
    Zur Benutzung von Code-Tags:

    Bitte den Text in der Konsole markieren, kopieren, hier im Editor auf den Button </> klicken und erst in dem jetzt erscheinenden neuen Fenster den Text einfügen----ok klicken.

    Ergibt dann nicht so ein Kuddel-Muddel wie oben, welches entsteht, wenn man den Text direkt in den Beitrag einfügt, komplett wieder Markiert und dann erst auf </> klickt......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138246 haftet ausdrücklich der jeweilige Autor: Sauerland

  • ThomasS schrieb:

    Und da du anscheinend Wayland nutzt, nach meinem Wissensstand ist es noch nicht ganz ausgereift.
    Ich habe es mal in einer VM probiert. Die Darstellung ist zwar korrekt, aber die Handhabung ist zäh.
    Sehe ich auch so :)

    Also mal nicht Wayland auswählen (am Login Screen, wo du auch Gnome usw. siehst), sondern Plasma (ohne die Wayland-Bezeichnung).
    Sollte bei dir diese Auswahl nicht zu sehen sein, installierst du es einfach nach:

    Quellcode

    1. zypper install -t pattern kde kde_plasma

    Für den Inhalt des Beitrages 138247 haftet ausdrücklich der jeweilige Autor: sterun

  • sudo funktioniert schon.
    Man findet es sogar auf diversen Seiten von OpenSuse.

    Ich halte es eher für eine philosophische Frage...
    Hier hatte mal jemand ein längeres Referat darüber abgehalten.
    War trotzdem interessant, wegen der technischen Hintergründe.

    Auch wenn ein sudo in den aller meisten Fällen genau so gut ist,
    hier bitte ein richtiges su - + Passwort (blind eingeben) verwenden, um volle Root-Rechte zu erhalten.

    Für den Inhalt des Beitrages 138250 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Danke, soviele Helfer

    jetzt erstmal der Reihe nach

    ThomasS:

    Quellcode

    1. bureau@OSRitz35:~> uname -a
    2. Linux OSRitz35 5.5.0-rc4-1.g7e31c5e-default #1 SMP Mon Dec 30 06:30:53 UTC 2019 (7e31c5e) x86_64 x86_64 x86_64 GNU/Linux
    3. bureau@OSRitz35:~>


    In der Anleitung stand Udaterepo des aktuellen Leap, Danke wird geändert de.opensuse.org/SDB:Distribution-Upgrade

    de.opensuse.org schrieb:

    ...muss die Adresse download.opensuse.org/update/leap/15.1/oss/ existieren (ersetzen Sie 15.1 durch die vorhandene Version) und aktiviert sein:
    also die vorhandene (?), das war 15.0

    ich habe beides in der Auswahl, Wayland ging nie richtig und nun gar nicht, daher habe ich ohne Wayland angemeldet

    Sauerland

    Quellcode

    1. bureau@OSRitz35:~> sudo echo $XDG_SESSION_TYPE
    2. bureau@OSRitz35:~>
    da kam nichts

    sterun:

    Brainfuck-Quellcode

    1. bureau@OSRitz35:~> sudo zypper install -t pattern kde kde_plasma
    2. Metadaten von Repository 'Games' abrufen ...........................................................................................................................[fertig]
    3. Cache für Repository 'Games' erzeugen ..............................................................................................................................[fertig]
    4. Metadaten von Repository 'utilities' abrufen .......................................................................................................................[fertig]
    5. Cache für Repository 'utilities' erzeugen ..........................................................................................................................[fertig]
    6. Metadaten von Repository 'Science' abrufen .........................................................................................................................[fertig]
    7. Cache für Repository 'Science' erzeugen ............................................................................................................................[fertig]
    8. Metadaten von Repository 'Geo' abrufen .............................................................................................................................[fertig]
    9. Cache für Repository 'Geo' erzeugen ................................................................................................................................[fertig]
    10. Metadaten von Repository 'Libdvdcss Repository' abrufen ............................................................................................................[fertig]
    11. Cache für Repository 'Libdvdcss Repository' erzeugen ...............................................................................................................[fertig]
    12. Metadaten von Repository 'Packman Repository' abrufen ..............................................................................................................[fertig]
    13. Cache für Repository 'Packman Repository' erzeugen .................................................................................................................[fertig]
    14. Metadaten von Repository 'openSUSE-Leap-15.1-Non-Oss' abrufen ......................................................................................................[fertig]
    15. Cache für Repository 'openSUSE-Leap-15.1-Non-Oss' erzeugen .........................................................................................................[fertig]
    16. Metadaten von Repository 'openSUSE-Leap-15.1-Oss' abrufen ..........................................................................................................[fertig]
    17. Cache für Repository 'openSUSE-Leap-15.1-Oss' erzeugen .............................................................................................................[fertig]
    18. Metadaten von Repository 'openSUSE-Leap-15.1-Update' abrufen .......................................................................................................[fertig]
    19. Cache für Repository 'openSUSE-Leap-15.1-Update' erzeugen ..........................................................................................................[fertig]
    20. Metadaten von Repository 'openSUSE-Leap-15.1-Update-Non-Oss' abrufen ...............................................................................................[fertig]
    21. Cache für Repository 'openSUSE-Leap-15.1-Update-Non-Oss' erzeugen ..................................................................................................[fertig]
    22. Repository-Daten werden geladen...
    23. Installierte Pakete werden gelesen...
    24. 'pattern:kde' ist bereits installiert.
    25. Kein Aktualisierungskandidat für 'pattern:kde-20181130-lp151.1.1.noarch'. Die neueste Version ist bereits installiert.
    26. 'pattern:kde_plasma' ist bereits installiert.
    27. Kein Aktualisierungskandidat für 'pattern:kde_plasma-20181130-lp151.1.1.noarch'. Die neueste Version ist bereits installiert.
    28. Paketabhängigkeiten werden aufgelöst...
    29. Keine auszuführenden
    Alles anzeigen
    beim Update hatte ich die überzähligen Repos inaktiv

    Petert:
    bei mir geht sudo

    ich hoffe, alle Fragen richtig beantwortet zu haben

    ich habe einen MariaDB server und sabra-katana, digikambackend auf MariaDB, ein zwar noch ungenutztes aber fertiges Wiki ...,
    das wäre schon krass, wenn ich das nochmal erneuern müsste
    ich habe die Laufwerke mit Luks, cryptsetup, pam_mount eingehängt, auch viel Schreibkram

    Danke

    Für den Inhalt des Beitrages 138251 haftet ausdrücklich der jeweilige Autor: ansegisel

  • @ansegisel, woher hast du diesen Kernel? Für OpenSuse ist der 5.4.8 gerade veröffentlicht worden. Und das auch nur im Repo Kernel:stable.
    Selbst reingebastelt? 5.5rc4

    Release-Candidat 4

    Kernel.org bietet den in der Version RC5 an. Also auch noch nichts finales.
    Also, wie hast du den denn da installiert und warum?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von ThomasS ()

    Für den Inhalt des Beitrages 138253 haftet ausdrücklich der jeweilige Autor: ThomasS

  • ThomasS schrieb:

    @ansegisel, woher hast du diesen Kernel? Für OpenSuse ist der 4.8 gerade veröffentlicht worden. Und das auch nur im Repo Kernel:stable.
    Selbst reingebastelt? 5.5rc4

    Release-Candidat 4

    Kernel.org bietet den in der Version 5 an. Also auch noch nichts finales.
    Also, wie hast du den denn da installiert und warum?
    1. Kernel 5.4.8......
    2. Index of /repositories/Kernel:/HEAD/standard
    Und der ist experimentell...........




    ansegisel schrieb:

    Sauerland

    Quellcode

    1. bureau@OSRitz35:~> sudo echo $XDG_SESSION_TYPE
    2. bureau@OSRitz35:~>


    Sauerland schrieb:

    Poste mal innerhalb von KDE in einer Konsole/Terminal als User ausgeführt (zielt ebenso wie ThomasS auf wayland ab)

    Quellcode

    1. echo $XDG_SESSION_TYPE
    sudo ist nicht User.....



    Poste einmal (kannst du auch als User machen):

    Quellcode

    1. zypper se -si kernel session wayland

    Quellcode

    1. zypper lr -d
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138254 haftet ausdrücklich der jeweilige Autor: Sauerland