NFS-Server einrichten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema NFS-Server einrichten gibt es 72 Antworten auf 8 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Ja, habe alles genommen was da war. Ich dachte besser alle drin als einer zu wenig.
    So hier nun die Antwort:

    zypper in nfs-kernel-server
    Loading repository data...
    Reading installed packages...
    'nfs-kernel-server' is already installed.
    No update candidate for 'nfs-kernel-server-2.1.1-lp151.7.3.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...


    Nothing to do.

    Den Firewall habe ich jetzt angehalten.
    So wie ich das sehen ist der nfs-kernel-server installiert.
    PC mit AMD Athlon(tm) II x4 645 Prozessor

    Für den Inhalt des Beitrages 139833 haftet ausdrücklich der jeweilige Autor: Zebix

  • systemctl status nfs-server.service
    ● nfs-server.service - NFS server and services
    Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/nfs-server.service.d
    └─nfsserver.conf, options.conf
    Active: active (exited) since Tue 2020-02-18 18:29:44 CET; 2h 11min ago
    Main PID: 1596 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
    CGroup: /system.slice/nfs-server.service


    Feb 18 18:29:44 Zebix-10 systemd[1]: Starting NFS server and services...
    Feb 18 18:29:44 Zebix-10 systemd[1]: Started NFS server and services.
    PC mit AMD Athlon(tm) II x4 645 Prozessor

    Für den Inhalt des Beitrages 139837 haftet ausdrücklich der jeweilige Autor: Zebix

  • Ok mach dann mal eine Denkpause. Ich kling mich mal aus.
    Sitze schon den ganzen Tag am Bildschirm und versuch den Fehler zu finden.
    Vielen Dank erst mal.
    PC mit AMD Athlon(tm) II x4 645 Prozessor

    Für den Inhalt des Beitrages 139840 haftet ausdrücklich der jeweilige Autor: Zebix

  • Sehe deine beschriebene Fehlermeldung gerade im openSUSE-Manual (unter dem ersten Bild):
    cha-nfs.html#sec-nfs-installation
    Hilft dir das schon?

    Also, das wären die "normalen" Schritte (als Root):
    zypper in nfs-kernel-server
    systemctl enable nfsserver
    systemctl restart nfsserver
    firewall-cmd --add-service=nfs --permanent
    firewall-cmd --reload

    Erst danach kommt die eigentliche nfs-Konfiguration - Verlinkung in diesem Post.

    Für den Inhalt des Beitrages 139842 haftet ausdrücklich der jeweilige Autor: sterun

  • sterun schrieb:

    Sehe deine beschriebene Fehlermeldung gerade im openSUSE-Manual (unter dem ersten Bild):
    cha-nfs.html#sec-nfs-installation
    Hilft dir das schon?

    Also, das wären die "normalen" Schritte (als Root):
    zypper in nfs-kernel-server
    systemctl enable nfsserver
    systemctl restart nfsserver
    firewall-cmd --add-service=nfs --permanent
    firewall-cmd --reload

    Erst danach kommt die eigentliche nfs-Konfiguration - Verlinkung in diesem Post.
    Hallo sterum,
    die Vorgehensweise wie im Llink beschrieben war mir bereits bekannt und wurde auch als erstes durchgeführt.
    Und dies hier ist das Ergebnis der von dir aufgeführten Shellbefehle:

    Passwort:
    Zebix-10:~ # zypper in nfs-kernel-server
    Loading repository data...
    Reading installed packages...
    'nfs-kernel-server' is already installed.
    No update candidate for 'nfs-kernel-server-2.1.1-lp151.7.3.1.x86_64'. The highest available version is already installed.
    Resolving package dependencies...


    Nothing to do.

    Zebix-10:~ # systemctl enable nfsserver
    Zebix-10:~ # systemctl restart nfsserver
    Zebix-10:~ # firewall-cmd --add-service=nfs --permanent
    FirewallD is not running
    Zebix-10:~ # firewall-cmd --reload
    FirewallD is not running
    Zebix-10:~ #

    Obwohl ich alles war Ihr mir hier an Tips gegeben habt, ist dass Ergebnis immer noch das selbe.
    Der NSF-Sever lässt sich nicht konfigurieren.
    PC mit AMD Athlon(tm) II x4 645 Prozessor

    Für den Inhalt des Beitrages 139852 haftet ausdrücklich der jeweilige Autor: Zebix

  • Ok, habe ich gemacht mit dem Ergebnis:

    Quellcode

    1. Zebix-10:~ # systemctl enable firewalld
    2. Zebix-10:~ # systemctl start firewalld.service
    3. Zebix-10:~ # firewall-cmd –state
    4. usage: see firewall-cmd man page
    5. firewall-cmd: error: unrecognized arguments: –state
    PC mit AMD Athlon(tm) II x4 645 Prozessor

    Für den Inhalt des Beitrages 139862 haftet ausdrücklich der jeweilige Autor: Zebix