xsane und simple-scan funktionieren nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema xsane und simple-scan funktionieren nicht gibt es 34 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • ja libusb-Fehlermeldung ist vermutlich eine Sackgasse. Ich habe die beiden rpms vom Hersteller direkt installiert:

    Quellcode

    1. sudo rpm -ihv --nodeps --replacefiles --replacepkgs brscan4-0.4.8-1.x86_64.rpm
    2. [sudo] Passwort für root:
    3. Verifying... ################################# [100%]
    4. Preparing... ################################# [100%]
    5. Updating / installing...
    6. 1:brscan4-0.4.8-1 ################################# [100%]
    7. This software is based in part on the work of the Independent JPEG Group.
    +

    Quellcode

    1. sudo rpm -ihv --nodeps --replacefiles --replacepkgs brscan-skey-0.2.4-1.x86_64.rpm
    2. Verifying... ################################# [100%]
    3. Preparing... ################################# [100%]
    4. Updating / installing...
    5. 1:brscan-skey-0.2.4-1 ################################# [100%]
    6. ln: die symbolische Verknüpfung '/etc/opt/brother/scanner/brscan-skey/brscan_mail.config' konnte nicht angelegt werden: Die Datei existiert bereits
    7. ln: die symbolische Verknüpfung '/etc/opt/brother/scanner/brscan-skey/brscan_mailmessage.txt' konnte nicht angelegt werden: Die Datei existiert bereits
    8. ln: die symbolische Verknüpfung '/etc/opt/brother/scanner/brscan-skey/brscan-skey-0.2.4-0.cfg' konnte nicht angelegt werden: Die Datei existiert bereits
    9. ln: die symbolische Verknüpfung '/usr/bin/brscan-skey' konnte nicht angelegt werden: Die Datei existiert bereits
    10. warning: %post(brscan-skey-0.2.4-1.x86_64) scriptlet failed, exit status 1

    Quellcode

    1. sudo brsaneconfig4 -a name=MFC-L3770CDW model=MFC-L3770CDW ip=192.168.178.29

    Brainfuck-Quellcode

    1. sudo brsaneconfig4 -d name=MFC-L3770CDW
    2. [sudo] Passwort für root:
    3. -----------------------------
    4. cat /etc/fstab
    5. -----------------------------
    6. sane-find-scanner
    7. # sane-find-scanner will now attempt to detect your scanner. If the
    8. # result is different from what you expected, first make sure your
    9. # scanner is powered up and properly connected to your computer.
    10. # No SCSI scanners found. If you expected something different, make sure that
    11. # you have loaded a kernel SCSI driver for your SCSI adapter.
    12. # No USB scanners found. If you expected something different, make sure that
    13. # you have loaded a kernel driver for your USB host controller and have setup
    14. # the USB system correctly. See man sane-usb for details.
    15. # Not checking for parallel port scanners.
    16. # Most Scanners connected to the parallel port or other proprietary ports
    17. # can't be detected by this program.
    18. -----------------------------
    19. ls -R -all /proc/bus/usb
    20. ls: Zugriff auf '/proc/bus/usb' nicht möglich: Datei oder Verzeichnis nicht gefunden
    21. -----------------------------
    22. cat /proc/bus/usb/devices
    23. cat: /proc/bus/usb/devices: Datei oder Verzeichnis nicht gefunden
    24. -----------------------------
    25. scanimage -L
    26. device `brother4:net1;dev0' is a Brother MFC-L3770CDW MFC-L3770CDW
    27. -----------------------------
    28. -----------------------------
    29. /etc/opt/brother/scanner/brscan4//brsanenetdevice4.cfg:
    30. -----------------------------
    31. /etc/opt/brother/scanner/brscan4//Brsane4.ini:
    32. -----------------------------
    33. /etc/opt/brother/scanner/brscan4//models4/ext_1.ini:
    34. -----------------------------
    35. /etc/opt/brother/scanner/brscan4//models4/ext_10.ini:
    36. -----------------------------
    37. /etc/opt/brother/scanner/brscan4//models4/ext_11.ini:
    38. -----------------------------
    39. /etc/opt/brother/scanner/brscan4//models4/ext_12.ini:
    40. -----------------------------
    41. /etc/opt/brother/scanner/brscan4//models4/ext_13.ini:
    42. -----------------------------
    43. /etc/opt/brother/scanner/brscan4//models4/ext_14.ini:
    44. -----------------------------
    45. /etc/opt/brother/scanner/brscan4//models4/ext_15.ini:
    46. -----------------------------
    47. /etc/opt/brother/scanner/brscan4//models4/ext_16.ini:
    48. -----------------------------
    49. /etc/opt/brother/scanner/brscan4//models4/ext_17.ini:
    50. -----------------------------
    51. /etc/opt/brother/scanner/brscan4//models4/ext_18.ini:
    52. -----------------------------
    53. /etc/opt/brother/scanner/brscan4//models4/ext_19.ini:
    54. -----------------------------
    55. /etc/opt/brother/scanner/brscan4//models4/ext_2.ini:
    56. -----------------------------
    57. /etc/opt/brother/scanner/brscan4//models4/ext_20.ini:
    58. -----------------------------
    59. /etc/opt/brother/scanner/brscan4//models4/ext_21.ini:
    60. -----------------------------
    61. /etc/opt/brother/scanner/brscan4//models4/ext_22.ini:
    62. -----------------------------
    63. /etc/opt/brother/scanner/brscan4//models4/ext_23.ini:
    64. -----------------------------
    65. /etc/opt/brother/scanner/brscan4//models4/ext_24.ini:
    66. -----------------------------
    67. /etc/opt/brother/scanner/brscan4//models4/ext_3.ini:
    68. -----------------------------
    69. /etc/opt/brother/scanner/brscan4//models4/ext_4.ini:
    70. -----------------------------
    71. /etc/opt/brother/scanner/brscan4//models4/ext_5.ini:
    72. -----------------------------
    73. /etc/opt/brother/scanner/brscan4//models4/ext_6.ini:
    74. -----------------------------
    75. /etc/opt/brother/scanner/brscan4//models4/ext_7.ini:
    76. -----------------------------
    77. /etc/opt/brother/scanner/brscan4//models4/ext_8.ini:
    78. -----------------------------
    79. /etc/opt/brother/scanner/brscan4//models4/ext_9.ini:
    80. -----------------------------
    81. -----------------------------
    82. ping
    83. test MFC-L3770CDW
    84. ping 192.168.178.29 -w 10
    85. PING 192.168.178.29 (192.168.178.29) 56(84) bytes of data.
    86. 64 bytes from 192.168.178.29: icmp_seq=1 ttl=255 time=31.3 ms
    87. 64 bytes from 192.168.178.29: icmp_seq=2 ttl=255 time=52.7 ms
    88. 64 bytes from 192.168.178.29: icmp_seq=3 ttl=255 time=73.1 ms
    89. 64 bytes from 192.168.178.29: icmp_seq=4 ttl=255 time=97.8 ms
    90. 64 bytes from 192.168.178.29: icmp_seq=5 ttl=255 time=16.2 ms
    91. 64 bytes from 192.168.178.29: icmp_seq=6 ttl=255 time=39.4 ms
    92. 64 bytes from 192.168.178.29: icmp_seq=7 ttl=255 time=61.7 ms
    93. 64 bytes from 192.168.178.29: icmp_seq=8 ttl=255 time=84.0 ms
    94. 64 bytes from 192.168.178.29: icmp_seq=9 ttl=255 time=107 ms
    95. 64 bytes from 192.168.178.29: icmp_seq=10 ttl=255 time=26.5 ms
    96. --- 192.168.178.29 ping statistics ---
    97. 10 packets transmitted, 10 received, 0% packet loss, time 9014ms
    98. rtt min/avg/max/mdev = 16.186/58.921/106.644/29.461 ms
    Alles anzeigen
    sieht eigentlich ok aus.
    ich habe jetzt auch die 32-bit Treiber installiert, obwohl die debugs auf das lib64 Verzeichnis gehen.
    Keine Änderung

    Für den Inhalt des Beitrages 140029 haftet ausdrücklich der jeweilige Autor: r3z5

  • r3z5 schrieb:

    kann es sein, dass hier ein Typo vorhanden ist?
    Brother erwartet: libusb-0.1-4
    installiert wird: libusb-0_1-4
    oder ist das hier egal?
    Das ist eine gute Frage!
    Ist die Schreibweise hier egal, wer weiß das? (Ob mit Punkt oder Unterstrich nach der Null?)



    Wenn es die libusb vielleicht nicht ist, könnte es also das SANE Paket sein?
    Also
    sane-backends 1.0.27-5.9 --> 1.0.27-5.11
    sane-backends-autoconfig 1.027-5.9 --> 1.0.27-5.11


    Leider fehlt mir das Knowhow, um hier weiter zu untersuchen.
    Kann man irgendwie beim aktuellen System die neue SANE Version deinstallieren und die alte Version wieder installieren? Ist das sinnvoll, oder zieht man sich dabei neue Fehler(quellen) ins System?

    LG

    Für den Inhalt des Beitrages 140034 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • AlphaLemmi schrieb:

    r3z5 schrieb:

    kann es sein, dass hier ein Typo vorhanden ist?
    Brother erwartet: libusb-0.1-4
    installiert wird: libusb-0_1-4
    oder ist das hier egal?
    Das ist eine gute Frage!Ist die Schreibweise hier egal, wer weiß das? (Ob mit Punkt oder Unterstrich nach der Null?)



    Wenn es die libusb vielleicht nicht ist, könnte es also das SANE Paket sein?
    Also
    sane-backends 1.0.27-5.9 --> 1.0.27-5.11
    sane-backends-autoconfig 1.027-5.9 --> 1.0.27-5.11


    Leider fehlt mir das Knowhow, um hier weiter zu untersuchen.
    Kann man irgendwie beim aktuellen System die neue SANE Version deinstallieren und die alte Version wieder installieren? Ist das sinnvoll, oder zieht man sich dabei neue Fehler(quellen) ins System?

    LG
    Gelesen?
    Und wenns vorher funktioniert hat......

    Sauerland schrieb:

    r3z5 schrieb:

    apt-get install libusb-0.1-4
    Das sieht nach Debian aus.......

    Mal sane-backends von hier versuchen:
    Index of /repositories/home:/Sauerland:/branches:/home:/Sauerland/openSUSE_Tumbleweed_standard
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 140035 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Welchen Teil gelesen?

    Verstehe ich dich richtig und du vermutest beim "apt-get", dass eventuell die .deb Treiber von der Brotherwebsite heruntergeladen wurden?


    Sauerland schrieb:

    Mal sane-backends von hier versuchen:
    Leider weiß ich nicht so recht, wie es sauber geht, Pakete gegen andere auszutauschen (und eventuell sauber wieder zurück zu tauschen).
    --Sollte man das über hinzugefügte Repos machen, also das ich dein Repo in mein System einbinde,
    ODER
    --Sollte ich nur die SANE Pakete bei dir herunterladen, die derzeitigen deinstallieren (zypper remove) und dann deine installieren (rpm ??).


    Vielen Dank für das Verständnis, dass ich mit GNU/Linux sowie OpenSuse noch recht unbeholfen bin:)

    Für den Inhalt des Beitrages 140037 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • AlphaLemmi schrieb:

    -Sollte man das über hinzugefügte Repos machen, also das ich dein Repo in mein System einbinde,
    Ja
    als root:

    Quellcode

    1. zypper ar -f https://download.opensuse.org/repositories/home:/Sauerland:/branches:/home:/Sauerland/openSUSE_Tumbleweed_standard/ Sauerland_branch

    Quellcode

    1. zypper in -f sane-backends
    Wenn es nicht geht, einfach das Repo im Yast löschen und noch einmal den zypper in Befehl
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 140038 haftet ausdrücklich der jeweilige Autor: Sauerland

  • AlphaLemmi schrieb:

    Vielen Dank für das Verständnis, dass ich mit GNU/Linux sowie OpenSuse noch recht unbeholfen bin:)
    Das entspricht dann aber nicht dem von openSUSE angesprochenen Tumbleweed User:
    Portal:Tumbleweed
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 140039 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Warum muss das Paket libieee1284 ebenfalls installiert werden?

    Quellcode

    1. Das folgende NEUE Paket wird installiert:
    2. libieee1284
    3. Das folgende Paket wird aktualisiert:
    4. sane-backends
    5. Das folgende Paket wird den Anbieter ändern:
    6. sane-backends openSUSE -> obs://build.opensuse.org/home:Sauerland

    Für den Inhalt des Beitrages 140040 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • Sauerland schrieb:

    Das entspricht dann aber nicht dem von openSUSE angesprochenen Tumbleweed User:
    Portal:Tumbleweed
    Nunja, ganz unerfahren bin ich nun auch nicht. Außerdem sehr lernwillig:)
    Ich denke, dass hast du im Eingangspost vielleicht schon erkennen können. Habe wirklich, wie geschrieben, seit ein paar Tagen im Web recherchiert und verschiedenste Dinge ausprobiert :)

    Übrigens: Unter Leap gab es das gleiche Problem:(
    Habe es an einem Tuxedo Laptop probiert.
    Kommando zurück: Wenn der Laptop (Leap) am LAN-Kabel angeschlossen ist, funktioniert der Scan.

    Installiert sind auf dem Laptop:
    sane-backends 1.0.27-lp151.5.3
    sane-backends-autoconfig 1.0.27-lp151.5.3
    brscan-skey 0.2.4-1
    brscan4 0.4.8-1
    libusb-1_0-0 1.0.21-lp151.2.3
    libusbmuxd4 1.0.10-lp151.4.3
    libusbredirhost1 0.7.1-lp151-2-2
    libusbredirparser1 0.7.1-lp151-2-2

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von AlphaLemmi ()

    Für den Inhalt des Beitrages 140041 haftet ausdrücklich der jeweilige Autor: AlphaLemmi