apache php-fpm file not found

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema apache php-fpm file not found gibt es 1 Antwort.
  • apache php-fpm file not found

    Hallo,

    ich habe vorrübergehend für die lokale Entwicklung den LAMP Stack eingerichtet.
    Meine Projekte liegen unter /home/thomas/Projekte und jeder Unterodner davon stellt einen vhost dar. Dafür habe lasse ich apache und fpm unter Benutzer thomas und Gruppe users laufen.

    Allerdings erhalte ich nur ein schmales "File not found.".

    Der vhost sieht folgendermaßen aus, welche ich von der template Datei kopiert hatte:

    Quellcode

    1. <VirtualHost 127.0.0.1:80>
    2. ServerAdmin webmaster@dummy-host.example.com
    3. ServerName "ackc.local"
    4. DocumentRoot "/home/thomas/Projekte/meinprojekt/public"
    5. ErrorLog /var/log/apache2/meinprojekt.local-error_log
    6. CustomLog /var/log/apache2/meinprojekt.local-access_log combined
    7. <FilesMatch \.php$>
    8. SetHandler "proxy:fcgi://127.0.0.1:9000"
    9. </FilesMatch>
    10. HostnameLookups Off
    11. UseCanonicalName Off
    12. ServerSignature On
    13. ScriptAlias /cgi-bin/ "/srv/www/vhosts/dummy-host.example.com/cgi-bin/"
    14. <Directory "/srv/www/vhosts/dummy-host.example.com/cgi-bin">
    15. AllowOverride None
    16. Options +ExecCGI -Includes
    17. <IfModule !mod_access_compat.c>
    18. Require all granted
    19. </IfModule>
    20. <IfModule mod_access_compat.c>
    21. Order allow,deny
    22. Allow from all
    23. </IfModule>
    24. </Directory>
    25. <IfModule mod_userdir.c>
    26. UserDir public_html
    27. Include /etc/apache2/mod_userdir.conf
    28. </IfModule>
    29. <Directory "/home/thomas/Projekte/meinprojekt/public">
    30. Options Indexes FollowSymLinks
    31. AllowOverride All
    32. DirectoryIndex index.php showpare.php index.html
    33. <IfModule !mod_access_compat.c>
    34. Require all granted
    35. </IfModule>
    36. <IfModule mod_access_compat.c>
    37. Order allow,deny
    38. Allow from all
    39. </IfModule>
    40. </Directory>
    41. </VirtualHost>
    Alles anzeigen



    Die www.conf von php-fpm sieht so aus:

    Quellcode

    1. [www]
    2. user = thomas
    3. group = users
    4. listen = 127.0.0.1:9000
    5. listen.allowed_clients = 127.0.0.1
    6. pm = dynamic
    7. pm.max_children = 5
    8. pm.start_servers = 2
    9. pm.min_spare_servers = 1
    10. pm.max_spare_servers = 3
    11. security.limit_extensions =
    Alles anzeigen
    Wie man sieht habe ich auch security.limit_extensions leer gelassen, um alle Dateien zu erlauben, was auch ab und zu den Fehler auslöst.

    Das public Verzeichnis von allen Benutzern lesbar und ausführbar (r-x), also Apache sollte es auflisten können bzw. reinblicken können.

    Im error_log finde ich nur folgendes:

    Quellcode

    1. [proxy_fcgi:error] [pid 10241] [client 127.0.0.1:51356] AH01071: Got error 'Primary script unknown'
    Auch wie manche meinten, brachte ein System Neustart in meinen Fall nichts. Für Hilfe dazu wäre ich dankbar.

    MFG

    derwunner
    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 140472 haftet ausdrücklich der jeweilige Autor: derwunner

  • Moin zusammen,

    schau mal hier ob Dir das weiterhilft:
    debianforum.de/forum/viewtopic.php?t=174245

    Mit Folgendem kannst du nachsehen wo Apache versucht das File zu finden:

    Quellcode

    1. tcpdump port 9001 -A | strings

    Und schau Dir mal bitte Folgendes an in Deiner Config des Apache2:
    UserDir public_html

    Bedeutet, Apache erwartet in Deinem Homeverzeichnis ein Unterverzeichnis public_html DORT und nirgends sonst (ausser im Standardverzeichnis /srv/www) sucht der Indianer Deine Webseiten.

    Du aber gehst nach /home/thomas/Projekte/meinprojekt/public als Server Root Deiner Webseite.
    Da kann der Indianer nix finden weil der dort gar nicht erst danach sucht!
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 140851 haftet ausdrücklich der jeweilige Autor: Tamerlain