wllan läuft mit ifup aber nicht mit knetworkmanager

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema wllan läuft mit ifup aber nicht mit knetworkmanager gibt es 13 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • wllan läuft mit ifup aber nicht mit knetworkmanager

    Liebe openSuse Gemeinde,

    erstmal eine gesundes und erfolgreiches neues Jahr. Bin neu im Forum und ein Linux-Anfänger.
    Ich schlage mich schon ein paar Tage erfolglos mit einem Netzwerkproblem rum.
    Habe auf einem Dell E6510 laptop openSuse 11.3 - 64bit installiert und versuche vergeblich das wlan mit dem knetworkmanager zum Laufen zu bringen.
    Netzwerkkarte: Intel Centrino Advanced-N 6200 Treiber: iwlagn
    Mit ifup hat es funktioniert, da ich in verschiedenen Netzwerken unterwegs bin, wollte ich auf knetworkmanager umstellen - SCPM gibt es ja LEIDER nicht mehr.

    Was habe ich gemacht?
    - in Yast beide Netzwerkkarten deaktiviert, dann auf Netzwerkmanager zurückgestellt
    - in 'Network Settings' 'wireless' konfiguriert, mit WPA und DHCP - lief unter ifup auch.
    - ach ja, kdewallet hat sich gemeldet. Nachdem ich im Zweifel war, ob die Probleme durchs 'wegclicken' verursacht werden, verwende ich es jetzt.
    - nachdem nach restart kein networkmanager icon in der Taskleiste erschien, lasse ich knetworkmanager durch 'Autostart' starten.

    Ergebnis: das icon erscheint aber 'Network Management disabled'
    alle Einstellungen wurden als root gemacht

    Ich sollte noch erwähnen, das es zwischenzeitlich sogar mal funktioniert hat. Allerdings musste die Verbindung immer erst als root gestartet werden, damit sie als user benutzt werden konnte. Ich bin dann auf das nette tool 'collectNWData' gestossen. Das sagte mir, dass noch ifup Konfigurationsfiles existierten. Nachdem ich die Netzwerkkarten (unter ifup) deaktiviert hatte, ging nichts mehr. Der Zustand läßt sich auch nicht mehr reproduzieren. Die angehängte collectNWData.txt bezieht sich auf den aktuellen Zustand. Leider hilft mir die Diagnose nicht weiter, weil ich unter ifup ja eine IP erhalte, so dass auf der Router-Seite alles ok sein sollte.
    Ebenfalls angehängt sind die relevanten Zeilen der iwconfig und lspci Ausgaben und von /var/log/Networkmanager.

    Könnte es sein, dass irgendwas mit der Verschlüsselung nicht funktioniert?
    in /var/log/wpa_supplicant.log finde ich als letzte Eintragung : 'Failed to initiate AP scan'
    Oder ist das ein Folgefehler?


    Vielen Dank fuer Eure Hilfe
    raheri
    Dateien

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von raheri ()

    Für den Inhalt des Beitrages 27729 haftet ausdrücklich der jeweilige Autor: raheri

  • Hi,
    schau doch mal unter Yast in der Netzwerkkarten-Einrichtung einen Haken, der die Gerätesteuerung ohne Root-Rechte erlaubt.
    Gruss, mecky

    Für den Inhalt des Beitrages 27731 haftet ausdrücklich der jeweilige Autor: mecky

  • Hi mecky,

    habe weder im Yast -> Network Settings noch bei Configure Desktop-> Network Settings einen entsprechenden Haken gefunden. Sollte es den geben? Im Moment kriege ich den networkmanager aber nicht mal mehr als root zum Laufen.

    Gruesse
    raheri

    Für den Inhalt des Beitrages 27734 haftet ausdrücklich der jeweilige Autor: raheri

  • Hi,
    Yast - Netzwerkeinstellungen - Übersicht
    dann Wlankarte markieren und auf bearbeiten gehen.
    dann findest du im Reiter Allgemein das Feld.
    Bei dir halt alles auf Englisch
    Gruss,mecky

    Für den Inhalt des Beitrages 27737 haftet ausdrücklich der jeweilige Autor: mecky

  • Hi Martin,

    der link ist sicher nützlich, wenn ich denn mal soweit kommen würde. Leider funktioniert die Einwahl nicht, weil das icon network management deaktiviert anzeigt. Hast Du Deine Netzwerkkarten unter Yast im ifup Modus beide deaktiviert. Das wird nämlich empfohlen - jedenfalls habe ich das so verstanden.
    Meinen Zwischenerfolg hatte ich aber bevor dieser Aktion. Im Yast sehe ich im Menu Hostname/DNS jetzt 'No interface with dhcp'.
    Was mir komisch vorkommt.

    Viele Gruesse
    raheri

    Für den Inhalt des Beitrages 27739 haftet ausdrücklich der jeweilige Autor: raheri

  • Danke mecky,

    da steht bei mir 'Enable device control for Non-root User Via Qinternet', was ich auch installiert hatte. Allerdings fuhrwerke ich jetzt wieder im ifup modus rum. Ich dachte, das ist wirkungslos wenn man die Kontrolle über den Networkmanager ausübt. Hast Du Deine Netzwerkkarten im Yast noch aktiv oder deaktiviert?
    Wie gesagt, momentan kriege ich das selbst als root nicht hin.

    Viele Gruesse
    raheri

    Für den Inhalt des Beitrages 27745 haftet ausdrücklich der jeweilige Autor: raheri

  • Hi,
    ich benutze ifup, da ich nicht zwischen verschiedenen Netzen wechsel muss.
    Aber die Karten müssen schon aktiv sein.
    Gruss,
    mecky

    Für den Inhalt des Beitrages 27747 haftet ausdrücklich der jeweilige Autor: mecky

  • Hi,
    wenn ich die wlan Karten aktiviere (um den Haken zu setzen) muss ich sie auch konfigurieren. Das geht nur unter Yast/ifup. Wenn ich hinterher auf Netzwerkmanager-Kontrolle wechsle, bringt mir das Diagnose Tool 'collectNMData' schon den Fehler, dass noch ifup Konfigurationsdateien existieren. Irgendwas stimmt da nicht.
    Gruesse
    raheri

    Für den Inhalt des Beitrages 27749 haftet ausdrücklich der jeweilige Autor: raheri