Seit 11.4 keine Lüftersteuerung über /proc/acpi/fan

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Seit 11.4 keine Lüftersteuerung über /proc/acpi/fan gibt es 3 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Seit 11.4 keine Lüftersteuerung über /proc/acpi/fan

    Hallo,

    bei openSUSE 11.3 konnte ich den Lüfter z.B. mit

    Quellcode

    1. echo -n 1 > /proc/acpi/fan/FAN/state
    drosseln.

    Seit der Neuinstallation von 11.4 gibt es bei /proc/acpi aber gar kein Verzeichnis "fan" mehr , sondern nur die Verzeichnisse ac_adapter, battery, button und processor. Ich brauche die Lüftersteuerung dringend, weil mein Lüfter dauerlärmt.

    Weiß jemand Rat?

    Marty

    Für den Inhalt des Beitrages 29364 haftet ausdrücklich der jeweilige Autor: Marty615

  • Hi,
    ich habe das selbe Problem und weis nicht wie ich den Lüfter leise bekomme. Mit Win ging der automatisch aus und bei Suse ging der noch nie aus. Ich habe gehört das da entweder irgend ein Drehzahlregler kaputt ist oder kein Treiber installiert (evtl. auch nicht richtig installiert ist). Mehr kann ich auch nicht sagen.

    Für den Inhalt des Beitrages 29423 haftet ausdrücklich der jeweilige Autor: chrismartindd

  • Ja, das kenn ich. Bei openSUSE 11.3 habe ich es jedoch geschafft. Der Grund war bei meinem Notebook (Fujitsu Amilo) eine fehlerhafte Konfiguration (DSDT), die aus dem BIOS ausgelesen wird. Man findet jedoch im Internet Anleitungen, wie man die manuell korrigieren kann. Danach konnte ich wie oben beschrieben den Lüfter steuern und auch eine automatische Regelung aktivieren.
    Aber wie gesagt: Jetzt gibt es das fan-Verzeichnis nicht mehr :(

    Für den Inhalt des Beitrages 29432 haftet ausdrücklich der jeweilige Autor: Marty615

  • Hallo Leute,
    ich hatte dasselbe Problem: Zwei Notebook-Lüfter, die ständig laufen und sich nicht leisestellen lassen. Ich habe es mittlerweile folgendermaßen gelöst:

    In die "kernel"-Zeile von /boot/grub/menu.lst den Eintrag

    acpi_osi=Linux

    hintenanhängen (irgendwo im Netz gefunden). Meine beiden Lüfter sind im Filesystem unter

    /sys/devices/virtual/thermal/cooling_device1 und
    /sys/devices/virtual/thermal/cooling_device2

    zu finden und haben jeweils den Zustand ("cur_state") "0" (aus) oder "1" (an). Nach dem Rebooten des Computers (um obige boot-Option zu laden), gebe ich den Lüftern "einen Tritt", indem ich

    echo -n 1 > /sys/devices/virtual/thermal/cooling_device1/cur_state
    echo -n 0 > /sys/devices/virtual/thermal/cooling_device1/cur_state

    eingebe. Das schaltet den Lüfter 1 aus, der Lüfter 2 schaltet sich bei mir automatisch gleich mit ab (sonst gibt man die beiden Zeilen halt auch für cooling_device2 ein...). Jetzt funktioniert die Lüftung so, wie es vom BIOS geregelt ist, d.h. sie gehen bei bestimmten Temperaturen an, und dann wieder aus, und wieder an....

    Um das nicht jedesmal händisch machen zu müssen, habe ich die beiden Zeilen in das Startskript /etc/init.d/acpid eingetragen, dann wird das beim Booten automatisch ausgeführt. Damit die Lüftung auch nach dem Aufwachen aus dem Suspend To RAM richtig funktioniert, habe ich die beiden Zeilen auch noch in

    /usr/lib/pm-utils/sleep.d/80acpi-fan

    eingetragen (alle anderen Befehle in dem Skript kann man herauskommentieren, denn die betreffen noch das alte System, bei dem die Lüfter unter /proc/acpi/fan ... zu finden waren).
    Dann mußte ich aber den File 80acpi-fan noch nach 47acpi-fan verschieben (trial and error...), damit er beim Aufwachen an der "richtigen" Stelle ausgeführt wird.

    Ich hoffe, das hilft Euch! Beste Grüße
    Wolfgang

    Für den Inhalt des Beitrages 31107 haftet ausdrücklich der jeweilige Autor: wolfgang.j