Ein Problem mit DosBox unter OpenSuse 11.3

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Ein Problem mit DosBox unter OpenSuse 11.3 gibt es 2 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Ein Problem mit DosBox unter OpenSuse 11.3

    Hallo Zusammen,
    nachdem ich ein Update auf OpenSuse 11.3 gemacht habe, habe ich festgestellt, dass mein DosBox nicht mehr läuft. Es zeigt sich folgende Meldung:

    Quellcode

    1. DOSBox version 0.74
    2. Copyright 2002-2010 DOSBox Team, published under GNU GPL.
    3. ---
    4. CONFIG:Loading primary settings from config file /home/corvus/.dosbox/dosbox-0.74.conf
    5. MIXER:Got different values from SDL: freq 44100, blocksize 940
    6. ALSA:Can't subscribe to MIDI port (65:0) nor (17:0)
    7. MIDI:Opened device:none
    8. DOSBox switched to max cycles, because of the setting: cycles=auto. If the game runs too fast try a fixed cycles amount in DOSBox's options.
    9. Speicherzugriffsfehler

    Ich habe keine Änderungen in der Config-Datei vorgenommen.
    Kennt Jemand eine Lösung?
    Kra kra, ich bin da!

    Acer TravelMate 7730, Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz, openSUSE 13.1 (x86_64), KDE 4.11.5, [GeForce 9300M GS], NVIDIA 310.44

    forum.suse.pl/index.php

    Für den Inhalt des Beitrages 30017 haftet ausdrücklich der jeweilige Autor: Kruk

  • Ich habe das Problem nur teilweise gelöst, nachdem ich timidity eingespielt habe. Es zeigt sich, dass:

    Quellcode

    1. ONFIG:Loading primary settings from config file /home/corvus/.dosbox/dosbox-0.74.conf
    2. MIXER:Got different values from SDL: freq 44100, blocksize 940
    3. ALSA:Client initialised [128:0]
    4. MIDI:Opened device:alsa

    Die Ausgabe von aplaymidi -l liefert:

    Quellcode

    1. Port Client name Port name
    2. 14:0 Midi Through Midi Through Port-0

    Ich habe kein Potr 128:0 und das Problem ist weiterhin vorhanden:

    Quellcode

    1. ALSA lib pcm.c:7245:(snd_pcm_recover) underrun occured
    2. DOSBox switched to max cycles, because of the setting: cycles=auto. If the game runs too fast try a fixed cycles amount in DOSBox's options.
    3. Speicherzugriffsfehler
    Kra kra, ich bin da!

    Acer TravelMate 7730, Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz, openSUSE 13.1 (x86_64), KDE 4.11.5, [GeForce 9300M GS], NVIDIA 310.44

    forum.suse.pl/index.php

    Für den Inhalt des Beitrages 30057 haftet ausdrücklich der jeweilige Autor: Kruk

  • Ich habe zufällig eine Lösung gefunden. Man muss core=auto auf core=normal in der Config-Datei setzen. Dann läuft's. Ich weiß aber nicht warum?
    Kra kra, ich bin da!

    Acer TravelMate 7730, Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz, openSUSE 13.1 (x86_64), KDE 4.11.5, [GeForce 9300M GS], NVIDIA 310.44

    forum.suse.pl/index.php

    Für den Inhalt des Beitrages 30099 haftet ausdrücklich der jeweilige Autor: Kruk