Boot Problem - initrd haengt sich auf!

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Boot Problem - initrd haengt sich auf! gibt es 4 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Boot Problem - initrd haengt sich auf!

    Hallo liebe Community,

    ich habe ein sehr eigenartiges Problem. Ich benutze GRUB auf einem RAID-System (2 Platten als 1 grosse angeschlossen) um meine openSUSE 11.4 zu starten. Als Chainloader habe ich auch eine Win7 Platte installiert die voellig unabhaengig auf einer eigenen HD laeuft (mit eigenem Bootloader auf der Platte).

    Jetzt passiert halt dass mein Linux nur bootet wenn ich nach dem PC-Anschalten die Win7 Platte zuerst boote und dann reboote und openSUSE im GRUB starte. Wenn ich direkt nach dem Einschalten openSUSE im GRUB Menu auswaehle, laedt das System den Kernel, dann die initrd und nachdem steht wieviele Byte geladen sind - FREEZE! Man kann nichts mehr machen, nur Reset-Button hilft.

    Das passiert seit ich neuerdings mehrere Kernels rauf und runter-installiert hatte um VMWARE Server zu kompilieren. Ich hatte auch einen Kernel manuell kompiliert, aber hatte ihn nicht benutzt und mich doch auf das standardmaessige Dektop Kernel gestuezt. Es koennte sein dass das irgendwie etwas veraendert hat. Das System lief einwandfrei bis zu dieser Kernel-Kompilierung und mkinitrd Aufrufen.

    Ich hatte die Boot-Partition neuformatiert und GRUB neuinstalliert. Alle Kernels runter und den Desktop Kernel wieder drauf (default Kernel muss halt auch immer bleiben). Habe an diversen BIOS Einstellungen was AHCI/SATA/Jmicron/etc... betrifft rumgespielt, aber ohne Erfolg. Ich habe solch ein Problem noch nicht woanders gesehen und darum bitte ich euch um Eueren Rat.

    Peace!

    :smilie_pc_057:

    Für den Inhalt des Beitrages 32960 haftet ausdrücklich der jeweilige Autor: Rock_Strongo

  • Hab mir die Log-Datei angeschaut, wenn das Ding mal richtig bootet.
    Unter /var/log/boot.msg steht u.A. :

    Notice: NX (Execute Disable) protection missing in CPU or disabled in BIOS!

    Hat jemand hier ne Ahnung was das bedeutet? Kann es sein dass ich das ausgeschaltet habe im BIOS? Der Linux-Boot funzt immer noch nicht. Es reicht nicht aus, die win7 Platte kurz anzubooten und dann mit STR-ALT-ENTF neuzustarten und dann Linux zu starten. Nein, die win7 Platte muss bis zum Windows durchladen und dann bei Neustart geht Linux wieder. Ich will nicht jedesmal Windows starten um an Linux ranzukommen. Hat keiner hier eine Idee? :smilie_pc_153:

    Für den Inhalt des Beitrages 33200 haftet ausdrücklich der jeweilige Autor: Rock_Strongo

  • als Bootparameter oder im failsafe mode versuchen.
    Seit 11.4 und kernel 2.6.37 startet alles das ich kenne mit nomodeset.
    Damit konfiguriert der Kernel nicht automatisch.
    Ich kenne aber nicht alles.

    Für den Inhalt des Beitrages 33201 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Hat alles nix geholfen. Es liegt ws. am Southbridge des Motherboards (ASUS P5 WDH DELUXE) und der aktuellen Festplattenkonfiguration. Wenn ich die 500 GB Platte mit Win7 drauf ausstoepsel, bootet Linux ohne Probleme.
    Trotzdem danke fuer den Vorschlag.

    Für den Inhalt des Beitrages 33816 haftet ausdrücklich der jeweilige Autor: Rock_Strongo