Sprache/Tastatur/LDAP mit yast2 auf der Kommandozeile einstellen schägt fehl

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Sprache/Tastatur/LDAP mit yast2 auf der Kommandozeile einstellen schägt fehl

    Hallo,

    ich versuche bisher erfolglos, das Tastaturlayout, die Sprache und LDAP per Kommandozeile über yast2 zu konfigurieren. Da die Konfiguration über ein Skript erfolgen soll, kann ich keine GUI (ach keine Text-GUI) brauchen. yast2 bringt auch entsprechende Funktionen mit, die aber nicht funktionieren.

    Mit

    yast2 keyboard set layout=german
    yast2 language set lang=de_DE

    sollte sich das Tatstaurlayout und die Sprache auf Deutsch einstellen lassen. Leider bleibt es bei US-Englisch. Stelle ich in /etc/X11/xorg.conf.d/90-keytable.conf das Layout auf "de", so wird es beim Neustart wieder auf "us" gesetzt.

    Rufe ich

    yast2 keyboard summary
    yast2 language summary

    auf, so wird bestätigt, daß "Deutsch" eingestellt ist. Die Tastatur ist aber Englisch. Benutze ich die yast2-Text-GUI, wird die Sprache richtig eingestellt.


    LDAP ist ebenso fehlerhaft (hier geht auch die Text-GUI nicht):

    yast2 ldap pam enable server="192.168.1.2" base="dn=nodomain" tls=no mkhomedir=yes
    yast2 ldap pam enable

    Debian/Ubuntu-Systeme können sich an dem LDAP-Server problemlos anmelden.

    Sind das Bugs?

    Gibt es Workarounds oder mache ich etwas falsch?

    Wäre super, wenn mir jemand helfen könnte.

    Hauke

    Für den Inhalt des Beitrages 33730 haftet ausdrücklich der jeweilige Autor: hh42

www.cyberport.de