Wlan unter OpenSuse 12.1 RC2

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Wlan unter OpenSuse 12.1 RC2 gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Wlan unter OpenSuse 12.1 RC2

    ich hab bei einem freund OpenSuse 12.1 RC2 installiert,hat gut geklappt,allerdings:
    WLan im Yast kofigurieren klappt nicht,muss ich mich dannach neu anmelden oder so?
    kann es sein dass es einfach nur bei firefox nicht klappt ich hab von fällen gelesen da gings im yast,hab das allerdings leider nicht ausprobiert.
    kann es an seinem Telekom Speedport liegen?,man liest ja öfters probleme mit alice und außerdem ist das ding allgemein ziemlich ärgerlich,soll öfters ausfallen etc.

    realtek rtl8191 se wireless lan 802.11n pci-e-ni

    collectNWData.sh geht auch nicht,ich habs ihm im icq dirigiert wie ers aus der konsole öffnet:
    komischerweise hieß es keine rechte dafür,dabei kann ich es hier auch als normaluser ausführen.
    na gut,dann eben sudo,hier weiß ich nicht genau was er meinte,der musste das mit dem iphone mir schreiben also so wie ich das verstanden hab hat das skript gefragt ob es iwas installiern soll,bei ja ging ne das yast mit der repository liste auf,bei nein ging kwrite auf .
    wer das skript kennt weiß dass sich das anders gehört und das dirigieren ist einfach zu lästig ich will wenn ich schon komme gut vorbereitet sein also:


    -soll ich per cd auf die stabile version updaten (ungern,muss keinen rohling verschwenden)
    -stimmt da vll auch iwas mit ipv6 nicht?
    -was soll das mit dem skript? ich wollt es eigentlich hier posten aber dazu muss es erstmal laufen
    -kann es sein dass ich zusätzliche WLAN karten treiber brauche?wenn ja gibt es welche dafür und wo kann ich sie aus dem browser downloaden(also am besten gleich der download link),um sie auf nem stick mitzunehmen und zu installieren?(die treiber sind allerdings bestimmt für die stabile version ich weiß nicht ob das was ausmacht aber wenn muss ich wohl die stabile version brennen und von der cd updaten)
    -gibt es beim updaten von der cd sowas ähnliches wie den installer ich hab so noch nie geupdatet
    -oder sonstige ideen?

    Für den Inhalt des Beitrages 36748 haftet ausdrücklich der jeweilige Autor: Hubert Hupkonzert

  • Hast Du das Script ausführbar gemacht?
    Du kannst es auch als User starten, es wird dann nach dem Passwort gefragt.
    Bist Du im richtigen Verzeichnis?

    Zum Wlan:
    Als erstes würde auch mal die Ausgabe von:

    Quellcode

    1. /usr/sbin/hwinfo --wlan

    bzw.

    Quellcode

    1. lsusb

    helfen (hwinfo evtl. nachinstallieren).

    Bring erstmal den Stick zum laufen bevor Du ein Update machst.

    PS:
    Mein Speedport läuft ohne Probleme allerdings mit der Telekom als Provider.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 36752 haftet ausdrücklich der jeweilige Autor: Sauerland

  • das skript muss bei mir nicht ausführbar gemacht werden,ich starte es einfach aus der konsole,hab 11.3 mit mit hwinfo kann ich morgen vll dienen,ich glaub da komm ich dann mal besuchen.wie kann man hwinfo nachinstallieren??ich hab ja dort kein internet es is ein fester PC und es ist kein Kabel verlegt

    achja und was für ein stick??

    Für den Inhalt des Beitrages 36753 haftet ausdrücklich der jeweilige Autor: Hubert Hupkonzert

  • hwinfo von CD nachinstallieren.

    Hab mich vertan, ist ja pci
    Also:

    Quellcode

    1. lspci -nnk

    als root statt lsusb.

    Bei mir muß ich das Script erst ausführbar machen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 36754 haftet ausdrücklich der jeweilige Autor: Sauerland

  • soo ich war mal dort und nachdem ich die stabile version installiert hatte

    hwinfo --wlan:

    int.7: hdb
    > int.12: udev

    PHP-Quellcode

    1. 25: PCI 400.0: 0282 WLAN controller
    2. [Created at pci.319]
    3. Unique ID: y9sn.6hYtgnRUOv8
    4. Parent ID: hoOk.xs8MJGcRAY2
    5. SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:04:00.0
    6. SysFS BusID: 0000:04:00.0
    7. Hardware Class: network
    8. Model: "Realtek WLAN controller"
    9. Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
    10. Device: pci 0x8172
    11. SubVendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
    12. SubDevice: pci 0x8172
    13. Revision: 0x10
    14. Driver: "rtl8192se"
    15. Driver Modules: "rtl8192se"
    16. Device File: wlan0
    17. Features: WLAN
    18. I/O Ports: 0xc800-0xc8ff (rw)
    19. Memory Range: 0xfeafc000-0xfeafffff (rw,non-prefetchable)
    20. IRQ: 18 (no events)
    21. HW Address: 1c:4b:d6:42:a1:d5
    22. Link detected: no
    23. WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
    24. WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
    25. WLAN encryption modes: WEP40 WEP104 TKIP CCMP
    26. WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    27. Module Alias: "pci:v000010ECd00008172sv000010ECsd00008172bc02sc80i00"
    28. Driver Info #0:
    29. Driver Status: rtl8192se is active
    30. Driver Activation Cmd: "modprobe rtl8192se"
    31. Config Status: cfg=no, avail=yes, need=no, active=unknown
    32. Attached to: #10 (PCI bridge)
    Alles anzeigen


    lspci -nnk:

    PHP-Quellcode

    1. linux-8knb:/home/rainer # lspci -nnk
    2. 00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
    3. Subsystem: Wistron Corp. Device [17c0:10d0]
    4. 00:01.0 PCI bridge [0604]: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port [8086:2a41] (rev 07)
    5. Kernel driver in use: pcieport
    6. 00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
    7. Subsystem: Wistron Corp. Device [17c0:10d0]
    8. Kernel driver in use: uhci_hcd
    9. 00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
    10. Subsystem: Wistron Corp. Device [17c0:10d0]
    11. Kernel driver in use: uhci_hcd
    12. 00:1a.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
    13. Subsystem: Wistron Corp. Device [17c0:10d0]
    14. Kernel driver in use: uhci_hcd
    15. 00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
    16. Subsystem: Wistron Corp. Device [17c0:10d0]
    17. Kernel driver in use: ehci_hcd
    18. 00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
    19. Subsystem: Wistron Corp. Device [17c0:10d0]
    20. Kernel driver in use: snd_hda_intel
    21. 00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
    22. Kernel driver in use: pcieport
    23. 00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
    24. Kernel driver in use: pcieport
    25. 00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
    26. Kernel driver in use: pcieport
    27. 00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
    28. Kernel driver in use: pcieport
    29. 00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
    30. Kernel driver in use: pcieport
    31. 00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
    32. Kernel driver in use: pcieport
    33. 00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
    34. Subsystem: Wistron Corp. Device [17c0:10d0]
    35. Kernel driver in use: uhci_hcd
    36. 00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
    37. Subsystem: Wistron Corp. Device [17c0:10d0]
    38. Kernel driver in use: uhci_hcd
    39. 00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
    40. Subsystem: Wistron Corp. Device [17c0:10d0]
    41. Kernel driver in use: uhci_hcd
    42. 00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
    43. Subsystem: Wistron Corp. Device [17c0:10d0]
    44. Kernel driver in use: ehci_hcd
    45. 00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
    46. 00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
    47. Subsystem: Wistron Corp. Device [17c0:10d0]
    48. 00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
    49. Subsystem: Wistron Corp. Device [17c0:10d0]
    50. Kernel driver in use: ahci
    51. 00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
    52. Subsystem: Wistron Corp. Device [17c0:10d0]
    53. Kernel driver in use: i801_smbus
    54. 03:00.0 Multimedia controller [0480]: Philips Semiconductors SAA7231 [1131:7231] (rev ca)
    55. Subsystem: Creatix Polymedia GmbH Device [16be:0013]
    56. 04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller [10ec:8172] (rev 10)
    57. Subsystem: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller [10ec:8172]
    58. Kernel driver in use: rtl8192se
    59. 07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
    60. Subsystem: Wistron Corp. Device [17c0:10d0]
    61. Kernel driver in use: r8169
    62. 08:00.0 VGA compatible controller [0300]: nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2)
    63. Subsystem: Wistron Corp. Device [17c0:10d0]
    64. Kernel driver in use: nouveau
    65. 08:00.1 Audio device [0403]: nVidia Corporation High Definition Audio Controller [10de:0be2] (rev a1)
    66. Subsystem: Wistron Corp. Device [17c0:10d0]
    67. Kernel driver in use: snd_hda_intel
    Alles anzeigen


    collectNWData ist im anhang

    collectNWData empfiehl mir besser den network manager zu benutzen,der ging allerdings nicht bis ich draufkam,dass ich nach dem umstellen auf NetworkManager rebooten muss.zuerst funktionierte es,aber nach ner halben minute gings auf einmal nicht mehr,als ich im yast repos einrichten wollte.also möglicherweise liegts am yast oder es funktioniert von selber nicht mehr.ich habe ebenfalls den bug dass keine netzwerke angezeigt werden,davon hab ich aber schon gelesen also wollt ich wieder verbinden hab deaktiviert und aktiviert,doch der verbindungsstatus blieb bei "autorisierung wird erwartet" hängen.also der ganze status:

    PHP-Quellcode

    1. Typ:
    2. Drahtlos 802.11
    3. Verbindungsstatus:
    4. Autorisierung wird erwartet
    5. IP-Adresse:
    6. Keine IP-Adresse.
    7. Verbindungsgeschwindigkeit:
    8. Unbekannt
    9. Systemname:
    10. wlan0
    11. MAC-Adresse:
    12. 1C:4B:D6:42:A1:D5
    13. Treiber:
    14. rtl8192se
    15. Zugangspunkt (SSID):
    16. WLAN-0BEE17
    17. Zugangspunkt (MAC):
    18. 00:1D:19:0B:EE:34
    19. Band:
    20. b/g
    21. Channel:
    22. 1 (2412 MHz)
    Alles anzeigen
    Dateien

    Für den Inhalt des Beitrages 36786 haftet ausdrücklich der jeweilige Autor: Hubert Hupkonzert

  • Der Knetworkmanager läuft nicht:

    Mal als root einloggen und den Knetworkmanager starten, dort kannst Du es auch so einstellen, das sich Benutzer mit Netzwerke verbinden können.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 36821 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Wenn Du den Networkmanager (das plasmoid) benutzen willst, mußt Du die Netzwerkkarten in Yast---Netzwerkgeräte---Netzwerkeinstellungen löschen sodaß sie unkonfiguriert sind, und dort auf Netzwerkmanager umstellen.

    Außerdem sollte im Router die ESSID (SSID) nicht unsichtbar (versteckt) sein.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 37138 haftet ausdrücklich der jeweilige Autor: Sauerland