Installation von openSuSE

Hinweis: In dem Thema Installation von openSuSE gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo,


    ich habe vor ein paar Tagen einen Prozessor Ryzen 5 5600G gekauft und mit diesem auf einem Testsystem openSuSE 15.3 installiert. Dies bevor ich irgendwelche Änderungen am Produktivsystem vornehme.


    Bei dieser Testinstallation bekomme ich es nicht hin, daß die Auflösung auf dem Bildschirm besser ist als 1024x768. Während der Installation selbst verwendet die Installations-Prozedur sehr wohl höhere Bildschirm-Auflösungen, aber das fertige Produkt hat nur noch diese eine (d.h. wenn ich auf Systemeinstellungen->Anzeige und Monitor gehe, dann hat die Combo-Box nur diesen einen Wert).


    Die Frage: An welcher Stellschraube muß ich drehen, damit ich höhere Auflösungen bekomme?


    Wie gesagt: Noch ist es ein Testsystem, ich kann gefahrlos alles mögliche ausprobieren.

    Für den Inhalt des Beitrages 293759 haftet ausdrücklich der jeweilige Autor: Suelkun

  • Was für GRAKA und die Konsoleausgabe von xorg.log wäre hilfreich für den Anfang.

    Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt. Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

    Für den Inhalt des Beitrages 293768 haftet ausdrücklich der jeweilige Autor: Heinz-Peter

  • Zitat

    lkddb pci 1002 1638 .... .... ...... : CONFIG_DRM_AMDGPU : drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c # in 5.11–5.14, 5.15-rc+HEAD

    zu neu. Offiziell von Kernel 5.11 und höher unterstützt.

    Code
    modprobeid 1002 1638
    Kernelmodulname amdgpu
    filename:       /lib/modules/5.14.11-lp153.5.g834dddd-default/kernel/drivers/gpu/drm/amd/amdgpu/amdgpu.ko.xz


    Ich würde kernel:stable:backports hinzufügen:

    Code
    zypper ar -f https://download.opensuse.org/repositories/Kernel:/stable:/Backport/standard/ kernel-stable-backport


    Code
    zypper dup --allow-vendor-change --from kernel-stable-backport

    Neu starten.

    Evtl. musst du bei secure boot noch das Zertifikat in mok bestätigen:

    https://forums.opensuse.org/sh…le)?p=3073187#post3073187


    Oder secure boot im Uefi/Bios ausschalten, erspart auch Ärger und wiegt dich nicht so in Sicherheit........

    Denn so sicher ist das auch nicht.

    Für den Inhalt des Beitrages 293778 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sobald ich dazu komme versuche ich die vorgeschlagene Lösung.


    Wenn ich das richtig verstehe, dann ist von der fehlenden Einsatzbereitschaft des Ryzen 5 5600G unter dem aktuellen openSuSE-Kernel nur die onBoard GPU betroffen. Ganz grundsätzlich funktioniert der Prozessor unter dem aktuellen openSuSE-Kernel aber schon.


    D.h. wenn ich die vorgeschlagene Lösung mit dem Backport nicht hinbekomme, dann könnte ich auch meine Radeon Grafikkarte wieder einbauen. Dann würde der Prozessor / openSuSE diese benutzen. Dann warte ich so lange, bis der Kernel 5.11 kommt (das passiert ja irgendwann). Wenn es dann so weit ist, baue ich die extra Grafikkarte wieder aus und Prozessor / openSuSE benutzen die onBoard-Grafik.


    Das Thema schließe ich damit.

    Für den Inhalt des Beitrages 293787 haftet ausdrücklich der jeweilige Autor: Suelkun

  • Versuch es einfach mit dem neuen Kernel, es ist auch ganz schnell wieder zurückgestellt.....

    ok, habe ich versucht. Ergebnis: Die onBoard Grafik läuft einwandfrei!, jetzt auch mit einer Menge an auswählbaren Auflösungen.


    Ich muß noch ein paar Tests machen (z.B. läuft VMWare auch?) und wenn das alles ok läuft, dann stelle ich auch das Produktivsystem um. Danke für den Hinweis Sauerland!

    Für den Inhalt des Beitrages 293791 haftet ausdrücklich der jeweilige Autor: Suelkun

  • z.B. läuft VMWare auch?

    Nimm Virtualbox, da gibts auch Kernel Module für den kernel:stable:backport.


    vmware und aktuelle Kernel ist immer so eine Sache, oft musst du vmware patchen.

    Für den Inhalt des Beitrages 293792 haftet ausdrücklich der jeweilige Autor: Sauerland