Tumbleweed & Nvidia Problem

Hinweis: In dem Thema Tumbleweed & Nvidia Problem gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Guten Tag opensuse Gemeinde,


    ich habe mir heute opensuse tumbleweed installiert und nach Anweisungen die nvidia Repo hinzugefügt sowie dann den nvidia Treiber von dort bezogen.


    Das System läuft, aber wenn ich z.b. den Rechner starte, kommt kurz eine Sekunde der Anmeldebildschirm und dann geht der Bildschirm aus bzw er findet kein Signal. ABER ich kann eine Passworteingabe tätigen und komme dann auf den Desktop. Da kommt dann wieder das Signal von der Grafikkarte zum Bildschirm.

    Ich kann dann auf dem Desktop arbeiten.


    Wenn ich dann ein Spiel starte, beispielsweise Supertux Karts, startet dieses im Fenstermodus. Wenn ich IM Spiel unter Grafikeinstellungen dann die Auflösung ändere, zur Auflösung meines Desktops, klappt das Spiel weiterhin, im Fenstermodus.

    Wenn ich dieses Spiel dann noch in den Vollbildmodus wechsel, kommt auch ein schwarzer Bildschirm bzw verliert der Monitor das Signal und schaltet sich ab.

    Über Alt + F4 kann ich dann das Spiel beenden und ich komme auf dem Desktop bzw. über ALT und Tab kann ich zu einem anderen Fenster wechseln. Bei beiden Sachen bekommt der Monitor wieder ein Signal.


    Was für Ausgaben der Konsole braucht ihr um mir vielleicht zu helfen?

  • Nachtrag:


    Ich möchte gerne, das dieser schwarze Bildschirm, aufhört, sodass ich z.b. PC Spiele am PC in Vollbild, spielen kann.


    Daher bitte ich euch um Hilfe!

  • Für den Anfang, die Ausgaben von

    Code
    cat /etc/os-release
    Code
    uname -r
    Code
    /sbin/lspci -nnk | grep -EiA3 vga
    Code
    xrandr
    Code
    zypper se -si nvidia
    Code
    zypper lr -d

    hier vorführen.

    Schreibtischrechner: openSUSE Leap 15.4 mit GNOME, geleg. KDE/Plasma

    Klapprechner 1: openSUSE Leap 15.4, GNOME mit Wayland & zurzeit aktuellsten verfügbaren Kernel

    Klapprechner 2: Spielplatz für Versuche/Testungen

    Schneidbrettchen: PineTab mit Arch Linux

    Für den Inhalt des Beitrages 294261 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Code
    # uname -r
    5.14.14-1-default
    Code
    # /sbin/lspci -nnk | grep -EiA3 vga
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU106 [GeForce RTX 2070 Rev. A] [10de:1f07] (rev a1)
            Subsystem: ASUSTeK Computer Inc. Device [1043:8670]
            Kernel driver in use: nvidia
            Kernel modules: nouveau, nvidia_drm, nvidia
    Code
    # xrandr
    Can't open display 
  • Und nach dieser Übersicht bitte noch die Ausgabe von

    Code
    env | grep -E "XDG_SESSION_TYPE|DESKTOP_SESSION"

    Schreibtischrechner: openSUSE Leap 15.4 mit GNOME, geleg. KDE/Plasma

    Klapprechner 1: openSUSE Leap 15.4, GNOME mit Wayland & zurzeit aktuellsten verfügbaren Kernel

    Klapprechner 2: Spielplatz für Versuche/Testungen

    Schneidbrettchen: PineTab mit Arch Linux

    Für den Inhalt des Beitrages 294263 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Und nach dieser Übersicht bitte noch die Ausgabe von

    Code
    env | grep -E "XDG_SESSION_TYPE|DESKTOP_SESSION"
    Code
    ~> env | grep -E "XDG_SESSION_TYPE|DESKTOP_SESSION"
    DESKTOP_SESSION=/usr/share/xsessions/plasma5
    XDG_SESSION_TYPE=x11
  • Code
    # xrandr
    Can't open display 
  • Problem hat sich von alleine gelöst.


    Das System wurde seit Montag nicht mehr benutzt. Jetzt gerade an geschaltet, hatte noch das Problem, aber nach dem langen Update, unter anderem NVIDIA, und einem Neustart konnte ich im Login Fenster mein Pw eingeben ohne das der Bildschirm aus ist und das Spiel Supertux Karts konnte ich auch im Vollbild starten.