Wlan brcmsmac mit BCM4313

Hinweis: In dem Thema Wlan brcmsmac mit BCM4313 gibt es 6 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Moin,


    ich habe mit den Treibern das Problem das die Downloadrate sprunghaft zwischen 0 und 500Kb/s variiert und auch die Requests eher hakelig abgearbeitet werden.


    Hardware: Dell Studio 1558, BCM4313


    Ich habe Parallel seit langem Ubuntu drauf mit dem gleichen Treiber der 1A Max Rate (3,5Mb/s) läuft.


    Man findet irgendwie keine wirklich hilfreichen Tipp.

    Einmal editiert, zuletzt von Schuppeste ()

    Für den Inhalt des Beitrages 297890 haftet ausdrücklich der jeweilige Autor: Schuppeste

  • Poste:

    Code
    /sbin/lspci -nnk | grep -iA3 net

    sowie

    Code
    uname -a

    Dann kann man schauen, ob broadcom-wl funktioniert.

    Für den Inhalt des Beitrages 297891 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Danke.


    Code
    /sbin/lspci -nnk | grep -iA3 net
    04:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
            Subsystem: Dell Inspiron M5010 / XPS 8300 [1028:0010]
            Kernel driver in use: bcma-pci-bridge
            Kernel modules: bcma
    --
    09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 03)
            Subsystem: Dell Device [1028:0413]
            Kernel driver in use: r8169
            Kernel modules: r8169



    Code
     uname -a
    Linux user-Studio-1558 5.3.18-150300.59.49-default #1 SMP Mon Feb 7 14:40:20 UTC 2022 (77d9d02) x86_64 x86_64 x86_64 GNU/Linux

    Für den Inhalt des Beitrages 297892 haftet ausdrücklich der jeweilige Autor: Schuppeste

  • Hast du es mal mit broadcom-wl versucht?


    Packman Repo einbinden und installieren:

    Code
    zypper in -f broadcom-wl broadcom-wl-kmp-default openSUSE-signkey-cert kernel-default-extra kernel-default-optional

    Wenn secure boot angeschaltet ist, musst du im "blauen Startbildschirm" noch das Zertifikat erlauben:

    LEAP 15.3 Help on booting to a 5.14.11 kernel:stable:backports kernel with secure boot? (or must I disable)?

    Für den Inhalt des Beitrages 297894 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich glaube das hatte ich schonmal manuell versucht..


    Weil:

    Code
    sitory 'Update repository with updates from SUSE Linux Enterprise 15'.
    'broadcom-wl' not found in package names. Trying capabilities.
    No provider of 'broadcom-wl' found.
    'broadcom-wl-kmp-default' not found in package names. Trying capabilities.
    No provider of 'broadcom-wl-kmp-default' found.
    Resolving package dependencies...

    Für den Inhalt des Beitrages 297895 haftet ausdrücklich der jeweilige Autor: Schuppeste

  • Das war es wohl, ich bin da eher aus der Fedora/Ubuntu Ecke, da hätte ich den Treiber vom Hersteller wahrscheinlich ohne Hilfestellung selbst kompiliert ;)


    Danke!

    Für den Inhalt des Beitrages 297897 haftet ausdrücklich der jeweilige Autor: Schuppeste