[gelöst] Transcode stürzt beim DVD-Rip mit "invalid pointer" Fehler ab

Hinweis: In dem Thema [gelöst] Transcode stürzt beim DVD-Rip mit "invalid pointer" Fehler ab gibt es 31 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo Leute,


    ich habe über die Weihnachtsferien mein System (AMD Athlon(tm) II X2 260 Processor, 3,2 GHz, 4G RAM) von openSuSE 11.3 auf 11.4 aktualisiert. Leider geht seitdem das Rippen von DVD nicht mehr. k3b meldet, dass es bei Transcode einen "invalid pointer" gegeben haben soll. Die komplette Ausgabe von k3b, aus der auch die verwendeten Versionen von k3b, transcode usw. hervorgehen, habe ich unten angehängt. Die verwndete glibc ist übrigens die 2.11.3-12.21.1 zusammen mit den Patches 4943, 5164 und 5554 aus dem openSuSE-11.4-Update-Repository. Ich habe schon nach dem Problem gegoogelt, aber keine Hilfe gefinden. Hat einer von Euch eine Idee, woran das liegen könnte?


    k3b_Errorlog.txt


    Wichtiger rechtlicher Hinweis: Es handelt es sich hier nicht um ein Problem beim illegalen Auslesen von kopiergeschützten DVD. Das Problem hat mit der libdvdcss m.E. nichts zu tun. Ich möchte eine von meinem Vater erstellte DVD mit privaten Urlaubsaufnahmen rippen. Testweise habe ich das Rippen auch mit einer handelsüblichen Spielfilm-DVD versucht, um sicherzustellen, dass es sich nicht um einen Fehler auf der selbsterstellten DVD handelt; das Problem tritt dort aber in beiden Fällen auf.

    2 Mal editiert, zuletzt von Trekkie00 ()

    Für den Inhalt des Beitrages 37855 haftet ausdrücklich der jeweilige Autor: FD1007

  • Warum nutzt Du für ein solches Vorhaben nicht Programme wie

    Code
    handbrake
    k9copy
    ogmrip
    dvdrip


    Da diese Programme auf solche Aufgaben spezialisiert sind.

  • Ich hatte unter openSuSE 11.3 nie Probleme mit k3b+transcode und war mit den Ergebnissen auch immer zufrieden. Daher habe ich auch nie über Alternativen nachgedacht.


    Nun meine Gegenfrage: Welche der von Dir genannten 4 Alternativen empfiehlst Du mir?


    Was ich in meinem letzten Posting noch vergessen hatte: Ich verwende die 64bit-Variante von openSuSE 11.4.

  • Für solche Aufgaben verwende ich eigentlich immer handbrake (Zielformat mkv).
    Sehr zuverlässig und, wenn gewünscht, sehr detailiert einzustellen.

  • Hier die Ergebnisse:


    ffmpeg wurde übrigens erst heute morgen auf die oben angegebene Version aktualisiert; der Fehler ist aber immer noch da. Nun zu den eingetragenen Repositories:


  • Du hast aber schon alle Pakete auf Packman umgestellt?

    Code
    zypper dup --from 3


    Und Deine Repos mal priorisieren:
    Packman=20
    Update=50

  • Hallo Sauerland,


    vielen Dank für Deine bereitwillige Hilfe. Habe die Repositories jetzt nach Deinem Vorschlag priorisiert. Dann habe ich die Aktualisierung durchgeführt. Dazu musste ich allerdings Kopete deinstallieren, da sonst einige Abhängigkeiten nicht aufgelöst werden konnten, aber da ich Kopete eh nicht verwende, war mir das egal.


    Der Fehler ist aber immer noch in genau der gleichen Form vorhanden. Die Ausgaben von zypper beim Update sowie das neue Logfile von k3b habe ich unten angehängt.


    LOG_zypper_Update.txt
    k3b_Errorlog_03.txt

  • Könntest Du eventuell in Erfahrung bringen, mit welchem Programm Dein Vater diese DVD erzeugt hat?
    Das sieht mir sehr danach aus, dass entweder das DVD Medium beschädigt ist oder das Video an dieser Stelle nicht standardkonform kodiert wurde, was sich beim Abspielen auf einem standalone Player nicht einmal bemerkbar machen muss.

  • Das glaub ich nicht. Ich habe testweise auch mal eine handelsübliche Spielfilm-DVD versucht zu rippen, und da steigt k3b mit genau demselben Fehler aus. Daran sollte es also nicht liegen. Außerdem ist der Punkt, an dem k3b abbricht immer an einer anderen Stelle; mal bei 73%, mal bei 98% mal noch woanders, allerdings immer in der ersten Phase des Auslesens.


    Einen Hardware-Fehler schließe ich eigentlich auch aus, da transcode mit der gleiche Hardware unter openSuSE 11.3 keine Probleme hatte.