[gelöst] Transcode stürzt beim DVD-Rip mit "invalid pointer" Fehler ab

Hinweis: In dem Thema [gelöst] Transcode stürzt beim DVD-Rip mit "invalid pointer" Fehler ab gibt es 31 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    Zitat


    Der Fehler ist aber immer noch in genau der gleichen Form vorhanden.


    transcode deinstallieren (wurde ja immer noch gebraucht).


    Gruss,
    Roland

    Für den Inhalt des Beitrages 37873 haftet ausdrücklich der jeweilige Autor: rme

  • Ich würde mal testweise mit Hilfe von K3b ein iso Abbild der DVD erstellen.
    Dieses iso Abbild kannst Du dann direkt wie eine physikalische DVD mit handbrake öffnen umd die DVD zu recodieren. Sollte dies funktionieren, würde man zumindest wissen, dass sowohl mit dem Datenträger als auch mit dem Video alles in Ordnung ist. Ein weiterer positiver Effekt dieser Vorgehensweise ist, dass sowohl Dein Laufwerk als auch Dein DVD Medium geschont werden.
    K3b ist ja leider nur in der Lage im Laufwerk vorliegende Medien zum Auslesen zu verwenden.

  • Habe es jetzt mal mit Handbrake probiert:


    1.) DVD mit k3b in ein iso-Image ausgelesen --> problemlos möglich


    2.) iso-image mit Handbrake geöffnet und versucht, einen DVD-Titel der Queue hinzuzufügen --> Speicherzugriffsfehler ! Hier der entsprechende Eintrag aus /var/log/messages:

    Code
    Jan 7 16:46:11 RECHNER kernel: [ 9276.458020] HandBrakeGUI[17438]: segfault at 292c000 ip 00007f1f5d7de7b0 sp 00007fff0fddfbc0 error 4 in libglib-2.0.so.0.2800.0[7f1f5d793000+f0000]


    3.) iso-image mit Handbrake geöffnet und versucht, einen DVD-Titel ohne vorherigen Eintrag in die Queue auszulesen: --> Speicherzugriffsfehler!

    Code
    Jan 7 16:47:02 RECHNER kernel: [ 9327.432779] HandBrakeGUI[17497]: segfault at 25e9000 ip 00007fdafe9fa7b0 sp 00007fff7c2fb5d0 error 4 in libglib-2.0.so.0.2800.0[7fdafe9af000+f0000]


    Da brat mit doch einen einen Storch! Was ist denn da im System faul? Stimmt da etwa mit der glibc was nicht?



    Hmmm, wofür braucht man eigentlich die glibc-devel?

    Für den Inhalt des Beitrages 37883 haftet ausdrücklich der jeweilige Autor: FD1007

  • Was sagt:

    Code
    zypper se -si libglib


    Zitat

    Hmmm, wofür braucht man eigentlich die glibc-devel?


  • Sagt:

    Code
    USERNAME@RECHNER:~> zypper se -si libglib
    Daten des Repositorys laden ...
    Installierte Pakete lesen ...
    S | Name | Typ | Version | Arch | Repository
    --+---------------------+-------+--------------+--------+---------------------
    i | libglib-2_0-0 | Paket | 2.28.0-3.8.1 | x86_64 | openSUSE-11.4-Update
    i | libglib-2_0-0-32bit | Paket | 2.28.0-3.8.1 | x86_64 | openSUSE-11.4-Update


    Das sieht doch OK aus, oder?

    Für den Inhalt des Beitrages 37885 haftet ausdrücklich der jeweilige Autor: FD1007

  • Eventuell müsste mal jemand mit einer openSuSE 11.4 Installation testen, ob das dort reproduzierbar auftritt. Ich kann das leider nicht machen, da auf meinen Rechnern nur noch openSuSE 12.1 läuft. Ich halte es durchaus für vorstellbar, dass das momentan ein generelles Problem bei openSuSE 11.4 ist und nicht nur auf Dein System beschränkt.

  • Tja, dann hätte ich wohl doch besser von 11.3 gleich auf 12.1 upgegradet, aber ich war der Meinung, dass ein Upgrade mit Überspringen einer Version immer problematischer ist. Andererseits ist die openSuSE 11.4 jetzt schon mehr als 9 Monate draußen; wenn es da ein grundlegendes Problem mit transcode geben würde, hätten das bestimmt schon andere entdeckt. Das war für mich übrigens auch mit ein Grund, auf 11.4 statt 12.1 umzusteigen; ich war der Meinung, dass bei der 11.4 die meisten Fehler schon behoben sein sollten, während die "frische" 12.1 mehr Probleme hätte.


    Ich hatte auch schon nach dem Problem gegoogelt, aber nur dies gefunden: http://forum.mandriva.com/en/viewtopic.php?f=90&t=135692. Da hat aber offensichtlich niemand drauf geantwortet; die einzigen Posts in dem Thread stammen beide von demselben Autor.


    Ich bedanke mich jedenfalls erstmal für die Hife - auch wenn sich bislang noch kein Erfolg eingestellt hat. Aber vielleicht hat ja jemand noch einen rettenden Einfall. Wäre doch peinlich, wenn ich zum DVD-Rippen noch HandBrake unter Windoofs installieren müsste.

    Für den Inhalt des Beitrages 37920 haftet ausdrücklich der jeweilige Autor: FD1007