Tumbleweed: Freeze beim Start nach Update - wegen nVidia-Treiber?

Hinweis: In dem Thema Tumbleweed: Freeze beim Start nach Update - wegen nVidia-Treiber? gibt es 19 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • [ 5348.261] (--) PCI: (0@0:2:0) 8086:1912:1043:8694 rev 6, Mem @ 0x2ffe000000/16777216, 0x2fe0000000/268435456, I/O @ 0x0000f000/64

    [ 5348.261] (--) PCI:*(1@0:0:0) 10de:1b81:1462:3302 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @

    8086 ist die ID von Intel, 10ec ist die ID von Nvidia, daher 2 Grafikkarten und ich schätze mal Bumblebee.......


    Da Nvidia no-kms bzw nomodeset benutzt, läuft der Intel Treiber jetzt nicht.....

    Für den Inhalt des Beitrages 303969 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich verstehe noch nicht: Meinst du, dass der Intel-Treiber Ursache des Problems ist oder meinst du, dass er eine Alternative sein könnte, damit ich überhaupt nen Desktop zu sehen bekomme?


    Meine CPU ist ein Intel i7 6700k. Der bringt Intel HD Graphics 530 mit.


    zypper se nvidia zeigt mir ein paar Pakete mit "bumblebee" im Namen, die aber alle nicht installiert sind.

    Für den Inhalt des Beitrages 303971 haftet ausdrücklich der jeweilige Autor: jilipop

  • Wenn es ein Laptop mit hybrid GPU ist, sprich optimus, dann ist suse-prime die bessere Wahl.


    Es gibt, AFAIR , nicht sonderlich viele Modelle wo man im BIOS eine der GPU`s abschalten kann.


    Bei meinem Gaming Laptop ist das so. Deshalb benutze ich Suse-Prime.


    Beim letzten Nvidia Update fehlten " x11-video-nvidiaG06 x11-video-nvidiaG06-32bit ". Ich benutze Tumbleweed.

    Das war mir direkt aufgefallen. Fand ich irgendwie komisch. Deshalb hatte ich das Update erst mal abwartend hinausgezögert.

    In der Zeit änderte sich das nicht. Zur Version G06 fehlen die genannten Dateien nach wie vor. Ich habe das gerade eben noch mal geprüft in den Repos. Für die anderen Treiber Versionen sind diese Dateien allerdings vorhanden.

    Vielleicht ist das auch neu und normal beim aktuellen G06 ?


    Bislang,, nach dem Update, hatte ich den Nvidia Modus mittels suse-prima noch nicht aktiviert. Das Laptop läuft läuft ohnehin die meiste Zeit im " Intel2 " Modus. Ich bin halt eher Gelegenheits- Zocker, nach Laune eben.


    Bisher funktionierte das umschalten mittels Suse-Prime immer zuverlässig und sehr gut. Allerdings benutze ich die Option "next-boot". Also beim GPU Wechsel ein Reboot

    Wenn ich das Wechseln der GPU lediglich mit dem Leisten-Tool (was auch funktionieren sollte) über das aus- und einloggen machen will, müsste ich die Config von Suse-Prima modifizieren, und dort extra auf " Intel2 " umschreiben.

    Ansonsten mache ich das immer mittels der Option " ... next-boot nvidia", und/oder " ... "next-boot Intel2". Sonst funktioniert das nicht. Liegt halt an der verbauten Intel-GPU.

    Wenn ich zB. die Option ... next-boot intel benutze, lande ich bei einem schwarzen Bildschirm. Dann muss ich die Konsole wechseln und dort auf Intel2 korrigieren und rebooten.


    Bei mir, nach dem komischen Nvidia Update, wollte ich im Anschluss den Suse-Prime Service abfragen, und sehen ob der Service aktiv ist.

    War er wie vermutet dann auch nicht. Allerdings kam auch die Info im Terminal dazu, und die Lösung wurde auch genannt. Der Service musste reaktiviert werden.


    Da die bereits oben genannten "x11-video-nvidiaG06 x11-video-nvidiaG06-32bit" noch fehlen , aber für die anderen Versionen mittlerweile in den Nvidia Repos verfügbar sind, warte ich einfach noch ab und nutze den Intel2 Modus. Zwischenzeitlich schaue ich den Repos ab und an nach.


    Unter open-Suse läuft das zocken auf meinem Laptop am besten. Performance und Stabilität ist sehr gut. Unter Arch und Debian / Ubuntu basierenden Linux ist das weniger gut.

    Ich vermute daß deshalb der Regata OS Spin von open-Suse , unter Zockern hoch im Kurs steht. Und auch wegen den extra Tools.


    Die Bumblebee Variante würde ich lassen, weil AFAIK veraltet und eher eine Bremse.


    Und falls das ein Desktop PC ist, vermute ich dass man sehr wohl die Intel GPU dauerhaft im BIOS deaktivieren kann.

    Das Problem könnte daher, wenn Desktop PC mit relativ neuer Nvidia GPU, welcher dann die Version G06 braucht, an den fehlenden x11-video-nvidiaG06 x11-video-nvidiaG06-32bit liegen.

    Für den Inhalt des Beitrages 303973 haftet ausdrücklich der jeweilige Autor: Quinix

  • Schau mal, ob du im BIOS eine Grafikkarte abschalten kannst.

    Ich prüfe das heute Abend, wenn ich wieder am betroffenen PC bin.


    Beim letzten Nvidia Update fehlten " x11-video-nvidiaG06 x11-video-nvidiaG06-32bit ". Ich benutze Tumbleweed.

    Das war mir direkt aufgefallen. Fand ich irgendwie komisch. Deshalb hatte ich das Update erst mal abwartend hinausgezögert.

    In der Zeit änderte sich das nicht. Zur Version G06 fehlen die genannten Dateien nach wie vor. Ich habe das gerade eben noch mal geprüft in den Repos. Für die anderen Treiber Versionen sind diese Dateien allerdings vorhanden.

    Vielleicht ist das auch neu und normal beim aktuellen G06 ?

    Ja, stimmt, das hab ich bei der Fehlersuche auch gesehen. Ich bin aber davon ausgegangen, dass das so soll. Standardmäßig nutzt Gnome inzwischen wohl auch Wayland und auch das klappt bei mir nicht.


    Und falls das ein Desktop PC ist, vermute ich dass man sehr wohl die Intel GPU dauerhaft im BIOS deaktivieren kann.

    Das Problem könnte daher, wenn Desktop PC mit relativ neuer Nvidia GPU, welcher dann die Version G06 braucht, an den fehlenden x11-video-nvidiaG06 x11-video-nvidiaG06-32bit liegen.

    Es ist ein Desktop-PC. Und ja, meine GTX 1070 braucht den G06-Treiber.

    Das klingt plausibel als Ursache, danke. Ich kann zwar auch aus einem Snapshot von vor dem letzten nvidia-Treiber-Update nicht starten, aber das vorangegangene nvidia-Update ist auch noch nicht lange her und vielleicht fehlten da auch schon die G06-Treiber.

    Für den Inhalt des Beitrages 303974 haftet ausdrücklich der jeweilige Autor: jilipop

  • Du könntest, bis dieses Treiber Problem mit Nvidia geklärt und gelöst ist, dann ja auch eine Weile die Intel GPU nutzen.

    Im BIOS die Nvidia GPU deaktivieren, dann die benötigten Intel GPU Treiber installieren , und sehen ob du zu ende booten kannst, bis zum Desktop.


    Ich habe die gleiche Nvidia GPU, aber meine Intel GPU ist etwas neuer als deine. Allerdings sind die Treiber dafür identisch.

    Der i915, welcher AFAIK im Kernel schon eingebaut ist, wird nicht funktionieren. Tut er zumindest bei mir nicht. Ich brauche die ältere Version. Wird bei dir nicht anders sein.


    Falls du gegenwärtig den Desktop nicht erreichst, um zB. von dort mittels yast2-Software den Intel Treiber zu installieren, wirst du das dann mittels Konsole machen müssen. Ist ja auch logisch.


    Ich habe gerade eben nochmal in den Nvidia Repos nachgeschaut. Die X11 Sachen fehlen noch immer. Es ist wohl nur eine Frage der Zeit. In der Zwischenzeit wird das auch sicher die Runde gemacht haben.

    Dauert aber dann eben immer etwas. Denn die Nvidia Treiber zirkulieren zuvor immer eine Weile, weil sie AFAIK einen Prozess u.a beim OBS durchlaufen. Und ich denke der oder die Paket Bauer , oder Betreuer, brauchen dann auch etwas Zeit.

    Für den Inhalt des Beitrages 303982 haftet ausdrücklich der jeweilige Autor: Quinix

  • Durchbruch! Im BIOS kann ich die "primäre Anzeige" auswählen. Hab da mal "CPU Graphics" gewählt. Hatte dann kein Bild mehr, bis ich den Monitor direkt am Mainboard anschloss. So konnte ich bis zum Desktop durchbooten - ohne zusätzliche Intel-Treiber-Installation.

    Ich hab dann mal versuchsweise einen System-Snapshot erstellt, die nvidia-Treiberpakete deinstalliert und das Installationsskript von der nvidia-Seite ausgeführt. Das ist natürlich total unsauber und keine Dauerlösung, aber siehe da: Jetzt funktioniert der aktuelle nvidia-Treiber! Irgendwas ist wohl an den Paketen im nvidia-Repo verkehrt.


    Ich warte jetzt, bis es ein Update der Pakete gibt, lasse dann das nvidia-Skript mit Parameter --uninstall durchlaufen und steige dann wieder auf die Pakete aus dem Repo um. Hoffentlich geht dann wieder alles.


    Ich sehe das Problem damit als gelöst an, auch wenn mir da noch Aufräumarbeiten bevorstehen. Vielen Dank für die Hilfe!

    Für den Inhalt des Beitrages 303989 haftet ausdrücklich der jeweilige Autor: jilipop

  • Nachtrag: Nachdem ein erneutes Update kam, hab ich versucht, wieder auf die Paketversion umzusteigen und mein Problem kam zurück. Allerdings hab ich diesmal in /usr/lib/modprobe.d/ eine .conf gefunden, die wohl von einem nvidia-Skript angelegt wurde, und unter anderem "blacklist nvidia" enthielt. Hab die .conf durch Umbenennung unwirksam gemacht und siehe da: Es läuft alles wieder mit den Treibern aus nvidia-Repo.


    Quinix : Weiterhin gibt es die Pakete x11-video-nvidiaG06 und x11-video-nvidiaG06-32bit nicht und dennoch läuft es bei mir per Wayland und per Xorg.

    Für den Inhalt des Beitrages 304143 haftet ausdrücklich der jeweilige Autor: jilipop

  • Verstehe ich ehrlich gesagt gar nicht. Welchen Grund sollte Nvidia haben, sich bei der Installation der Treiber selbst zu blacklisten? Das ist derartig widersinnig, da möchte ich gar nicht darüber nachdenken. Wenn das stimmt, hat aber einer bei Nvidia oder auch anderswo richtig Mist gebaut! Glauben kann und will ich das nicht.

  • Diese Datei war's: https://github.com/openSUSE/SU…odprobe-bbswitch-G04.conf

    Stimmt, die stammt nicht von nvidia.

    Die hatte ich in /usr/lib/modprobe.d/, obwohl ich meines Wissens nie Suse Prime installiert hatte.


    Einen Fehler meinerseits kann ich natürlich nicht ausschließen.

    Für den Inhalt des Beitrages 304149 haftet ausdrücklich der jeweilige Autor: jilipop