mount.cifs error(13): Permission denied

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema mount.cifs error(13): Permission denied gibt es 6 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • mount.cifs error(13): Permission denied

    Hallo Community,

    ich habe folgendes Problem. Auf einem Rechner in meiner Schule habe ich openSUSE education 12.1 32 bit installiert und in die dortige Windows Server 2003 Domäne aufgenommen. Nun soll auf dem openSUSE Rechner beim Anmelden das Home Verzeichnis des jeweiligen Nutzers eingebunden werden. Dazu nutze ich pam_mount. Im Anhang die Konfigurationsdatei.
    Beim Anmelden wird das Netzwerklaufwerk jedoch nicht eingebunden. In der Konsole erhalte ich folgende Debug Ausgabe von pam_mount:

    Quellcode

    1. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(pam_mount.c:364): pam_mount 2.12: entering auth stage
    2. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(pam_mount.c:553): pam_mount 2.12: entering session stage
    3. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:38): Session open: (ruid/rgid=0/10000, e=0/10000)
    4. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:662): Could not get realpath of /home/SCHULE/ich/Eigene_Dateien: No such file or directory
    5. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:226): Mount info: globalconf, user=SCHULE\ich <volume fstype="cifs" server="10.1.1.1" path="Benutzer$/Schueler/Campus/11er/ich" mountpoint="/home/SCHULE/ich/Eigene_Dateien" cipher="(null)" fskeypath="(null)" fskeycipher="(null)" fskeyhash="(null)" options="user=ich" /> fstab=0 ssh=0
    6. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:267): mkmountpoint: checking /home
    7. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:267): mkmountpoint: checking /home/SCHULE
    8. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:267): mkmountpoint: checking /home/SCHULE/ich
    9. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:267): mkmountpoint: checking /home/SCHULE/ich/Eigene_Dateien
    10. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:292): mkdir[10000] /home/SCHULE/ich/Eigene Dateien
    11. Feb 24 12:15:45 R1115L kdm: :0[1307]: command: 'mount' '-t' 'cifs' '//10.1.1.1/Benutzer$/Schueler/Campus/11er/ich' '/home/SCHULE/ich/Eigene Dateien' '-o' 'user=SCHULE\ich,uid=10000,gid=10000,user=ich'
    12. Feb 24 12:15:45 R1115L kdm: :0[1478]: pam_mount(misc.c:38): set_myuid<pre>: (ruid/rgid=0/10000, e=0/10000)
    13. Feb 24 12:15:45 R1115L kdm: :0[1478]: pam_mount(misc.c:38): set_myuid<post>: (ruid/rgid=0/10000, e=0/10000)
    14. Feb 24 12:15:45 R1115L kernel: [ 71.460104] CIFS VFS: default security mechanism requested. The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3
    15. Feb 24 12:15:45 R1115L kernel: [ 71.474931] CIFS VFS: cifs_read_super: get root inode failed
    16. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:65): Messages from underlying mount program:
    17. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:69): mount error(13): Permission denied
    18. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:69): Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    19. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 17 22 0:5 / /dev rw,relatime - devtmpfs devtmpfs rw,size=1601636k,nr_inodes=209552,mode=755
    20. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 18 17 0:15 / /dev/shm rw,relatime - tmpfs tmpfs rw
    21. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 19 22 0:16 / /run rw,nosuid,nodev,relatime - tmpfs tmpfs rw,mode=755
    22. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 22 1 8:6 / / rw,relatime - ext4 /dev/sda6 rw,user_xattr,acl,barrier=1,data=ordered
    23. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 20 22 0:3 / /proc rw,relatime - proc proc rw
    24. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 15 22 0:14 / /sys rw,relatime - sysfs sysfs rw
    25. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 16 17 0:11 / /dev/pts rw,relatime - devpts devpts rw,gid=5,mode=620,ptmxmode=000
    26. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 23 15 0:18 / /sys/fs/cgroup rw,nosuid,nodev,noexec,relatime - tmpfs tmpfs rw,mode=755
    27. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 24 23 0:19 / /sys/fs/cgroup/systemd rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd
    28. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 25 23 0:20 / /sys/fs/cgroup/cpuset rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,cpuset
    29. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 26 23 0:21 / /sys/fs/cgroup/cpu,cpuacct rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,cpuacct,cpu
    30. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 27 23 0:22 / /sys/fs/cgroup/memory rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,memory
    31. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 28 23 0:23 / /sys/fs/cgroup/devices rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,devices
    32. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 29 23 0:24 / /sys/fs/cgroup/freezer rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,freezer
    33. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 30 23 0:25 / /sys/fs/cgroup/net_cls rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,net_cls
    34. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 31 23 0:26 / /sys/fs/cgroup/blkio rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,blkio
    35. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 32 23 0:27 / /sys/fs/cgroup/perf_event rw,nosuid,nodev,noexec,relatime - cgroup cgroup rw,perf_event
    36. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 33 20 0:28 / /proc/sys/fs/binfmt_misc rw,relatime - autofs systemd-1 rw,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct
    37. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 34 15 0:10 / /sys/kernel/security rw,relatime - securityfs securityfs rw
    38. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 35 17 0:13 / /dev/mqueue rw,relatime - mqueue mqueue rw
    39. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 36 22 0:16 / /var/run rw,nosuid,nodev,relatime - tmpfs tmpfs rw,mode=755
    40. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 37 17 0:29 / /dev/hugepages rw,relatime - hugetlbfs hugetlbfs rw
    41. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 38 22 0:16 /lock /var/lock rw,nosuid,nodev,relatime - tmpfs tmpfs rw,mode=755
    42. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 39 15 0:6 / /sys/kernel/debug rw,relatime - debugfs debugfs rw
    43. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 40 22 0:30 / /media rw,nosuid,nodev,noexec,relatime - tmpfs tmpfs rw,mode=755
    44. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 41 15 0:31 / /sys/fs/fuse/connections rw,relatime - fusectl fusectl rw
    45. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 42 22 8:1 / /windows/C rw,nosuid,nodev,noexec,relatime - fuseblk /dev/sda1 rw,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096
    46. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(misc.c:380): 43 22 8:2 / /windows/D rw,nosuid,nodev,noexec,relatime - fuseblk /dev/sda2 rw,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096
    47. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(pam_mount.c:521): mount of Benutzer$/Schueler/Campus/11er/ich failed
    48. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:662): Could not get realpath of /home/SCHULE/ich/Eigene_Dateien: No such file or directory
    Alles anzeigen

    Aufgefallen ist mir dabei Zeile 17:

    Quellcode

    1. Feb 24 12:15:45 R1115L kdm: :0[1307]: pam_mount(mount.c:69): mount error(13): Permission denied


    Das Anmelden an die Domäne klappt jedoch problemlos. Also habe ich die Einbindung nochmal über die Konsole versucht:

    Quellcode

    1. mount -v -t cifs //s1/Benutzer$/schueler/campus/11er/ich/ /home/SCHULE/ich/Eigene_Dateien -o user=SCHULE\ich,nounix
    2. Password:
    3. mount.cifs kernel mount options: ip=10.1.1.1,unc=\\s1\Benutzer$,nounix,ver=1,user=ich,domain=SCHULE,prefixpath=schueler/campus/11er/ich/,pass=********
    4. mount error(13): Permission denied
    5. Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


    Ich bin davon ausgegangen, dass das Passwort nicht korrekt übertragen wird. Da meins Sonderzeichen enthält, habe ich es geändert und wieder versucht. Schließlich habe ich gar kein Passwort gesetzt. Ohne Erfolg. Ich habe gelesen, dass die zusätzliche Option nounix das Problem beheben könnte; wie man aber oben sieht ist dies nicht der Fall.

    Was mache ich falsch?
    Dateien

    Für den Inhalt des Beitrages 39511 haftet ausdrücklich der jeweilige Autor: tux94

  • Hallo,
    du musst den mount-Befehl als root Benutzer ausführen. Wenn du als root Benutzer auf der Konsole angemeldet bist, dann ist das an der roten Schrift in der Konsole zu erkennen.
    Für das mounten (auf deutsch Einhängen), für das Installieren von Software, für Systemsachen im Allgemeinen muss man als root Benutzer angemeldet sein.
    Nach /home zu mounten ist nicht Standard, funktioniert natürlich trotzdem. Es gibt im Linux Umfeld zwei typische Möglichkeiten: Entweder nach /mnt, oder nach /media.
    Ich bevorzuge nach /mnt.
    Wichtig dabei ist, die nötigen Rechte an dem Ordner zu haben, in dem die Freigabe einhängt werden soll. Das heißt das erste Buchstabenset (r = read w = write x = execute) steht für den Eigentümer des Ordners/ der Datei, das 2. Buchstabenset für die Gruppe und das 3. Buchstabenset für alle anderen. u = User (der Eigentümer), g = Group (die Gruppe), o = other (alle anderen).
    Setzen kann man das ganze mit

    Quellcode

    1. chmod

    Rekursiv, das heißt mit allen Unterdateien und Unterordner geht mit der Option -R, also

    Quellcode

    1. chmod -R


    username und password legen den Benutzernamen und das Passwort für die Freigabe fest. uid (= Userid) legen den lokalen Benutzer fest, unter welchem die Freigabe eingehängt ist. Das heißt dieser lokaler Benutzer ist der Eigentümer. Näheres siehe hier: opensuse.swerdna.org/susesambacifs.html

    Allgemeine Hilfe zu Befehlen kann man erhalten indem man in der Konsole eingibt

    Quellcode

    1. man befehl

    die sog. Man-Pages (= Anleitungsseiten). Verlassen kann man diese Seiten wieder mit q. Mit den Cursortasten kann man zeilenweise und mit den Bild nach oben und Bild nach unten Bildschirmweise navigieren.

    Ansonsten kann ich dir noch einen Eintrag in der fstab (man fstab) empfehlen. Aber vorsicht: In diesem Fall muss die Freigabe immer verfügbar sein, sonst startet das System nicht mehr.

    Ich benutze in der Berufsfachschule mein Notebook, mein mount Befehl sieht so aus:

    Quellcode

    1. mount -t cifs -o username=server_nutzer,password=server_passwort,uid=lokaler_benutzer,gid=lokale_gruppe,rw //server_ip/freigabe /mnt/freigabeordner

    Gibt man oben das Passwort nicht ein, fragt der Computer automatisch danach. Es gilt noch zu beachten, sollten sich Dateien in dem Ordner befinden, sind sie solange wie die Freigabe eingehängt ist, unsichtbar.

    MFG derwunner
    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 39512 haftet ausdrücklich der jeweilige Autor: derwunner

  • Hi,

    bitte entschuldige, ich habe vergessen zu erwähnen, dass ich den mount Befehl als root gestartet habe.

    Ich mounte nach /home damit Schüler, welche diesen Rechner später mal nutzen sollen, ihre Eigenen Dateien leichter finden.
    Es ist egal, ob ich nach /mnt, /media oder /home mounte. Ich bekomme immer ein Zugriff verweigert. Das dürfte aber auch nicht daran liegen, dass ich keine schreib Rechte auf diese Ordner habe, da ich ja root bin. Meiner Meinung nach kommt die Fehlermeldung vom Server, aber warum?

    Die fstab kann ich nicht nutzen, da ich ja von unseren 400 Schülern nicht das Passwort für ihr Domänenkonto kenne. Und um die Eigenen Dateien des jeweiligen Nutzers einzubinden brauche ich das ja. Deshalb nutze ich pam_mount, damit gleich beim Anmelden Benutzername und Passwort für das Einbinden abgegriffen werden können.

    Für den Inhalt des Beitrages 39519 haftet ausdrücklich der jeweilige Autor: tux94

  • Also so intensiv habe ich mich damit auch noch nicht befasst.
    Der Link sollte aber ganz hilfreich sein: linupedia.org/opensuse/Linux-Client_in_Windows_Domain

    Ist schon etwas älter, es könnte also sein, dass manche Sachen leicht abweichend sind.

    So weit wie ich das ganze verstanden habe, hat pam_mount einen Daemon. Also ein Dienst, der im Hintergrund läuft. Dieser muss auch beim Systemstart aktiviert werden, noch bevor jemand angemeldet ist, sonst klappt es nicht.
    In YAST2 im Runlevel Editor bei Runlevel 5 sollte dieser Daemon bei Systemstart mit gestartet werden.
    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 39524 haftet ausdrücklich der jeweilige Autor: derwunner

  • Danke für den Link, ist wirklich sehr interessant. Besonders der Gedanke, dass die smb.conf durch Yast nicht optimal für pam_mount konfiguriert wurde.

    Ich glaube nicht, dass der Daemon nscd zu pam_mount gehört. Ich kann keinen Eintrag wie /etc/init.d/ in der Dateiliste des rpms von pam_mount entdecken. Wikipedia sagt dazu:
    de.wikipedia.org/wiki/Name_service_caching_daemon

    Ich melde mich wenn es neue Erkenntnisse gibt.

    Für den Inhalt des Beitrages 39527 haftet ausdrücklich der jeweilige Autor: tux94

  • Leider kein Erfolg gehabt. Wie auf der Seite beschrieben habe ich die smb.conf abgeändert und überprüft, dass nscd gestartet wird. Nach wie vor wird mir der Zugriff verweigert. mount.cifs dürfte die smb.conf eig. auch ziemlich egal sein, da ich ihm ja alle nötigen Optionen über die Shell mitgebe.

    Für den Inhalt des Beitrages 39560 haftet ausdrücklich der jeweilige Autor: tux94

  • Es geht!!

    Die ganze Zeit hat mich folgende Zeile in der Ausgabe irritert:

    Quellcode

    1. Feb 24 12:15:45 R1115L kernel: [ 71.460104] CIFS VFS: default security mechanism requested. The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3


    NTLM ist der Windows LAN Manager mit welchem man sich wohl an der Domäne anmeldet, siehe Wikipedia:
    de.wikipedia.org/wiki/NTLM

    Mit dem Linux-Kernel Release 3.0 haben vermutlich die Kernel Programmierer das Modul ntlm rausgenommen und wollen es auf Version 2 im Kernel 3.3 aktualisieren. Da also ntlm nicht mehr vorhanden war, konnte sich Linux auch nicht am Domänencontroller anmelden. Die Folge: Permission Denied.

    Da Version 3.3 zur Zeit nur als RC vorhanden ist, habe ich mir den Linux Kernel 2.6.39.4 runtergeladen, kompiliert und installiert. Und es ging auf anhieb.

    Für den Inhalt des Beitrages 39585 haftet ausdrücklich der jeweilige Autor: tux94