[Erledigt]Probleme mit Repository nach Upgrade von 10.3 nach 12.1

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [Erledigt]Probleme mit Repository nach Upgrade von 10.3 nach 12.1 gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • [Erledigt]Probleme mit Repository nach Upgrade von 10.3 nach 12.1

    Hallo,

    nach einem Update von Open Suse 10.3 nach 10.4 und nachfolgendem Upgrade nach 12.1 wurden die
    Repositories Update, Oss und Non-Oss automatisch auf die neuen Suse-Repositories der Version 12.1
    gestellt.
    Beim Start der Online-Aktualisierung bekomme ich in der Phase "Auffrischen der Software-Repositories"
    den Fehler
    "Kein Zugriff auf Installations-Medium
    Pfad_des_Suse_Repositorys (Medium 1)" .
    Über einen Browser kann ich aber auf die Suse-Repositories zugreifen. Allerdings gibt es dort kein
    "Medium 1".
    Ein manuelles Eintragen eines Nicht-Suse-Repositorys (z. B. der TU Chemnitz) in "Software-Repositories"
    führt beim Prüfen dieses Repositorys ebenfalls zum Fehler
    "Kein Zugriff auf Installations-Medium

    Pfad_des_TU_Chemnitz_Repositorys (Medium 1)" .

    Hat jemand eine Idee?

    Viele Grüße

    Bernd Schreiber

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von LusH () aus folgendem Grund: Erledigt auf Grund mangelnder Interesse. Tags setzen.

    Für den Inhalt des Beitrages 41365 haftet ausdrücklich der jeweilige Autor: bernd10

  • bernd10 schrieb:

    nach einem Update von Open Suse 10.3 nach 10.4 und nachfolgendem Upgrade nach 12.1

    Ist nicht dein ernst, oder?

    Was ergeben denn die Ausgaben von:

    Quellcode

    1. zypper lr -d

    Quellcode

    1. ls /etc/zypp/repos.d/

    Quellcode

    1. ls /etc/zypp/services.d/

    ?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von tomfa-ng ()

    Für den Inhalt des Beitrages 41367 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Antwort an tomfa-ng

    Hier die Antworten:

    zypper lr -d
    # | Alias | Name | Aktiviert | Aktualisieren | Priorität | Typ | URI | Dienst
    --+------------------------+----------------------------+-----------+---------------+-----------+--------+-----------------------------------------------------------------------+-------
    1 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Ja | Nein | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD-ROM_DH30N_K57A6E42138 |
    2 | repo-debug | openSUSE-12.1-Debug | Nein | Ja | 99 | NONE | download.opensuse.org/debug/distribution/12.1/repo/oss/ |
    3 | repo-debug-update | openSUSE-12.1-Update-Debug | Nein | Ja | 99 | NONE | download.opensuse.org/debug/update/12.1/ |
    4 | repo-non-oss | openSUSE-12.1-Non-Oss | Ja | Ja | 99 | yast2 | download.opensuse.org/distribution/12.1/repo/non-oss/ |
    5 | repo-oss | openSUSE-12.1-Oss | Ja | Ja | 99 | yast2 | download.opensuse.org/distribution/12.1/repo/oss/ |
    6 | repo-source | openSUSE-12.1-Source | Nein | Ja | 99 | NONE | download.opensuse.org/source/distribution/12.1/repo/oss/ |
    7 | repo-update | openSUSE-12.1-Update | Ja | Ja | 99 | rpm-md | download.opensuse.org/update/12.1/

    ls /etc/zypp/repos.d
    openSUSE-12.1-12.1-1.4.repo repo-debug-update.repo repo-oss.repo repo-update.repo
    repo-debug.repo repo-non-oss.repo repo-source.repo

    /etc/zypp/services.d
    bash: /etc/zypp/services.d: Ist ein Verzeichnis

    Für den Inhalt des Beitrages 41368 haftet ausdrücklich der jeweilige Autor: bernd10

  • "bernd10" schrieb:

    installations-mediumPfad_des_Suse_Repositorys (Medium 1)" .
    Über einen Browser kann ich aber auf die Suse-Repositories zugreifen. Allerdings gibt es dort kein
    "Medium 1".


    War bei der Meldung die DVD eingelegt? Da diese ja nicht mehr benötigt wird, kannst du diese auch mit

    Quellcode

    1. zypper mr -d 1

    deaktivieren. Oder komplett mit:

    Quellcode

    1. zypper rr 1

    aus der Liste der Repos entfernen.

    Für den Inhalt des Beitrages 41371 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • Ich hatte schon folgendes versucht:
    - deaktivieren des Repository "DVD"
    - aktualisieren der Repositories deaktiviert

    Es hat leider alles nichts gebracht.

    Für den Inhalt des Beitrages 41372 haftet ausdrücklich der jeweilige Autor: bernd10

  • Kommt die Meldung auch bei einem:

    Quellcode

    1. zypper -vv ref

    ? Dann bitte mal diese Ausgabe, mit zwei bis drei Zeilen davor und dahinter, zeigen.

    Für den Inhalt des Beitrages 41373 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • zypper -vv ref
    Ausführlichkeitsgrad: 2
    Ziel wird initialisiert
    Festgelegte Repositories:
    Deaktiviertes Repository 'openSUSE-12.1-12.1-1.4' wird übersprungen
    Deaktiviertes Repository 'openSUSE-12.1-Debug' wird übersprungen
    Deaktiviertes Repository 'openSUSE-12.1-Update-Debug' wird übersprungen
    Es wird überprüft, ob die Metadaten für openSUSE-12.1-Non-Oss aktualisiert werden müssen.
    Abruf: download.opensuse.org/distribution/12.1/repo/non-oss/content [Fehler]
    Fehler beim Herunterladen (curl) für 'http://download.opensuse.org/distribution/12.1/repo/non-oss/content':
    Fehlerkode: Connection failed
    Fehlernachricht: Failed to connect to 2001:67c:2178:8::13: Das Netzwerk ist nicht erreichbar

    Abbrechen, wiederholen, ignorieren? [a/w/i/?] (a):


    Über Firefox ist die Seite download.opensuse.org/distribution/12.1/repo/non-oss/content
    aber aufrufbar.

    Unser Rechner nutzt für Aussenverbindungen einen Proxy. Der Proxy ist über
    yast2 - Netzwerkdienste - Proxy ordentlich eingebunden.

    Für den Inhalt des Beitrages 41374 haftet ausdrücklich der jeweilige Autor: bernd10

  • Ich habe unseren Rechner für Testzwecke mal ins nach aussen offene Netz gestellt (Aussenverbindung
    ohne Proxy) und es funktioniert alles. Dies ist aber keine Lösung.
    Die Repositories waren unter Suse 11.3 über Proxy aufrufbar, sind es aber unter Suse 12.1 nicht.
    Ich werde den Fehler an Suse melden.
    Vielen Dank an tomfa-ng für die Hilfe.

    Für den Inhalt des Beitrages 41377 haftet ausdrücklich der jeweilige Autor: bernd10