Angepinnt Die richtige Bildschirmauflösung einstellen ... zu Fuß

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Die richtige Bildschirmauflösung einstellen ... zu Fuß gibt es 1 Antwort.
  • Die richtige Bildschirmauflösung einstellen ... zu Fuß

    Symptomatik:
    Die unter Systemeinstellungen -> Hardware -> Anzeige und Monitor (KDE)
    verfügbaren Bildschirmauflösungen entsprechen nicht der gewünschten Auflösung (unter Berücksichtigung der Spezifikationen von Grafikeinheit und Monitor).

    getestet unter:
    Kernel: Linux 3.4.28-2.20-desktop x86_64
    Distribution: openSUSE 12.2 (x86_64)
    KDE: 4.8.5 (4.8.5) "release 2"

    Lösungsvorschlag:
    1. stelle sicher, daß alle erforderlichen Treiber in der jeweils aktuellen Version installiert sind
    2. öffne ein Terminal-Fenster und melde dich als Benutzer "root" an

      Quellcode

      1. su
    3. führe folgenden Befehl aus (Anzeige der Hardwareinformationen - nur Grafikkarte)

      Quellcode

      1. hwinfo --gfx
    4. prüfe in der Ausgabe ob der Treiber aktiv ist

      Quellcode

      1. #:~> /usr/sbin/hwinfo --gfx
      2. 09: PCI 02.0: 0300 VGA compatible controller (VGA)
      3. [Created at pci.319]
      4. Unique ID: _Znp.Bbo46DvZKO7
      5. SysFS ID: /devices/pci0000:00/0000:00:02.0
      6. SysFS BusID: 0000:00:02.0
      7. Hardware Class: graphics card
      8. Model: "Intel VGA compatible controller"
      9. Vendor: pci 0x8086 "Intel Corporation"
      10. Device: pci 0x0152
      11. SubVendor: pci 0x1297 "Holco Enterprise Co, Ltd/Shuttle Computer"
      12. SubDevice: pci 0x8001
      13. Revision: 0x09
      14. Driver: "i915"
      15. Driver Modules: "drm"
      16. Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
      17. Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
      18. I/O Ports: 0xf000-0xf03f (rw)
      19. IRQ: 49 (145893 events)
      20. I/O Ports: 0x3c0-0x3df (rw)
      21. Module Alias: "pci:v00008086d00000152sv00001297sd00008001bc03sc00i00"
      22. Driver Info #0:
      23. Driver Status: i915 is active
      24. Driver Activation Cmd: "modprobe i915"
      25. Config Status: cfg=no, avail=yes, need=no, active=unknown
      26. Primary display adapter: #9
      Alles anzeigen

      Zeile 23 ist hier interessant:
      Driver Status: i915 is active
    5. gib folgenden Befehl ein (Anzeige der Ausgabeschnittstellen)

      Quellcode

      1. xrandr
    6. In diesem Beispiel haben wir eine tatsächliche Auflösung von 1024 x 768 bei 60Hz und eine theoretisch maximale Auflösung von 8192 x 8192; "theoretisch", weil Grafikkarte und/oder Monitor das selten mitmachen (zum Vergleich: 7680 x 4320 wäre z.B. schon UHDV). Angeschlossen ist der Monitor an den VGA-Ausgang.

      Quellcode

      1. #:~> xrandr
      2. Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
      3. VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
      4. 1024x768 60.0*
      5. 800x600 60.3 56.2
      6. 848x480 60.0
      7. 640x480 59.9
      8. HDMI1 disconnected (normal left inverted right x axis y axis)
      9. DP1 disconnected (normal left inverted right x axis y axis)

      bis zu diesem Punkt sollten Dir keine Fehler aufgefallen sein.
      Wenn doch: löse bitte erst die bis hier aufgetretenen Probleme bevor Du weiter machst.

      Wir arbeiten immer noch im Terminal-Fenster als Benutzer "root".

      Achte bitte darauf die von Deiner Hardware maximal unterstützte Auflösung und Bildfrequenz nicht zu überschreiten.

      Bitte denke daran, daß die folgenden Zeilen nur Beispiele sind und von Dir evtl. abgeändert werden müssen um den Gegebenheiten Deiner Konfiguration Rechnung zu tragen!
    7. in diesem Beispiel wünschen wir uns eine Auflösung von 1680x1050 bei einer Bildfrequenz von 60Hz.
      Erstelle nun mit mit folgendem Befehl ein neues "Auflösungs-Setting" (= Modeline):

      Quellcode

      1. cvt 1680 1050 60
    8. Du erhälst folgende Ausgabe:

      Quellcode

      1. Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
    9. trage die neue Auflösung im System ein:

      Quellcode

      1. xrandr --newmode "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
    10. weise die neue Auflösung Deinem Monitor zu (hier benutzen wir den VGA-Ausgang [siehe Punkt 6]):

      Quellcode

      1. xrandr --addmode VGA1 "1680x1050_60.00"
    11. teste die neue Auflösung indem Du sie temporär aktivierst:

      Quellcode

      1. xrandr --output VGA1 --mode "1680x1050_60.00"
    12. wenn Dir die neue Auflösung gefällt und Du sie auch nach einem Neustart des X-Servers behalten möchtest, ändere die Dateien "50-monitor.conf" und "50-screen.conf" im Verzeichnis "/etc/X11/xorg.conf.d/" wie unten beschrieben.
      Diese Beispiele gelten nur, wenn Du auf Deinem System keine Datei namens "xorg.conf" findest.
      Ist eine "xorg.conf" vorhanden, mußt Du die neue Modeline dort eintragen.
      Beispiel "50-monitor.conf":

      Quellcode

      1. Section "Monitor"
      2. Identifier "Default Monitor"
      3. Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
      4. EndSection

      Beispiel "50-screen.conf":

      Quellcode

      1. Section "Screen"
      2. Identifier "Default Screen"
      3. Monitor "Default Monitor"
      4. Subsection "Display"
      5. Modes "1680x1050_60.00"
      6. EndSubSection
      7. EndSection
    13. das war's!
      Fertig!





    Viel Erfolg!

    Quellen:
    Sax2 für openSuSE 11.3
    [gelöst] Probleme mit Intel HD 2500 - Auflösung zu gering

    Für den Inhalt des Beitrages 52874 haftet ausdrücklich der jeweilige Autor: rmpp

  • Danke für diese ausführliche Anleitung. :)
    Die wird bestimmt dem ein oder anderen User weiterhelfen.

    Für den Inhalt des Beitrages 52893 haftet ausdrücklich der jeweilige Autor: Trekkie00