[Gelöst] Ihrer Installation von GStreamer fehlt ein Plugin

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [Gelöst] Ihrer Installation von GStreamer fehlt ein Plugin gibt es 10 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • [Gelöst] Ihrer Installation von GStreamer fehlt ein Plugin

    Hallo

    Zuallererst: Danke fürs Forum!

    Problemstellung unter Amarok und Clementine
    Beim Aufruf eines x-beliebigen Radiostreams von Icecast und SKY.fm erhalte ich folgende Warnmeldung:

    "Ihrer Installation von GStreamer fehlt ein Plugin"

    Leider wird das fehlende Plugin in der Warnmeldung nicht näher spezifiziert.

    Distribution und Erstinstallation
    OpenSuse 12.3 mit KDE. Updates für OpenSuse 12.3 installiert.

    Hardware
    Notebook hp pavilion ze5200
    OS: 32 Bit
    CPU: Intel Pentium 4 2,4 GHz
    RAM: 1 GB
    Festplatte: 40 GB

    OpenSuse 12.3 läuft ansonsten reibungslos auf meiner Hardware.
    Wenn ich noch das Malheur mit GStream in Griff bekommen könnte, wäre ich rundum zufrieden.
    Nur, ich weiss einfach nicht wo ich ansetzen muss. Das ist Neuland für mich.

    Schön, wenn mir jemand Schritt für Schritt helfen könnte. Danke!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von BSL777 ()

    Für den Inhalt des Beitrages 57968 haftet ausdrücklich der jeweilige Autor: BSL777

  • Hallo SUSEDJAlex

    Die Terminalausgabe lautet wie folgt:

    Brainfuck-Quellcode

    1. Daten des Repositories laden ...
    2. Installierte Pakete lesen ...
    3. S | Name | Typ | Version | Arch | Repository
    4. --+--------------------------------+-------+---------------+------+-----------------------------
    5. i | PackageKit-gstreamer-plugin | Paket | 0.8.7-4.8.2 | i586 | openSUSE-12.3-Update
    6. i | gstreamer | Paket | 1.0.5-3.1.1 | i586 | openSUSE-12.3-Oss
    7. i | gstreamer-0_10 | Paket | 0.10.36-8.1.1 | i586 | openSUSE-12.3-Oss
    8. i | gstreamer-0_10-plugin-gnomevfs | Paket | 0.10.36-5.1.1 | i586 | openSUSE-12.3-Oss
    9. i | gstreamer-0_10-plugins-base | Paket | 0.10.36-5.1.1 | i586 | openSUSE-12.3-Oss
    10. i | gstreamer-0_10-plugins-good | Paket | 0.10.31-6.1.5 | i586 | openSUSE-12.3-Oss
    11. i | gstreamer-0_10-plugins-qt | Paket | 0.10.2-3.1.1 | i586 | openSUSE-12.3-Oss
    12. i | gstreamer-fluendo-mp3 | Paket | 18-9.7.1 | i586 | openSUSE-12.3-Update-Non-Oss
    13. i | gstreamer-plugins-base | Paket | 1.0.5-2.1.1 | i586 | openSUSE-12.3-Oss
    14. i | libQtGStreamer-0_10-0 | Paket | 0.10.2-3.1.1 | i586 | openSUSE-12.3-Oss
    15. i | libgstreamer-0_10-0 | Paket | 0.10.36-8.1.1 | i586 | openSUSE-12.3-Oss
    16. i | libgstreamer-1_0-0 | Paket | 1.0.5-3.1.1 | i586 | openSUSE-12.3-Oss
    17. i | phonon-backend-gstreamer-0_10 | Paket | 4.6.2-3.1.1 | i586 | openSUSE-12.3-Oss
    18. i | python-gstreamer-0_10 | Paket | 0.10.22-5.1.1 | i586 | openSUSE-12.3-Oss
    Alles anzeigen


    LG BSL777

    Für den Inhalt des Beitrages 57974 haftet ausdrücklich der jeweilige Autor: BSL777

  • dir fehlt offensichtlich ein Repository names "packman"

    Binde dir diesen Repo über Yast ->Software-Repositories -> Gemeinschafts-Repository ein und setze die priorität auf 20

    danach ein

    Quellcode

    1. zypper dup --from packman


    jetzt kannst du alles hören....

    LG SUSEDJAlex
    Uhrzeit richtig einstellen

    openSUSE Leap sowie Arch LInux in Nutzung

    Für den Inhalt des Beitrages 57975 haftet ausdrücklich der jeweilige Autor: SUSEDJAlex

  • Hallo SUSEDJAlex

    Das Input in Yast ->Software-Repositories -> Gemeinschafts-Repository war kein Problem.
    Doch nach Eingabe von zypper dup --from packman meint das Terminal:

    Brainfuck-Quellcode

    1. Retrieving repository 'Packman Repository' metadata .....................................................................................[done]
    2. Building repository 'Packman Repository' cache ..........................................................................................[done]
    3. Loading repository data...
    4. Reading installed packages...
    5. Computing distribution upgrade...
    6. Repository 'packman' not found by its alias, number, or URI.
    7. Use 'zypper repos' to get the list of defined repositories.


    Bin der Anweisung vom Terminal gefolgt, indem ich zypper repos eingab.
    Terminalausgabe ist wie folgt:

    Brainfuck-Quellcode

    1. # | Alias | Name | Enabled | Refresh
    2. --+---------------------------+------------------------------------+---------+--------
    3. 1 | ftp.gwdg.de-suse | Packman Repository | Yes | Yes
    4. 2 | repo-debug | openSUSE-12.3-Debug | No | Yes
    5. 3 | repo-debug-update | openSUSE-12.3-Update-Debug | No | Yes
    6. 4 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No | Yes
    7. 5 | repo-non-oss | openSUSE-12.3-Non-Oss | Yes | Yes
    8. 6 | repo-oss | openSUSE-12.3-Oss | Yes | Yes
    9. 7 | repo-source | openSUSE-12.3-Source | No | Yes
    10. 8 | repo-update | openSUSE-12.3-Update | Yes | Yes
    11. 9 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | Yes | Yes
    Alles anzeigen


    Gemäss Zeile 3 ist Packman aktiviert.
    Muss noch ein weiterer Befehl im Terminal eingegeben werden?

    Denn Amarok meldet: "Es ist kein Decoder verfügbar."
    Und Clementine meldet weiterhin: "Ihrer Installation von GStreamer fehlt ein Plugin."

    LG BSL777

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von BSL777 ()

    Für den Inhalt des Beitrages 57976 haftet ausdrücklich der jeweilige Autor: BSL777

  • Stell alle Pakete auf Packman um:

    Quellcode

    1. zypper dup --from 1


    sowie:
    opensuse-forum.de/restricted-f…-f17/t6523-f22/#post37423

    Das Thema mit Pulseaudio deinstallieren kannst Du überspringen, danach bitte lesen.
    Und bitte das VLC-Repo (Videolan) nicht einbinden, gibt nur Ärger mit den installierten Programmen von Packman. Den VLC-Player kann man auch von Packman installieren.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 57977 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Da Du das Packman-Repository jetzt eingebunden hast, wie wäre es, wenn Du mal yast öffnest und unter Software installieren/löschen in der Suchfunktion gstreamer eingibst? Jetzt sollteste alle gstreamer-plugins zum herunterlagen markierst?
    Mir scheint, bei Dir fehlen solche wie gstreamer0.10-plugin-bad, ..-ugly usw. Die helfen dann weiter.

    Gruß

    Slughorn

    Für den Inhalt des Beitrages 57991 haftet ausdrücklich der jeweilige Autor: slughorn

  • Hallo Sauerland und Slughorn

    Eure Anweisungen habe ich ausgeführt.
    Dabei fiel mir auf, dass sich die URL für Packman in YaST2 - Software - Repositories geändert hat.

    Mit Yast2, meiner Installation, erhalte ich:

    Quellcode

    1. http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_12.3/

    Laut Eurer Anleitung "Restricted Formats installieren" per Terminal hingegen diese URL:

    Quellcode

    1. sudo zypper ar http://packman.inode.at/suse/12.3/packman.repo 'Packman Repository'


    Haben die unterschiedlichen URLs Einfluss auf das Paketangebot, oder kann das einfach vernachlässigt werden?

    Im YaST-Kontrollzentrum habe ich in Software installieren oder löschen die noch unmarkierten GStreamer-Plugins aktiviert. In Amarok/KDE3 und Clementine lassen sich nun die unterschiedlichen Streams abspielen.

    Mein bester Dank an Euch alle sowie auch für Eure prima Anleitungen!
    Sie haben mich zu weiteren Linuxstudien angeregt.

    LG BSL777

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von BSL777 ()

    Für den Inhalt des Beitrages 57994 haftet ausdrücklich der jeweilige Autor: BSL777

  • BSL777 schrieb:

    Haben die unterschiedlichen URLs Einfluss auf das Paketangebot, oder kann das einfach vernachlässigt werden?

    Die haben keinen Einfluss auf das Paketangebot, es geht nur darum die Last ein wenig zu verringern.
    Gestern wurde der Beitrag zur Installation der Codecs aktualisiert.

    Wenn das Problem gelöst ist, bitte den ersten Beitrag bearbeiten und vor den Titel ein [Gelöst] schreiben.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 57996 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Habe die gleiche Fehlermeldung von Clementine. Und ich habe versucht, alles so zu machen, wie hier beschrieben.
    Ich habe das Packman-Repository. Ich habe über YAST alle gstreamer plugins - soweit sie dort so beschrieben waren - installieren lassen. (außer Frameworks für die Plugins)
    Die Titel werden aber mit mpv-Player abgespielt (ist aber eher mein Videobetrachter). Wie kann mir Clementine sagen, welches Plugin konkret fehlt. Gibts da eine detailliertere Auskunft?

    Für den Inhalt des Beitrages 99774 haftet ausdrücklich der jeweilige Autor: achmennoo