[Gelöst] Dienst autofs läuft nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [Gelöst] Dienst autofs läuft nicht gibt es 5 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • [Gelöst] Dienst autofs läuft nicht

    Ich möchte gerne die AUTOFS Funktionalität am Netbook nutzen, wie ich es bereits auf dem PC installiert habe. Leider kann ich den Dienst AUTOFS nicht aktivieren. Es kommt zwar folgende positive Meldung:
    /bin/systemctl start autofs.service gab 0 (Erfolg) zurück:

    Aber beim speichern der Systemdienste und Wiederaufruf erscheint der Dienst wieder mit einem "Nein*". Auch ein Neustart bewirkt keine Änderung.

    Im Systemlog erhalte ich nur folgende Meldung:
    map auto.master: Local domain name not set

    Ich habe schon einiges durchforstet, aber noch keine Lösung gefunden. Wo muss ich weitersuchen? Bzw was ist die Ursache?

    Den Netbook habe ich neu aufgesetzt mit Standard openSUSE 12.3 32Bit und bisher mich nur auf AUTOFS fokusiert. Keine weitere Änderungen sind seit der Installation durchgeführt worden.

    Installiert sind folgende Komponente:
    autofs 5.0.7-10.2.1
    kernel-desktop 3.7.10-1.16.1
    nfs-client 1.2.7-2.14.1

    Einbinden der Shares über den NFS-Client funktioniert einwandfrei. Deshalb sehe ich das Problem beim AUTOFS Dienst.
    Vielleicht liege ich auch falsch.

    Vielen Dank Vorab für eure Mühen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Schwalbe ()

    Für den Inhalt des Beitrages 59674 haftet ausdrücklich der jeweilige Autor: Schwalbe

  • Poste mal:

    Quellcode

    1. systemctl status autofs.service


    Wie startest Du den Dienst?

    Quellcode

    1. systemctl enable autofs.service
    um den Dienst beim Systemstart zu starten.

    Quellcode

    1. systemctl start autofs.service
    um den Dienst zu starten.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 59686 haftet ausdrücklich der jeweilige Autor: Sauerland

  • NB1-openSUSE:/ # systemctl status autofs.service
    autofs.service - Automounts filesystems on demand
    Loaded: loaded (/usr/lib/systemd/system/autofs.service; enabled)
    Active: active (running) since Sat, 2013-10-05 14:33:50 CEST; 5min ago
    Process: 1731 ExecStart=/usr/sbin/automount ${AUTOFS_OPTIONS} -p /var/run/automount.pid (code=exited, status=0/SUCCESS)
    Main PID: 1735 (automount)
    CGroup: name=systemd:/system/autofs.service
    └ 1735 /usr/sbin/automount -p /var/run/automount.pid

    Oct 05 14:33:50 NB1-openSUSE.site automount[1735]: lookup_init:136: lookup(yp): map auto.master: Local domain name not set
    Oct 05 14:33:50 NB1-openSUSE.site systemd[1]: Started Automounts filesystems on demand.
    Gestartet habe ich den Dienst bisher über YAST -> Systemdienste. Dort hat er den Status " Nein* "

    Am allgemeinen Status hat sich nichts geändert, aber ich habe den Zugriff auf meine Shares wie gewünscht. Ich kapier es nicht mehr; der Unterschied zu bisher war folgender Codefolge:
    systemctl disable autofs.service
    systemctl enable autofs.service
    systemctl stop autofs.service
    systemctl start autofs.service


    Ich habe die Vermutung, dass der Code disable und enable die Veränderung gebracht hat. Was wird hier genau gemacht? Legt das System neue links für den service an?

    Für den Inhalt des Beitrages 59695 haftet ausdrücklich der jeweilige Autor: Schwalbe

  • Schwalbe schrieb:

    Gestartet habe ich den Dienst bisher über YAST -> Systemdienste.

    Das funktioniert nicht zuverlässig, da ja umgestellt von sysvinit nach systemd.

    Um einen Dienst beim Systemstart zu starten ist der Befehl:

    Quellcode

    1. systemctl enable xxxxxx.service
    anzugeben, mit disable wird er beim Systemstart nicht mehr gestartet.

    Per Hand kann man mit start/stop/restart den Dienst in einer laufenden Sitzung starten/stoppen/neustarten.

    mikuerschner.org/node/26
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 59697 haftet ausdrücklich der jeweilige Autor: Sauerland

www.cyberport.de