Grafik unter 13.1

Hinweis: In dem Thema Grafik unter 13.1 gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • P { margin-bottom: 0.21cm; }



    Hallo ich habe ein Problem. Wie gewohnt
    lief die Installation auf mehreren Rechnern mit 13.1 unspektakulär
    ohne Probleme. Nur auf meinem Arbeitsrechner musste ich zu 12.3
    zurückkehren.


    Dieser Rechner hat eine AMD Radeon Hd
    7660D Grafikkarte und wird über einen Fernsehmonitor wiedergegeben.
    Die Auflösung unter 13.1 erinnerte an Blindenschrift, alles war
    riesig und die Bestätigungsfelder waren nicht zu erreichen. Mit
    verschiedenen Auflösungen war keine Besserung zu erzielen und im
    Endeffekt habe ich zum ersten mal seit fünfzehn Jahren mit der
    Installation von SuSe kapituliert. Ich fände es super, wenn mir
    jemand helfen könnten.

  • Da gibt es verschiedene Möglichkeiten:


    Zunächst brauchen wir noch folgende Infos: Ist die 13.1 noch installiert?


    Hast Du ein Update, also eine Aktualisierung auf die 13.1 vorgenommen oder eine Neuinstallation?

  • Die Installation war wie immer Neuinstallation. Nach dem ich nicht weiter kam, habe ich 12.3 installiert und ein Update auf 13.1 gemacht mit dem selben Ergebnis. Danach war mein Frustpotential so hoch, dass ich auf diesem Rechner wieder auf 12.3 umgestiegen bin. Das Problem sehe ich momentan bei der Wiedergabe auf dem großen Fernsehmonitor. Allerdings hatte ich bei allen Vorgängerversionen von Suse oder Ubuntu mit dieser Konfiguration noch nie Schwierigkeiten.

  • Wahrscheinlich hattest Du auch den propritären ATI-Treiber installiert.


    Zum Verständnis: Alle propritären Grafiktreiber bauen zum funktionieren ein Kernel-Modul.


    Macht man ein Systemupdate auf eine neue Version, kommt i.d.R. auch ein neuer Kernel zum Einsatz.


    Dieser weiß nichts von dem Grafik-Kernelmodul der Vorgängerversion.


    Man muss den propritären Graphiktreiber vor dem Update deinstallieren.


    Logge Dich mit Strg+Alt+F1 als root in eine Konsole ein (im System der 13.1) und benenne die Datei

    Code
    xorg.conf.install

    in

    Code
    xorg.conf

    um und reboote.


    Damit wird eine zumindest funktionierende graphische Oberfläche gestartet um weiter arbeiten zu können.


    Dann den Ati-Treiber installieren.


    Alternativ: Sichere in der 12.3 die /etc/X11/xorg.conf und kopiere sie in das Verzeichnis /etc/X11 der 13.1


    Das funktioniert aber nur, wenn Du keinen propritären Ati-Treiber installiert hattest.


    Hast Du in der 12.3 einen installiert, musst den auch in der 13.1 installieren; notfalls über die Konsole ohne grphische Oberfläche.


    Siehe Sebastian Sieberts Anleitungen dazu:


    http://de.opensuse.org/SDB:AMD/ATI-Grafiktreiber

    2 Mal editiert, zuletzt von thomas23 ()

    Für den Inhalt des Beitrages 61530 haftet ausdrücklich der jeweilige Autor: thomas23

  • Danke für die Antworten. Bisher liefen alle Distris ohne zusätzlich Treiber Installation. Die nächsten Tage werde ich es mal mit dem vorgeschlagenen versuchen. Zum Arbeiten habe ich zum Glück noch die 12,3.

  • Hatte dasselbe Problem von 12.3 auf 13.1. Während der Installation waren alle Grafiken o.k., jedoch nach dem Neustart konnte ich nichts mehr mit dem Bildschirm anfangen. Auch nach dem Neuformatieren und allein 13.1 aufspielen kam derselbe Effekt. Das reicht nach Unverträglichkeit der vorhandenen Grafiktreiber mit der aktuellen Karte. Dabei kann man aber nicht in Google suchen. Ich habe dann abgebrochen.


    Das Ergebnis war, dass nach Neuinstallation von 12.3 die Konfiguration ganz anders war als vordem. Die Patches in 12.3 haben viel Unordnung hineingebracht. Einige Programme wie kbibtex sind voll verschwunden. Lyx fehlen einige _.sty.

  • @ Wolfgang 38 - Du hast vermutlich eine nVidia Grafikkarte - die lief bei 12.3 mit dem Treiber aus dem nVidia repo. Für 13.1 gibt's aber noch immer kein Treiber in repository - beim Upgrade wurde den nuoveau (default) Treiber geladen. Ergebnis: Arbeitsfläche (Desktop) ohne Effekte. Fenster ohne Menüleiste, keine Icons in der Fensterleiste etc.
    In diesm Fall hätte in Systemeinstellungen (akribische blinde Sucherei vonnöten) -> rausnehmen des Häckchen bei "Arbeitsflächeneffekte beim Start aktivieren" gereicht...


    Ich empfehle allen, die keine Probleme mit der Grafik von nVidia haben wollen - WARTEN, bis die Firma ein Treiber zu Verfügung über repo bereitstellt.


    Gruß, Z.

  • .....und zu noveau noch ein Hinweis aus den Release-Notes, die jeder während und nach einer Suse Installation auf dem Rechner hat:


    Zitat

    5.2. Müll auf dem Bildschirm während der Installation mit dem Nouveau-Treiber
    Auf einigen Systemen mit NVIDIA-Grafikkarten kann das Installationsprogramm im oberen Teil des Bildschirms Müll anzeigen wegen Problemen mit dem standardmäßigen nouveau-Treiber. Wenn Sie von diesem Problem betroffen sind, können Sie das nouveau-Kernel-Modul während der Installation deaktivieren, und wieder aktivieren, nachdem das System installiert oder aktualisiert ist.
    Um das Kernel-Modul zu deaktivieren, wählen Sie den Eintrag 'Installation' aus, wenn Sie vom Installationsmedium booten, und drücken Sie 'e', um die Parameter zu ändern. Gehen Sie zu der Zeile, die mit 'linux' (oder 'linuxefi') beginnt, und fügen Sie brokenmodules=nouveau am Ende hinzu. Drücken Sie nun F10, um mit dem neuen Parameter weiter zu booten. Nachdem das System installiert ist, können Sie nouveau wieder aktivieren, indem Sie die Datei /etc/modprobe.d/50-blacklist.conf ändern, und den Eintrag entfernen, der nouveau sperrt.