Hoffentlich ist hier auch konstruktive Kritik erlaubt

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Hoffentlich ist hier auch konstruktive Kritik erlaubt gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hoffentlich ist hier auch konstruktive Kritik erlaubt

    Hallo SUSEisten,

    zunächst vielleicht erst mal, warum ich etwas genervt bin von der neuen openSUSE 13.1-KDE-Iso :

    Eigentlich bin ich nach einer langen Reise durch die Linux-Welt bei Manjaro und der KDE gelandet, vorher noch bei Debian und Arch, um Linux etwas besser zu lernen. Auch openSuse ist mir seit der 10er mehrfach über den Weg gelaufen, bin aber z.B. wegen yast noch nicht dabei geblieben. Das liegt wohl daran, dass ich Informatiker bin und eigentlich immer alles ganz genau wissen muss, um es auch verstehen zu können. Jetzt wollte ich die 13.1 mal in einer Virtualbox ausprobieren, um mir ein Urteil erlauben zu können, ob es vielleicht in Zukunft doch für meine Arbeit eine noch solidere Grundlage sein könnte. :rolleyes:

    Dabei bin ich so vorgegangen, wie es auch jeder MS-User machen würde, wenn er sich dafür interessiert: Alles wie vorgeschlagen abnicken und Geduld bewahren. Die VM schlug 8GB Platte, 512MB RAM und NAT vor, Suse richtete eine 4GB root- und eine 4GB home-Partition ein.Dann noch etwas Geduld und dann war die Suse fertig, aber trotz Spracheinstellung deutsch natürlich wie bei vielen (aber nicht allen) Distris die KDE in Englisch (wie auch bei der 12.1). Nach der Auswahl der drei fehlenden Sprachpakete in Yast UND der Auswahl, nur die ausgewählten Pakete installieren zu wollen, installierte Suse erst mal über 900MB Pakete und meldete, dass der Speicherplatz knapp würde und fragte nach, ob ich weitermachen wollte. Auf meine positive Antwort blieb das System naturgemäss kurze Zeit später einfach stehen. :smilie_pc_012:

    Ein 2. Versuch mit gewohnten Einstellungen für Test-VMs (12GB HDD, 2048 RAM und alles in einer Partition verhielt sich die Sprachumstellung der KDE genau so wie vorher. Nach der Installation dieses Mega-Paket-Packs hatte Suse noch ein Update in Petto, was ich auch abgenickt habe. Das läuft jetzt schon seit über einer Stunde (läuft auch tatsächlich, die Paketangaben im Updater ändern sich) und, wie ich gerade sehe mit folgender Fehlermeldung beendet worden:

    Ausführbare Datei: kded4 PID: 4587 Signal: Segmentation fault (11) Datum: 08.12.2013 00:15:52. :(

    OK, offensichtlich ein KDE-Problem... :huh:

    Wenn man übrigens nicht als erstes überhaupt das Networking-Setup auf KDE umstellt, hat man kein Netz und es geht gar nichts ! :smilie_pc_057:

    Nun gut, alles beherrschbare Probleme für jemanden, der schon einige Zeit was mit Linux zu tun hatte, aber jemand, der die Nase z.B. von MS voll hat und es in einer VM einfach mal mit Linux versuchen möchte, nimmt sicherlich direkt wegen Frust wieder Abstand davon. Wie ich finde, muss eine ISO von der Website direkt erst mal einfach nur funktionieren, egal. ob nun mit KDE oder einem anderen Desktop. Ich glaube nicht, dass das so viel Aufwand wäre gemessen an dem Aufwand, eine neue SUSE-Version zu erarbeiten.

    Jedenfalls hat mich diese Aktion bis jetzt viele Stunden gekostet. Eigentlich wollte ich nur die Suse 13.1 ausprobieren...

    Zwischen den 2 Versuchen mit der neuen Suse habe ich Mageia KDE in Deutsch installiert: hat ne halbe Stunde gedauert und alles lief sofort, was natürlich nicht das einzige Kriterium für eine gute Linux-Distribution ist, aber wahnsinnig wichtig für die Verbreitung. Der erste Eindruck ist meiner Ansicht nach hierfür immens wichtig.

    So, nun is genug gemeckert ...

    LG
    linusfan

    Für den Inhalt des Beitrages 62518 haftet ausdrücklich der jeweilige Autor: linusfan

  • Bevor du mit der Installation beginnst, würde ich erst mal checken ob die md5-summe bzw. sha1-summe stimmt....

    Dazu musst du diese beiden Dateien von der Webseite runterladen oder von einem Spiegelserver....

    Prüfung:

    Quellcode

    1. md5sum -c Datei.iso.md5
    2. sha1sum -c Datei iso.sha1


    ( Datei = name der heruntergeladenen ISO-Datei )

    in Virtualbox: Da musst du davon ausgehen dass nicht alle (realen ) Hardware unterstützt werden können
    und 8 GB für alles ( Swap + root + home ) ist etwas dürftig genug..... <== gilt auch für RAM

    Es bleibt mir eine Frage übrig:

    wie sehen die Fehlermeldungen genauer aus ? hast du die Log-Dateien geprüft auf diese von dir gemeldeten Fehlermeldungen....

    LG SUSEDJAlex
    Uhrzeit richtig einstellen

    openSUSE Leap sowie Arch LInux in Nutzung

    Für den Inhalt des Beitrages 62520 haftet ausdrücklich der jeweilige Autor: SUSEDJAlex

  • Hallo,
    da du dir das System nur anschauen möchtest, ob es in die nähere Auswahl kommt, bittet openSUSE auch eine Live-CD Version an. Und wenn du dein System vor großen Veränderungen schützen möchtest (was ich verstehen kann), würde ich diese Live-CD mit einer VM starten, dann bin ich auf der sicheren Seite, das auch eine Installation sich rentiert.

    So bin ich mit mehreren Unix/Linux-Distributionen vorgegangen, zb. frendora, freeBSD. NetBSD, usw.

    Das ich openSUSE verwende hat bei mir schon eine lange Tradition (seit SUSE 4.3).

    Für den Inhalt des Beitrages 62521 haftet ausdrücklich der jeweilige Autor: boser

  • Hoffentlich ist hier auch konstruktive Kritik erlaubt

    Klar ist hier auch Kritik erlaubt, Du hast es sogar ins richtige Unterforum gestellt.

    Nur glaube ich, das Deine Kritik hier im Forum nicht gut aufgehoben ist, hier wird kein Entwickler von openSUSE vorbei schauen.

    Probleme,auch bei der Installation, gibt es übrigens mit jeder Distribution, sonst wären die Foren überflüssig.
    Es werden natürlich auch nur die Probleme sichtbar, denn User, die keine Probleme haben, werden sich auch nicht melden.
    Übrigens könnte das auch ein Virtualbox-Problem sein.

    Daher kann ich Deine Probleme nicht nachvollziehen, bei mir geht es nach dem Motto:
    Usb-Stick einstöpseln und sich zurücklegen.

    linusfan schrieb:

    Zwischen den 2 Versuchen mit der neuen Suse habe ich Mageia KDE in Deutsch installiert: hat ne halbe Stunde gedauert und alles lief sofort, was natürlich nicht das einzige Kriterium für eine gute Linux-Distribution ist, aber wahnsinnig wichtig für die Verbreitung. Der erste Eindruck ist meiner Ansicht nach hierfür immens wichtig.

    So geht es mir mit einer Installation von openSUSE, die ist in 20 Minuten installiert, und andere haben evtl. Schwierigkeiten bei der Installation von Mageia.

    Deswegen ist der ganze Post von Dir für mich nicht aussagekräftig, den hättest Du auch auf Ubuntu, Debian, Mageia usw. beziehen können.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Sauerland ()

    Für den Inhalt des Beitrages 62524 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Die Live Cd Kde oder Gnome ist jeweils eine Cd mit 700Mb.
    Gegenüber der Installations Dvd mit 4,3 Gb sollte dort einiges fehlen.
    Das Fehlende wird nach der Installation aus dem Netz geholt.
    Deine Kritik ist in dem Fall eine Beschreibung der Realität.
    Ein Neuling sollte die Dvd nehmen. Dort kann er "alles" abnicken.
    Die Live Cd ist ein Livesystem, das zur Installation geeignet ist.

    Stell Dir vor die Entwickler würden ein Installationsmedium schaffen,
    auf dem die Installations Dvd, die Live Cd Kde und die Live Cd Gnome sind.
    Das ganze passt dann auch noch auf eine normale Dvd.
    Du kopierst das Medium mit Imagewriter auf einen 8 oder 16Gb Usb Stick,
    startest das Live System vom Usb Stick und hast ein persistentes Installatinssystem.

    Das ist kein Schlangenöl, das gibt es, und den Entwicklern bin ich dankbar dafür.

    Edit:
    Danke, tomfa-ng, da ich seit 12.1 mit Promodvs arbeite, ist mir das noch nicht aufgefallen.
    Die Cd Images der Livesysteme sind fast ein Gb groß.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Kanonentux ()

    Für den Inhalt des Beitrages 62525 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Hallo zu diesem "mal sehen wann das System ne Grätsche macht" -Versuch möchte ich auch mal was sagen:

    Die Standarteinstellungen bei der Virtualbox sind so wie du gesagt hast, blos kommen noch 126 MB Grafikspeicher hinzu.

    Als Jahrzehnte langer Win -User möchte ich dir sagen, das die wenigsten User so vorgehen würden, wie du. Die User, die du da glaubst zu zitieren, werden mit dem Begriff Virtuelle Maschine auch nix anfangen können.

    Ich habe es jedenfalls - selbst bei der Installation von komplexeren Programmen in der Regel erstmal so gehalten, dass ich mich über die Systemanforderungen informiert habe.

    Dann hätte ich Folgendes erfahren:

    die Magiea DVD hat laut Downloadseite 3,9 GB
    die Opensuse DVD hat laut Downloadseite 4,7 GB

    Erkenntnis: muss wohl ein Unterschied im Software-Angebot vorliegen - also mal genau hinsehen, was ich alles installieren will und magels Platz (4 GB) auch kann.

    Wenn man sich mit Betriebssystemen beschäftigt hat (und das hast du ja), weiss man,wenn man einem System nur 500 MB Arbeitsspeicher zugesteht, es aber minimal 1 GB braucht ( Spezifikation), dass da von den 4 GB erstmal ca. 1 GB an Virtuellem Speicher abgeht und als Folge davon die Platte nicht mehr stillsteht.

    Suse gibt als minimalen Festplattenspeicher 5 GB für eine Grafische Installation an. Hättest du keine separate Home- Partition gewählt, hättest du auch installieren und Updaten können. Diese Alternative wird im Installationsprozess vorgeschlagen.Warum du das hier als Negativ- Bespiel anführst,ist mir nicht klar. In deinem 2. Versuch hast du das dann ja auch gemacht.

    Auch um die Konfiguration des Internetzugangs hättest du dich nicht kümmern brauchen, hättest du die ziemlich erste Frage nach einem Update während der Installation mit ja beantwortet, wäre der Internetzugang bereits vor der Installation automatisch bzw. (wenns beliebt) zu Fuss eingerichtet gewesen.

    Warum das Update bei dir 1 Stunde läuft kann ja nur an deiner Leitung bzw. einem überlasteten Server nicht aber am Betriebssystem liegen.

    Die Fehlermeldung "Signal: Segmentation fault" deutet häufig auf einen Fehler im Arbeitsspeicher hin.Da du uns nicht gesagt hast was du für einen Rechner hast und wie die weiteren Einstellungen der Virtuellen Maschine sind, kann man zu diesem Fehler nichts weiter sagen.

    Ich habe diverse Virtuelle Maschinen darunter auch OpenSuse bei mir installiert, und hatte diese Probleme, die du beschreibst noch nie. Sowohl unter Windows als auch jetzt unter Linux als Host.

    Ich habe mich nach über 20 Jahren Windows bewusst für OpenSuse entschieden, gerade weil ich den Installationspozess den du bemängelst,vorbildlich finde, und praktisch alles vorher eingestellt werden kann.
    Das soll nicht heissen. das alles perfekt ist - bei weitem nicht - aber ich persönlich empfinde es als eine der besten Distros.

    Für den Inhalt des Beitrages 62529 haftet ausdrücklich der jeweilige Autor: linuxuser4711

  • Danke für das im Grossen und Ganzen wohlwollende Feedback ! In anderen deutschen Distri-Foren hätte ich dafür ausschliesslich "einen auf die Omme" gekriegt. Spricht ja erst mal für die Clientel, die Suse benutzt.

    Also, es wurde mein Rechner angefragt. Es ist hauptsächlich ein HP-Compaq DC7700 CMT mit 8GB Ram, GeForce 210 und 80GB HDD. Eine 60GB SSD hängt auch noch im System zum compilieren von Android-Apps und anderen Prgrammen und Progämmelchen. Die Syslogs bekomme ich bei Linuxen mit Kerneln über 3.6 nur per Blacklisting sauber, was aber auch nicht bei allen getesteten geht. Der Rechner hat also ein etwas sonderbares BIOS.

    Nachdem ich vor eineinhalb Jahren wieder angefangen hatte, zu entwickeln (mit Win7), stellte ich schnell fest, dass ich den Resourcenhunger von erst Win7, dann 8 nicht mehr befriedigen will und kann (zu der Zeit mit einem neuen ASUS-Notebook X54H) und dass das mit Ubuntu 12.04 nicht der Fall ist (ganz abzusehen von dem ständigen Big Brother, der ständigen Werbung und der Angriffe von subversiven "Software-Anbietern"). Also arbeitete ich eine Weile unter Ubuntu im Dual-Boot mit Win7/8, war damit aber auch nicht so glücklich und fing an nach einer Linux-Distribution zu suchen, mit der ich MS endlich vollständig ersetzen kann. Mit Unix war ich schon in den 80ern beruflich in Berührung gekommen (Sun- und HP-Workstations irgendwo im Institutsnetz), fand es damals schon genial und installierte zu Hause die so ziemlich die erste Linux-Distribution (DLD hiess sie glaube ich). Nach Fedora 17 bin ich dann einige Monate bei Mint 13 geblieben, probierte aber jede Menge Distributionen im VMware-Player aus (gefühlt ca 20). Man kann mir also nicht unbedingt nachsagen, dass ich damit keine Erfahrung habe. Ich habe auch alle Live-CDs oder -DVDs in der VM installiert, damit die Einstellungen persistent sind. Die VM-Voreinstellungen hatte ich jeweils vorher auf bewährte Werte gesetzt.

    Jedenfalls war die Suses die einzigen Distribution, wo man irgendeine Installations-Voreinstellung ändern musste, um z.B. direkt eine Netzverbindung zu haben.

    Aber es ist richtig, ein SUSE-Enwickler schaut hier wohl leider nicht rein. Ich wollte ja auch keine Kritik üben an Suse. Es ist mir eher daran gelegen, dass Suse mit den gleichen "Angenehmlichkeiten" ins Rennen geht, wie die anderen.

    Nach ein paar Handgriffen läuft 13.1 jetzt bei mir tadellos in der Virtualbox und ich werde jetzt wohl mal einiges damit probieren. Vielleicht steige ich ja dann auch um von der nie 100%ig sicheren Rolling-Release Manjaro auf Suse 13.1. Man ist sich ja dabei doch nie sicher, dass nicht ein Update (alle 1 bis 2 Wochen) wieder irgendwelche Fummeleien am System nach sich zieht. Aber immerhin war Manjaro wieder die erste Distribution, mit der ich wieder stabil arbeiten konnte, ohne mich dauernd wieder um irgendwas am Linux kümmern zu müssen. Ich arbeite damit jetzt seit über 2 Monaten, Nach einem aktuellen "Unfall", bei dem ungeklärt geblieben ist, ob es an einem Update oder an der Installation direkt auf einer zum BIOS nicht ganz kompatiblen SSD lag (ist ja echt geil schnell !), schaue ich mich halt wieder weiter ein bisschen um.

    LG ;)

    @linuxuser4711

    1. Es wurde nur eine etwas über 900MB grosse Live-DVD mit den "default"-Paketen installiert.
    2. Die Internetverbindung ist und war auch bei der Installation top (bislang seit Jahren sehr stabile und verlässliche 50MBit-Verbindung)
    3. Den Speicher hatte ich immer wieder mal auch in Verdacht, aber jegliche, teilweise sehr zeitaufwendige Tests mit diversen Test-Techniken verliefen immer ohne Fehler. Es ist ja wohl hier auch eher ein Fehler im "virtuellen" Speicher der VM, kann also auch ein Bug in der Software der Virtualbox sein.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von linusfan () aus folgendem Grund: Vervollständigung

    Für den Inhalt des Beitrages 62530 haftet ausdrücklich der jeweilige Autor: linusfan