openSUSE 13.1 hängt für >1 min beim booten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema openSUSE 13.1 hängt für >1 min beim booten gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • openSUSE 13.1 hängt für >1 min beim booten

    Hallo Leute,
    ich habe mich entschlossen, auf einem Rechner die 13.1 zu probieren, leider mit mäßigem Erfolg. Mein erstes Problem: Nachdem systemd die ersten Aufgaben in wenigen Sekunden abgearbeitet hat, bleibt der Bootvorgang ca. 1 min hängen. DIe letzte Ausgabe auf dem Bootscreen ist:

    Quellcode

    1. reached target soundcard
    , danach passiert eine Weile nichts, dann kommt die Meldung

    Quellcode

    1. starting Plymouth boot screen
    und die Bestätigung

    Quellcode

    1. started Plymouth boot screen
    , dann passiert wieder eine Weile nichts, und dann rauscht der Rest durch und wenige Sekunden später habe ich meinen Loginmanager.

    Ich habe bisher keine Ursache für die Verzögerung gefunden und suche nun Rat.

    Folgende Nachforschungen habe ich angestellt:
    • Quellcode

      1. systemctl status
      zeigt keine Fehler, alle services sind mit einem grünen 'active' versehen
    • dmesg gibt mir den einzigen Hinweis, da ein Zeitsprung zwischen 6,35s und 97s auftritt:

      Quellcode

      1. <snip>
      2. [ 5.356689] XFS (sda3): Mounting Filesystem
      3. [ 5.366530] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
      4. [ 5.366732] cdrom: Uniform CD-ROM driver Revision: 3.20
      5. [ 5.366950] sr 1:0:0:0: Attached scsi CD-ROM sr0
      6. [ 5.488839] XFS (sda3): Ending clean mount
      7. [ 5.567852] i801_smbus 0000:00:1f.3: SMBus using PCI Interrupt
      8. [ 5.636839] input: PC Speaker as /devices/platform/pcspkr/input/input18
      9. [ 5.759339] kvm: VM_EXIT_LOAD_IA32_PERF_GLOBAL_CTRL does not work properly. Using workaround
      10. [ 6.156675] systemd-udevd[289]: renamed network interface eth0 to enp3s0
      11. [ 6.354719] iTCO_vendor_support: vendor-support=0
      12. [ 6.354965] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.10
      13. [ 6.355114] iTCO_wdt: unable to reset NO_REBOOT flag, device disabled by hardware/BIOS
      14. [ 6.355627] gpio_ich: GPIO from 180 to 255 on gpio_ich
      15. [ 97.074324] systemd-journald[232]: Received request to flush runtime journal from PID 1
      16. [ 97.108880] type=1400 audit(1386879609.858:2): apparmor="STATUS" operation="profile_load" name="/{usr/,}bin/ping" pid=483 comm="apparmor_parser"
      17. [ 97.118974] type=1400 audit(1386879609.868:3): apparmor="STATUS" operation="profile_load" name="/sbin/klogd" pid=491 comm="apparmor_parser"
      18. [ 97.125589] type=1400 audit(1386879609.875:4): apparmor="STATUS" operation="profile_load" name="/sbin/syslog-ng" pid=495 comm="apparmor_parser"
      19. [ 97.132081] type=1400 audit(1386879609.882:5): apparmor="STATUS" operation="profile_load" name="/sbin/syslogd" pid=499 comm="apparmor_parser"
      20. [ 97.143163] type=1400 audit(1386879609.893:6): apparmor="STATUS" operation="profile_load" name="/usr/lib/apache2/mpm-prefork/apache2" pid=504 comm="apparmor_parser"
      21. [ 97.143731] type=1400 audit(1386879609.893:7): apparmor="STATUS" operation="profile_load" name="/usr/lib/apache2/mpm-prefork/apache2//DEFAULT_URI" pid=504 comm="apparmor_parser"
      22. [ 97.144346] type=1400 audit(1386879609.894:8): apparmor="STATUS" operation="profile_load" name="/usr/lib/apache2/mpm-prefork/apache2//HANDLING_UNTRUSTED_INPUT" pid=504 comm="apparmor_parser"
      23. [ 97.144862] type=1400 audit(1386879609.894:9): apparmor="STATUS" operation="profile_load" name="/usr/lib/apache2/mpm-prefork/apache2//phpsysinfo" pid=504 comm="apparmor_parser"
      24. [ 97.151772] type=1400 audit(1386879609.901:10): apparmor="STATUS" operation="profile_load" name="/usr/lib/dovecot/deliver" pid=508 comm="apparmor_parser"
      25. [ 97.159606] type=1400 audit(1386879609.909:11): apparmor="STATUS" operation="profile_load" name="/usr/lib/dovecot/dovecot-auth" pid=512 comm="apparmor_parser"
      26. [ 97.485818] ip6_tables: (C) 2000-2006 Netfilter Core Team
      27. [ 97.523845] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
      28. [ 97.529696] ip_tables: (C) 2000-2006 Netfilter Core Team
      29. [ 99.359181] NET: Registered protocol family 17
      30. <snip>
      Alles anzeigen

      Eine Suche nach der gpio_ich-Meldung, die vor der Pause kommt, förderte nichts kritisches zu Tage.
    meine Hardware:
    • Motherboard: Gigabyte Technology Co., Ltd. H55N-USB3/H55N-USB3, BIOS F4 07/06/2010
    • Prozessor: Core i3 540 @ 3,07GHz
    • 4GB RAM, 2TB HDD (Western Digital WD20EARS), 32GB SSD (SanDisk SDSSDRC0)
      Auf der HDD ist eine SUSE 11.2, die gut läuft; die SUSE 13.2 befindet sich auf der SSD und nutzt die /home - Partition auf der HDD mit.
    • Grafikkarte: nvidia GeForce 220GT (mit dem nouveau-Treiber)
    Wäre schön, wenn jemand eine Idee hätte, wo ich weiterforschen kann!

    Für den Inhalt des Beitrages 62704 haftet ausdrücklich der jeweilige Autor: kafe

  • kafe schrieb:

    meine Hardware:
    Motherboard: Gigabyte Technology Co., Ltd. H55N-USB3/H55N-USB3, BIOS F4 07/06/2010
    Prozessor: Core i3 540 @ 3,07GHz4GB RAM, 2TB HDD (Western Digital WD20EARS), 32GB SSD (SanDisk SDSSDRC0)
    Auf der HDD ist eine SUSE 11.2, die gut läuft; die SUSE 13.2 befindet sich auf der SSD und nutzt die /home - Partition auf der HDD mit.
    Grafikkarte: nvidia GeForce 220GT (mit dem nouveau-Treiber)Wäre schön, wenn jemand eine Idee hätte, wo ich weiterforschen kann!


    Ähm bei dir läuft 13.2 oder 13.1 ?

    poste doch bitte:

    Quellcode

    1. cat /etc/os-release
    2. lsmod | grep gpio
    3. dmesg | grep gpio
    4. modinfo gpio_ich


    Installation als Upgrade oder Neuinstallation ?
    openSUSE 11.2 ist schon lange tot.... ==> de.opensuse.org/Lifetime

    LG SUSEDJAlex
    Uhrzeit richtig einstellen

    openSUSE Leap sowie Arch LInux in Nutzung

    Für den Inhalt des Beitrages 62705 haftet ausdrücklich der jeweilige Autor: SUSEDJAlex

  • äähm, 13.1 - die 13.2 war ein Tippfehler.
    Es ist eine Neuinstallation auf die neu eingebaute SSD (/dev/sdb1). Der Rechner ist mein Media-PC im Wohnzimmer und läuft seit etlicher Zeit (Stichwort SuSE 11.2, auf /dev/sda2) mit mythtv recht stabil. Nun will ich ihn mit der SSD auf Trab bringen und dabei auch ein neues OS verwenden - SuSE 13.1 als Evergreen-Version kommt mir da ganz gelegen. Zur Zeit läuft die 11.2 sozusagen als "Produktivsystem" und wenn ich die 13.1 soweit habe, wird der Standard-Booteintag im GruB umgeschaltet - soweit der Plan. Die /home - Partition mit den Daten (/dev/sda3) verwende ich für beide Systeme gemeinsam, aber mit verschiedenen Usern.

    So, und hier die Ausgaben:

    Quellcode

    1. troubi@troubi:~> cat /etc/os-release
    2. NAME=openSUSE
    3. VERSION="13.1 (Bottle)"
    4. VERSION_ID="13.1"
    5. PRETTY_NAME="openSUSE 13.1 (Bottle) (i586)"
    6. ID=opensuse
    7. ANSI_COLOR="0;32"
    8. CPE_NAME="cpe:/o:opensuse:opensuse:13.1"
    9. BUG_REPORT_URL="https://bugs.opensuse.org"
    10. HOME_URL="https://opensuse.org/"
    11. ID_LIKE="suse"
    12. troubi@troubi:~> lsmod | grep gpio
    13. gpio_ich 13229 0
    14. troubi@troubi:~> dmesg | grep gpio
    15. [ 5.150736] lpc_ich: Resource conflict(s) found affecting gpio_ich
    16. [ 5.356776] gpio_ich: GPIO from 180 to 255 on gpio_ich
    17. troubi@troubi:~> sudo /sbin/modinfo gpio_ich
    18. filename: /lib/modules/3.11.6-4-desktop/kernel/drivers/gpio/gpio-ich.ko
    19. alias: platform:gpio_ich
    20. license: GPL
    21. description: GPIO interface for Intel ICH series
    22. author: Peter Tyser <ptyser@xes-inc.com>
    23. srcversion: D3A82C9B5B58C085FBA9413
    24. depends:
    25. intree: Y
    26. vermagic: 3.11.6-4-desktop SMP preempt mod_unload modversions 686
    27. parm: gpiobase:The GPIO number base. -1 means dynamic, which is the default. (int)
    28. troubi@troubi:~> sudo systemd-analyze blame
    29. 1min 31.547s systemd-udev-settle.service
    30. 21.784s network.service
    31. 21.338s network@enp3s0.service
    32. 1.504s mysql.service
    33. 563ms xdm.service
    34. 150ms SuSEfirewall2.service
    35. 143ms home.mount
    36. 115ms SuSEfirewall2_init.service
    37. 102ms user@1000.service
    38. 101ms systemd-tmpfiles-clean.service
    39. 86ms kmod-static-nodes.service
    40. 80ms cycle.service
    41. 80ms sys-kernel-debug.mount
    42. 80ms systemd-udev-root-symlink.service
    43. 80ms dev-hugepages.mount
    44. 79ms systemd-readahead-replay.service
    45. 79ms dev-mqueue.mount
    46. 79ms systemd-readahead-collect.service
    47. 63ms ModemManager.service
    48. 56ms systemd-vconsole-setup.service
    49. 51ms systemd-sysctl.service
    50. 38ms systemd-tmpfiles-setup-dev.service
    51. 36ms rsyslog.service
    52. 35ms avahi-daemon.service
    53. 32ms dev-disk-by\x2did-ata\x2dWDC_WD20EARS\x2d00MVWB0_WD\x2dWMAZA2043095\x2dpart1.swap
    54. 31ms polkit.service
    55. 31ms systemd-random-seed.service
    56. 27ms plymouth-start.service
    57. 26ms user@488.service
    58. 26ms systemd-logind.service
    59. 19ms user@0.service
    60. 17ms alsa-restore.service
    61. 16ms accounts-daemon.service
    62. 14ms systemd-udev-trigger.service
    63. 12ms systemd-remount-fs.service
    64. 12ms plymouth-read-write.service
    65. 12ms systemd-user-sessions.service
    66. 9ms sundtek.service
    67. 9ms sshd.service
    68. 8ms rc-local.service
    69. 8ms lvm2-activation-early.service
    70. 7ms lvm2-activation.service
    71. 6ms systemd-modules-load.service
    72. 5ms systemd-fsck@dev-disk-by\x2did-ata\x2dWDC_WD20EARS\x2d00MVWB0_WD\x2dWMAZA2043095\x2dpart3.service
    73. 4ms systemd-update-utmp-runlevel.service
    74. 4ms systemd-udevd.service
    75. 4ms systemd-tmpfiles-setup.service
    76. 3ms systemd-readahead-done.service
    77. 2ms systemd-journal-flush.service
    78. 2ms var-run.mount
    79. 2ms systemd-update-utmp.service
    80. 1ms var-lock.mount
    Alles anzeigen

    Für den Inhalt des Beitrages 62717 haftet ausdrücklich der jeweilige Autor: kafe

  • 1. Hast Du Dein Netzwerk mit ifup/Yast eingerichtet?
    Wenn ja, bist Du auch von einem bis heute noch nicht gefixten Fehler betroffen (ebenso wie ich)
    21.784s network.service
    21.338s network@enp3s0.service
    1.504s mysql.service

    Die 20 Sekunden wirst Du evtl nur mit Umstellen auf Networkmanager wegbekommen.

    2.
    1min 31.547s systemd-udev-settle.service
    21.784s network.service

    Da läuft irgendwas quer, irgendwo ein mount eines USB-Gerätes?
    Meine Ausgabe:

    Quellcode

    1. systemctl status systemd-udev-settle.service
    2. systemd-udev-settle.service - udev Wait for Complete Device Initialization
    3. Loaded: loaded (/usr/lib/systemd/system/systemd-udev-settle.service; static)
    4. Active: active (exited) since Fr 2013-12-13 13:15:43 CET; 7h ago
    5. Docs: man:udev(7)
    6. man:systemd-udevd.service(8)
    7. Main PID: 371 (code=exited, status=0/SUCCESS)
    8. Dez 13 13:15:43 linux64 systemd[1]: Started udev Wait for Complete Device Initialization.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 62720 haftet ausdrücklich der jeweilige Autor: Sauerland

  • 1. Hast Du Dein Netzwerk mit ifup/Yast eingerichtet?
    Hm, ich habe, glaube ich, nichts vom Standardvorschlag abweichendes getan. Ich werd mal morgen probieren, auf den Networkmanager umzustellen, um die 20s zu gewinnen. Bleibt noch die 1min für das udev-settle.

    Quellcode

    1. troubi@troubi:~> systemctl status systemd-udev-settle.service
    2. systemd-udev-settle.service - udev Wait for Complete Device Initialization
    3. Loaded: loaded (/usr/lib/systemd/system/systemd-udev-settle.service; static)
    4. Active: active (exited) since Sa 2013-12-14 13:44:39 CET; 11min ago
    5. Docs: man:udev(7)
    6. man:systemd-udevd.service(8)
    7. Process: 310 ExecStart=/usr/bin/udevadm settle (code=exited, status=0/SUCCESS)
    8. Main PID: 310 (code=exited, status=0/SUCCESS)


    Gibt es eine Möglichkeit, udev auf die Finger zu gucken, womit es sich so lange aufhält?

    Ich hatte bei der Installation einen im Gehäuse eingebauten Kartenleser dran, hab den aber zwischenzeitlich abgezogen, weil ich ihn schon im Verdacht hatte. Ebenso einen USB-RS232-Wandler. Es sind jetzt nur noch die Funktastatur und der TV-Tuner dran. Letzteren hatte ich zum Test auch schon mal weggelassen, ohne Erfolg.
    dmesg |grep usb scheint erstmal nichts verdächtiges zu zeigen, oder?

    Quellcode

    1. troubi@troubi:~> dmesg |grep usb
    2. [ 0.189925] usbcore: registered new interface driver usbfs
    3. [ 0.189931] usbcore: registered new interface driver hub
    4. [ 0.189949] usbcore: registered new device driver usb
    5. [ 0.509661] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    6. [ 0.509662] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    7. [ 0.509664] usb usb1: Product: EHCI Host Controller
    8. [ 0.509665] usb usb1: Manufacturer: Linux 3.11.6-4-desktop ehci_hcd
    9. [ 0.509666] usb usb1: SerialNumber: 0000:00:1a.7
    10. [ 0.519645] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
    11. [ 0.519646] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    12. [ 0.519647] usb usb2: Product: EHCI Host Controller
    13. [ 0.519649] usb usb2: Manufacturer: Linux 3.11.6-4-desktop ehci_hcd
    14. [ 0.519650] usb usb2: SerialNumber: 0000:00:1d.7
    15. [ 0.519967] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
    16. [ 0.519969] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    17. [ 0.519970] usb usb3: Product: UHCI Host Controller
    18. [ 0.519971] usb usb3: Manufacturer: Linux 3.11.6-4-desktop uhci_hcd
    19. [ 0.519973] usb usb3: SerialNumber: 0000:00:1a.0
    20. [ 0.520242] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
    21. [ 0.520244] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    22. [ 0.520245] usb usb4: Product: UHCI Host Controller
    23. [ 0.520246] usb usb4: Manufacturer: Linux 3.11.6-4-desktop uhci_hcd
    24. [ 0.520248] usb usb4: SerialNumber: 0000:00:1a.1
    25. [ 0.520503] usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
    26. [ 0.520505] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    27. [ 0.520506] usb usb5: Product: UHCI Host Controller
    28. [ 0.520507] usb usb5: Manufacturer: Linux 3.11.6-4-desktop uhci_hcd
    29. [ 0.520509] usb usb5: SerialNumber: 0000:00:1a.2
    30. [ 0.520773] usb usb6: New USB device found, idVendor=1d6b, idProduct=0001
    31. [ 0.520774] usb usb6: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    32. [ 0.520776] usb usb6: Product: UHCI Host Controller
    33. [ 0.520777] usb usb6: Manufacturer: Linux 3.11.6-4-desktop uhci_hcd
    34. [ 0.520778] usb usb6: SerialNumber: 0000:00:1d.0
    35. [ 0.521038] usb usb7: New USB device found, idVendor=1d6b, idProduct=0001
    36. [ 0.521040] usb usb7: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    37. [ 0.521041] usb usb7: Product: UHCI Host Controller
    38. [ 0.521043] usb usb7: Manufacturer: Linux 3.11.6-4-desktop uhci_hcd
    39. [ 0.521044] usb usb7: SerialNumber: 0000:00:1d.1
    40. [ 0.521295] usb usb8: New USB device found, idVendor=1d6b, idProduct=0001
    41. [ 0.521297] usb usb8: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    42. [ 0.521298] usb usb8: Product: UHCI Host Controller
    43. [ 0.521300] usb usb8: Manufacturer: Linux 3.11.6-4-desktop uhci_hcd
    44. [ 0.521301] usb usb8: SerialNumber: 0000:00:1d.2
    45. [ 0.805293] usbcore: registered new interface driver usbhid
    46. [ 0.805294] usbhid: USB HID core driver
    47. [ 0.862719] usb 1-6: new high-speed USB device number 3 using ehci-pci
    48. [ 0.979213] usb 1-6: New USB device found, idVendor=eb1a, idProduct=51b2
    49. [ 0.979218] usb 1-6: New USB device strings: Mfr=3, Product=1, SerialNumber=2
    50. [ 0.979221] usb 1-6: Product: MediaTV Pro II
    51. [ 0.979224] usb 1-6: Manufacturer: Sundtek
    52. [ 0.979226] usb 1-6: SerialNumber: 0101217165922
    53. [ 1.289890] usb 4-1: new low-speed USB device number 2 using uhci_hcd
    54. [ 1.459542] usb 4-1: New USB device found, idVendor=05af, idProduct=0408
    55. [ 1.459548] usb 4-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    56. [ 1.459551] usb 4-1: Product: 2.4G USB RF KeyBoard
    57. [ 1.491724] input: 2.4G USB RF KeyBoard as /devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.0/input/input0
    58. [ 1.492027] hid-generic 0003:05AF:0408.0001: input,hidraw0: USB HID v1.10 Keyboard [2.4G USB RF KeyBoard] on usb-0000:00:1a.1-1/input0
    59. [ 1.510705] input: 2.4G USB RF KeyBoard as /devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.1/input/input1
    60. [ 1.511171] hid-generic 0003:05AF:0408.0002: input,hidraw1: USB HID v1.10 Mouse [2.4G USB RF KeyBoard] on usb-0000:00:1a.1-1/input1
    61. [ 1.546626] input: 2.4G USB RF KeyBoard as /devices/pci0000:00/0000:00:1a.1/usb4/4-1/4-1:1.2/input/input2
    62. [ 1.547132] hid-generic 0003:05AF:0408.0003: input,hiddev0,hidraw2: USB HID v1.10 Device [2.4G USB RF KeyBoard] on usb-0000:00:1a.1-1/input2
    Alles anzeigen

    Für den Inhalt des Beitrages 62737 haftet ausdrücklich der jeweilige Autor: kafe

  • So, habe jetzt mal den Networkmanager aktiviert. Die 20s des erwähnten ifup-Bugs habe ich damit schon mal gewonnen:

    Quellcode

    1. troubi@troubi:~> sudo systemd-analyze blame
    2. 1min 31.535s systemd-udev-settle.service
    3. 1.502s mysql.service
    4. 551ms xdm.service
    5. 171ms home.mount
    6. [...]


    Danke, Sauerland! :thumbup:

    Nun würde ich noch gern herausbekommen, worauf der systemd-udev-settle.service so lange wartet -- hat jemand eine Idee?

    Für den Inhalt des Beitrages 62751 haftet ausdrücklich der jeweilige Autor: kafe

  • thomas23 schrieb:


    Ist das System auf dem aktuellsten Stand?
    Sind alle Updates gemacht und Patches eingespielt?
    Das letzte Update war so vor 3 Tagen, habe gerade nochmal ein frisches gemacht - leider ohne Erfolg.

    Für den Inhalt des Beitrages 62767 haftet ausdrücklich der jeweilige Autor: kafe

  • Wie machst du Updates?
    Ich spreche hier von Patch-Updates, die Fehler im System beseitigen.

    In Yast wäre das der Eintrag: Online-Aktualisierung.

    Für den Inhalt des Beitrages 62768 haftet ausdrücklich der jeweilige Autor: thomas23