Nach Anmeldung mit SSH ein Program mit X-Server starten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Nach Anmeldung mit SSH ein Program mit X-Server starten gibt es 13 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Nach Anmeldung mit SSH ein Program mit X-Server starten

    Hallo Leute,
    nach dem ein Suseentwickler (nach Auskunft der Leute bei KDE und VNC) KVNC ab der 12.3 so verändert hat, das man sich nicht mehr am Anmeldebildschirm der Remote-Maschine anmelden kann sondern das Teil laufen muss und ein User angemeldet sein muss der eine automatische Annahme der VNC-Sitzung eingerichtet hat frage ich mich, wie komme ich beispielsweise auf meinen Server um Programme zu starten. Ich habe das Thema bereits angesprochen wurde aber nur an das Team von VNC verwiesen. Auch eine entsprechende BUG-Meldung interessiert niemanden und an die zuständigen Entwickler ist ja kein Rankommen.
    Ich habe es mit SSH probiert. Ich logge mich ein und wenn ich dann ein Programm mit X-Server starten will kommt eine Fehlermeldung.
    Kann mir bitte jemand sagen was ich falsch mache?
    OpenSuse 13.1 64 bit, KDE, RADEON HD 7870.
    Dank und Gruß

    Im Übrigen allen ein gesundes neues Jahr und alles Gute.
    Einen riesen Dank an die Admins die hier Tag ein Tag aus ihren tollen Job machen. :smilie_pc_012:

    Für den Inhalt des Beitrages 63450 haftet ausdrücklich der jeweilige Autor: fanifeey

  • Was für eine Fehlermeldung denn?

    Was meinst du mit "Programm mit X-Server" ?
    Ich würde versuchen eine X-Session zu starten und dann davon eben das Programm.
    (Vllt. meinst du das)
    ___________________________________________________________________________________
    Zypper Befehlsreferenz

    Für den Inhalt des Beitrages 63451 haftet ausdrücklich der jeweilige Autor: lush

  • Ja so meine ich es sicher.
    Ich habe mich wie gesagt mit ssh angemeldet und dann auf der Konsole mit krfb --display versucht krfb zu starten.
    In der Hilfe Steht dazu:
    "--display <displayname> X-Server-Darstellung namens „Anzeige“ benutzen"

    Was ich auch als displayname probiere:
    "krfb: „<displayname>“ fehlt.
    krfb: Benutzen Sie den Parameter „--help“, um die verfügbaren Optionen zu sehen."

    ?(

    Für den Inhalt des Beitrages 63456 haftet ausdrücklich der jeweilige Autor: fanifeey

  • Ein weiterer Versuch.
    Ich bin über SSH als root angemeldet und:
    .... # krfb --display KDM
    krfb: cannot connect to X server KDM
    Die gleiche Meldung bei Verwendung von GDM, Xtherm.

    Was ist falsch?
    :wacko:

    Für den Inhalt des Beitrages 63458 haftet ausdrücklich der jeweilige Autor: fanifeey

  • Hallo lush

    krfb --display <displayname> sollte aber die X-Session starten. (nach meinem Verständnis, denn --display ist die Option die dies veranlasst)
    Oder wie startest Du eine X-Session?
    Alles was ich gefunden habe führt mich immer wieder zu meiner Methode.
    Gruß

    Für den Inhalt des Beitrages 63467 haftet ausdrücklich der jeweilige Autor: fanifeey

  • Hallo Leute,
    neuer Anlauf:

    ......:~> ssh -X -C root@192.168.0.3
    Password:
    X11 forwarding request failed on channel 0
    Last login: Sat Jan 4 11:29:17 2014 from xxx.yyy
    Have a lot of fun...

    Auch das funktioniert nicht. Muss man irgendwo den remote-Start des X-Server gestatten?
    ;(

    Für den Inhalt des Beitrages 63469 haftet ausdrücklich der jeweilige Autor: fanifeey

  • ALso ich hätte mal probiert mich einfach per SSH einzuloggen und dann mit "startx" eine grafische Oberfläche zu starten.
    Musst dann aber die ~/.xinitrc des verwendeten Users anpassen, und den Befehl zum Starten des eigentlichen Desktops reinsetzen.
    Sowas wie "exec startkde" oder "exec i3".

    Habe ich aber wie gesagt selbst noch nicht getestet..
    ___________________________________________________________________________________
    Zypper Befehlsreferenz

    Für den Inhalt des Beitrages 63470 haftet ausdrücklich der jeweilige Autor: lush

  • Hallo lush,

    wenn ich mich wie vorgeschlagen über ssh einlogge und dann: startx erscheint nach einer laangen Liste am Ende die Fehlermeldung:

    #file:///usr/lib/kde4/imports/org/kde/plasma/components/Button.qml:194:5: QML Row: Bei der Fülloperation wurde eine potentielle #Endlosschleife der Anker festgestellt.
    #file:///usr/lib/kde4/imports/org/kde/plasma/extras/ScrollArea.qml:96: TypeError: Result of expression 'verticalScrollBar' [null] is not #an object.
    #file:///usr/lib/kde4/imports/org/kde/plasma/extras/ScrollArea.qml:120: TypeError: Result of expression 'horizontalScrollBar' [null] is #not an object.

    und nichts geht. (die Rauten sind von mir)
    Mit der .xinitrc kann ich nichts anfangen.
    Was mich irritiert, ich habe alles nach: "http://codingdomain.com/linux/remote/x11/" konfiguriert und ... nix
    Gruß und Dank
    :smilie_pc_153:

    Für den Inhalt des Beitrages 63473 haftet ausdrücklich der jeweilige Autor: fanifeey

  • fanifeey schrieb:

    nach dem ein Suseentwickler (nach Auskunft der Leute bei KDE und VNC) KVNC ab der 12.3 so verändert hat, das man sich nicht mehr am Anmeldebildschirm der Remote-Maschine anmelden kann sondern das Teil laufen muss und ein User angemeldet sein muss der eine automatische Annahme der VNC-Sitzung eingerichtet hat frage ich mich, wie komme ich beispielsweise auf meinen Server um Programme zu starten. Ich habe das Thema bereits angesprochen wurde aber nur an das Team von VNC verwiesen.


    Hast du mal über tightvnc o.ä. nachgedacht? Das sollte eigentlich funktionieren.

    flo
    Auch zu finden bei der Mailingliste opensuse-de sowie im IRC als User grossing in den Netzwerken freenode und oftc - querys sind erlaubt, die Antwort kann dauern ;)

    Der Channel zum Forum: ##os-forum auf irc.freenode.net
    Per webchat webchat.freenode.net/##os-forum

    Alle von mir genannten Befehle sind als User auszuführen, außer ich schreibe explizit dazu "als root ausführen"!

    Meine Homepage

    Für den Inhalt des Beitrages 63504 haftet ausdrücklich der jeweilige Autor: grossing