Leap42.3: pyqt5, 5.10.1; libQt5Core, 5.11.1 ... autom. Deinstallationen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Leap42.3: pyqt5, 5.10.1; libQt5Core, 5.11.1 ... autom. Deinstallationen gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Leap42.3: pyqt5, 5.10.1; libQt5Core, 5.11.1 ... autom. Deinstallationen

    Wenn man kein Glück hat kommt immer auch noch Pech dazu!

    Beim Kompilieren von Sourcen von github erscheint folgende Fehlermeldung:
    Could not find a version that satisfies the requirement pyqt5==5.10.1

    Also versucht dies nachzuinstallieren via software.opensuse.org - community packages - home:Sauerland (bevorzugt)
    python-qt5-5.10.1-107.1.x86_64.rpm ... benötigt libQt5Core entsprechend.

    Dann ebenso wie zuvor:
    libQt5Core5-5.11.1-2.1.x86_64.rpm ... versucht zu installieren. Dies liefert:


    Quellcode

    1. $:> sudo zypper install libQt5Core5-5.11.1-2.1.x86_64
    2. Repository-Daten werden geladen...
    3. Installierte Pakete werden gelesen...
    4. Paketabhängigkeiten werden aufgelöst...
    5. Problem: python3-qt5-5.5.1-14.26.x86_64 benötigt libQt5Core.so.5(Qt_5.6.2_PRIVATE_API)(64bit), kann jedoch nicht zur Verfügung gestellt werden
    6. Lösung 1: Folgende Aktionen werden ausgeführt:
    7. Deinstallation von python3-qt5-5.5.1-14.26.x86_64
    8. libQt5DBus5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    9. openSUSE --> obs://build.opensuse.org/home:Sauerland
    10. libQt5Gui5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    11. openSUSE --> obs://build.opensuse.org/home:Sauerland
    12. libQt5Multimedia5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    13. openSUSE --> obs://build.opensuse.org/home:Sauerland
    14. libQt5Network5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    15. openSUSE --> obs://build.opensuse.org/home:Sauerland
    16. libQt5OpenGL5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    17. openSUSE --> obs://build.opensuse.org/home:Sauerland
    18. libQt5Positioning5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    19. openSUSE --> obs://build.opensuse.org/home:Sauerland
    20. libQt5PrintSupport5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    21. openSUSE --> obs://build.opensuse.org/home:Sauerland
    22. Deinstallation von libQt5Script5-5.6.2-1.18.x86_64
    23. libQt5Sensors5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    24. openSUSE --> obs://build.opensuse.org/home:Sauerland
    25. libQt5SerialPort5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    26. openSUSE --> obs://build.opensuse.org/home:Sauerland
    27. libQt5Sql5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    28. openSUSE --> obs://build.opensuse.org/home:Sauerland
    29. libQt5Sql5-mysql-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    30. openSUSE --> obs://build.opensuse.org/home:Sauerland
    31. libQt5Sql5-sqlite-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    32. openSUSE --> obs://build.opensuse.org/home:Sauerland
    33. libQt5Svg5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    34. openSUSE --> obs://build.opensuse.org/home:Sauerland
    35. libQt5Test5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    36. openSUSE --> obs://build.opensuse.org/home:Sauerland
    37. libQt5WebChannel5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    38. openSUSE --> obs://build.opensuse.org/home:Sauerland
    39. libQt5WebSockets5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    40. openSUSE --> obs://build.opensuse.org/home:Sauerland
    41. libQt5Widgets5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    42. openSUSE --> obs://build.opensuse.org/home:Sauerland
    43. libQt5Xml5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    44. openSUSE --> obs://build.opensuse.org/home:Sauerland
    45. libQt5XmlPatterns5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    46. openSUSE --> obs://build.opensuse.org/home:Sauerland
    47. libQtQuick5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    48. openSUSE --> obs://build.opensuse.org/home:Sauerland
    49. libqt5-linguist-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    50. openSUSE --> obs://build.opensuse.org/home:Sauerland
    51. libqt5-qtdeclarative-tools-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    52. openSUSE --> obs://build.opensuse.org/home:Sauerland
    53. Deinstallation von python-qt5-5.5.1-8.26.x86_64
    54. libqt5-qtwebengine-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    55. openSUSE --> obs://build.opensuse.org/home:Sauerland
    56. libQt5Core-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    57. openSUSE --> obs://build.opensuse.org/home:Sauerland
    58. libQt5Concurrent5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    59. openSUSE --> obs://build.opensuse.org/home:Sauerland
    60. Deinstallation von libKF5Declarative5-5.32.0-1.3.x86_64
    61. Deinstallation von kwin5-5.8.7-2.1.x86_64
    62. libQt5DBus-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    63. openSUSE --> obs://build.opensuse.org/home:Sauerland
    64. libQt5Gui-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    65. openSUSE --> obs://build.opensuse.org/home:Sauerland
    66. libQt5Designer5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    67. openSUSE --> obs://build.opensuse.org/home:Sauerland
    68. Deinstallation von kwayland-5.32.0-1.3.x86_64
    69. libQt5Network-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    70. openSUSE --> obs://build.opensuse.org/home:Sauerland
    71. libQt5OpenGL-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    72. openSUSE --> obs://build.opensuse.org/home:Sauerland
    73. libQt5PrintSupport-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    74. openSUSE --> obs://build.opensuse.org/home:Sauerland
    75. Deinstallation von ktexteditor-5.32.0-3.2.x86_64
    76. Deinstallation von kio-5.32.0-5.1.x86_64
    77. Deinstallation von libKF5I18n5-5.32.0-1.3.x86_64
    78. Deinstallation von kross-5.32.0-1.3.x86_64
    79. Deinstallation von grantlee5-5.1.0-3.4.x86_64
    80. libQt5Sql-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    81. openSUSE --> obs://build.opensuse.org/home:Sauerland
    82. libQt5Test-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    83. openSUSE --> obs://build.opensuse.org/home:Sauerland
    84. libQt5Widgets-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    85. openSUSE --> obs://build.opensuse.org/home:Sauerland
    86. libQt5Xml-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    87. openSUSE --> obs://build.opensuse.org/home:Sauerland
    88. libQt5WebKit5-imports-5.212~alpha2-9.2.x86_64 installieren (mit Anbieterwechsel)
    89. openSUSE --> obs://build.opensuse.org/home:Sauerland
    90. libQt5WebKit5-5.212~alpha2-9.2.x86_64 installieren (mit Anbieterwechsel)
    91. openSUSE --> obs://build.opensuse.org/home:Sauerland
    92. libqt5-qtdeclarative-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    93. openSUSE --> obs://build.opensuse.org/home:Sauerland
    94. libqt5-qtquickcontrols-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    95. openSUSE --> obs://build.opensuse.org/home:Sauerland
    96. libqt5-qttools-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    97. openSUSE --> obs://build.opensuse.org/home:Sauerland
    98. Deinstallation von plasma5-integration-plugin-5.9.4-4.6.1.x86_64
    99. Deinstallation von xdg-desktop-portal-kde-5.10.3-3.1.x86_64
    100. Deinstallation von plasma5-workspace-5.8.7-11.1.x86_64
    101. libqt5-qtsensors-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    102. openSUSE --> obs://build.opensuse.org/home:Sauerland
    103. libqt5-qtsvg-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    104. openSUSE --> obs://build.opensuse.org/home:Sauerland
    105. libQt5WebChannel5-imports-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    106. openSUSE --> obs://build.opensuse.org/home:Sauerland
    107. Deinstallation von libqt5-qtgraphicaleffects-5.6.2-1.3.x86_64
    108. libqt5-linguist-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    109. openSUSE --> obs://build.opensuse.org/home:Sauerland
    110. Deinstallation von python-qt5-devel-5.5.1-8.26.x86_64
    111. Deinstallation von python3-qt5-devel-5.5.1-14.26.x86_64
    112. libQt5PlatformHeaders-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    113. openSUSE --> obs://build.opensuse.org/home:Sauerland
    114. libqt5-qtbase-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    115. openSUSE --> obs://build.opensuse.org/home:Sauerland
    116. Deinstallation von libKF5Declarative5-lang-5.32.0-1.3.noarch
    117. ...1)*
    118. Deinstallation von kcalutils-lang-17.04.2-1.1.noarch
    119. libqt5-qtbase-common-devel-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    120. openSUSE --> obs://build.opensuse.org/home:Sauerland
    121. libQt5Help5-5.11.1-2.1.x86_64 installieren (mit Anbieterwechsel)
    122. openSUSE --> obs://build.opensuse.org/home:Sauerland
    123. Deinstallation von libKF5Bookmarks5-lang-5.32.0-1.3.noarch
    124. Deinstallation von milou5-lang-5.8.7-1.1.noarch
    125. Deinstallation von kded-lang-5.32.0-1.3.noarch
    126. Lösung 2: libQt5Core5-5.11.1-2.1.x86_64 nicht installieren
    127. Lösung 3: python3-qt5-5.5.1-14.26.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
    128. Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/3/a] (a):
    Alles anzeigen

    Verursacht bei mir mehr als nur gefühlte Bauchschmerzen dies durchzuführen.
    ?( Warum die ganzen Deinstallationen?

    :!: ob ich python3-qt5 unbedingt benötige weiß ich nicht

    ?( Hab ich was übersehen oder wie bekommen ich für Leap42.3 PyQt5 auf eine Version >=5.10.1?
    Dateien
    honi soit qui mal y pense :: lärnt L.i.n.u.x zu buchstabieren

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von TuxSv748 ()

    Für den Inhalt des Beitrages 121897 haftet ausdrücklich der jeweilige Autor: TuxSv748

  • Du versaust dir dein System.
    Warum willst du etwas kompilieren?

    Ich habe gimp aus meinem Repo installiert, in diesem Repo sind alle!!!!! Abhängigkeiten für diese Version von gimp vorhanden.

    Poste einfach:

    Quellcode

    1. zypper se -si gimp gegl babl libglib-2
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 121899 haftet ausdrücklich der jeweilige Autor: Sauerland

  • DAS IST NICHT GIMP

    ist was neues: openSnitch
    honi soit qui mal y pense :: lärnt L.i.n.u.x zu buchstabieren

    Für den Inhalt des Beitrages 121901 haftet ausdrücklich der jeweilige Autor: TuxSv748

  • Aus dem anderen Beitrag:

    Wollte gimp2.10 unter Leap 42.3 ans Laufen bekommen. Installation mit Anhängigkeiten ist soweit durchgelaufen,

    python-qt5-5.10.1-107.1.x86_64.rpm
    Das Paket gibt es in meinem Repo nicht........
    Braucht man auch für gimp nicht
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 121902 haftet ausdrücklich der jeweilige Autor: Sauerland

  • TuxSv748 schrieb:

    DAS IST NICHT GIMP
    ist hier eine NEUES Thema, betrifft nicht gimp sondern :!: openSnitch :!: -> opensnitch

    Sauerland schrieb:

    Ich würde die Probleme nacheinander angehen!!!!!
    wollte jetzt auch erst snitch angehen und danach wieder gimp, lief aber nicht so wie geplant.
    honi soit qui mal y pense :: lärnt L.i.n.u.x zu buchstabieren

    Für den Inhalt des Beitrages 121904 haftet ausdrücklich der jeweilige Autor: TuxSv748

  • Und die Pakete sind alle aus dem musescore Repo:
    Show home:Sauerland:musescore - openSUSE Build Service

    Lass es.
    Die sind nicht für das normale Leap 42.3 geeignet, sondern für das QT5 Repo.

    Nicht einfach irgendwas machen, vorher lesen und wenn man es nicht versteht, nachfragen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 121905 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Übrigens verbaust du dir mit dieser Aktion gerade dein System......

    Und damit das nicht passiert, hab ich das Sauerland:musescore gerade gelöscht.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 121909 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Sauerland schrieb:

    Übrigens verbaust du dir mit dieser Aktion gerade dein System......
    bisher habe ich noch keine der beiden Pakete installiert.

    Sauerland schrieb:

    musescore Repo
    wenn man bei software.opensuse.org nach Pakten sucht bekommt man nicht unbedingt alle Details angezeigt.
    zunächst das offizielle Paket, wenn die Versionnummer nicht passt kann man noch die Community Pakete auflisten lassen, dort nach der Versionsnummer entscheiden. Alle weiteren Informationen müsste man sich schon tiefer erarbeiten. Wer macht das - normalerweise - ? Versionsnummer ist da aussagekräftig genug in den meisten Fällen. So kann man sich täuschen!!

    Werde snitch wohl nicht mehr für Leap42.3 bauen, evtl. mit Leap15.0 versuchen - sonst geht mir zuviel kaputt

    ps GIMP:
    ich habe meinen Beitrag im andeern Thread ergänzt, da fehlt ein rpm auf home:Sauerland ... besagtes mit Version 2.10.3
    honi soit qui mal y pense :: lärnt L.i.n.u.x zu buchstabieren

    Für den Inhalt des Beitrages 121921 haftet ausdrücklich der jeweilige Autor: TuxSv748