Amarok & Dragonplayer, Codecs laufen nicht.

Hinweis: In dem Thema Amarok & Dragonplayer, Codecs laufen nicht. gibt es 2 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hey ho,


    hab mir ein frisches openSUSE Leap 42.1 mit KDE installiert, als erstes Updates gemacht und dann mit snapper nen "sauberen" Snapshot (btrfs sollte klar sein, sei aber trotzdem nochmal erwähnt) angelegt.


    Dann habe ich mich den Multimediafähigkeiten des Systems angenommen und bin komplett gescheitert. Dragonplayer spielt nach wie vor keine mp4 und auch keine flv ab, amarok gibt überhaupt keine Töne von sich, dazu gleich mehr.


    What I have done so far:


    1. 1-Click-installation:
    Die KDE-Codecs von dieser Seite haben keine Änderungen am Verhalten von dragon und amarok getan: http://opensuse-community.org/


    2. gstreamer-0_10_plugins-fluendo_mp3 manuell nachinstallieren hat für amarok auch keine Wirkung erbracht.


    3. Ich hatte festgestellt, dass gstreamer ein absolutes Chaos aus Packman und opensuse Repositories war und habe alles, was ging, auf Packman umgestellt. Auch das blieb ohne Erfolg.


    4. Zum Schluss habe ich auch amarok auf Packman umgestellt, keine Änderung.


    Hier ein paar Informationen, wie meine Pakete momentan aussehen:


    Code
    zypper se -si amarok
    Loading repository data...
    Reading installed packages...
    S | Name | Type | Version | Arch | Repository
    --+-------------+---------+------------+--------+-------------------
    i | amarok | package | 2.8.0-29.1 | x86_64 | Packman Repository
    i | amarok-lang | package | 2.8.0-29.1 | noarch | Packman Repository




    Hier noch ein paar weitere (gekürzt, ähnliche gelöscht) Zeilen, dessen, was amarok ausspuckt, wenn man es in der Konsole startet:



    Das war der Grund, warum ich mich überhaupt mit gstreamer beschäftigt habe.


    Abgesehen davon hab ich mich noch nicht viel um den dragonplayer speziell gekümmert. Falls da jemand Ideen hat oder Informationen braucht bin ich für Vorschläge offen.


    Falls ich irgendetwas kaputt gemacht haben sollte, müsste es ohne Probleme mit snapper zurücksetzbar sein. Allerdings war der 1-Click-Install allein nicht die Lösung.


    lg.
    Tris

  • Hey,


    danke für die schnelle Antwort.


    Das Löschen von den ugly-plugins allein hat leider nichts gebracht, aber der Link den du mir dazu gegeben hast hat mich dazu veranlasst ein wenig zu experimentieren. Ich habe die gesamte 1-Click-Installation rückgängig gemacht und alles einschließlich amarok zurück auf opensuse-repository gestellt. Danach wie es in deinem verlinketen Forums-Thread stand nur diese libav der Version 1.4.5 manuell nachinstalliert.


    Das hatte eine Wirkung: Amarok kann jetzt mp3 und m4a abspielen. Der dragonplayer kann jetzt immerhin mp4. Aber leider kann der dragonplayer noch kein flv. Ich werde aber wahrscheinlich noch vlc installieren, der aber normalerweise seine Codecs selbst mitbringt (und aus Packman normal auch alle, falls es aber zu vlc spezifisch Probleme geben sollte wird das nen eigener Thread).


    Es sieht so aus als würde die Version 1.6.x nicht sonderlich zuverlässig laufen. Oder zumindest nicht bei allen. Von der Seite konnte ich alledings die anderen Plugins (z.b. bad & ugly), ebenfalls Version 1.4.5_x nicht manuell nachinstallieren, da Abhänigkeiten nicht aufgelöst werden konnten (ziiiiemlich viele...). Auch das erneute hinzufügen von Packman konnte die Abhängigkeiten nicht lösen.


    Offensichtlich hab ich jetzt einige von den (für mich) wichtigsten Formate/Codecs, aber bestimmt nicht alle über die man so stolpern könnte.


    In der Version 1.4.5_x alles installieren zu wollen wird offensichtlich eine ganze Menge Handarbeit. Bevor ich mich da also durchquäle die Frage:


    Ist das überhaupt eine "gute Lösung"? Auf die Art und Weise steht halt nicht wirklich ein Repository dahinter. Aber die Version 1.6.x habe ich ja nicht zum laufen gebracht.


    Die Version ist mir ansonsten eigentlich egal, Hauptsache die Codecs sind da.


    lg.
    Tris