Win7 MBR und Tumbleweed GPT parallel -> Boot Problem

Hinweis: In dem Thema Win7 MBR und Tumbleweed GPT parallel -> Boot Problem gibt es 21 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Moin!


    Liebe Gemeinde, ich muß Euch - nach Jahren (zufriedener 13.1 Nutzung) - mal wieder belästigen ... und das Folgende ist schon die Kurzform:
    Mein liebgewonnes Rechnerchen ist leider abgeraucht, Staubinfarkt oder Altersschwäche, leider war nur noch der Tod festzustellen...
    Reines Dummenglück: Der "neue" PC kam von selbst, vom Kollegen:
    hp pro 3500
    intel 2 kern, 4 gb ram
    intel grafik
    orig. 500 gb hd mit win7pro
    Da auf dem erstaunlich sauberen Windows bereits (für mich wertvolle und) teure Software installiert war und alles reibungsfrei läuft, will ich das nicht anfassen.
    HD: Windows a la nature: MBR + Bootpartition + SystempartitionNTFS + Partition FAT32 zum zukünftigen Datenaustausch mit dem Linux.(Mittlerweile auch schon gut gefüllt.)
    Also hab ich
    1 tb Festplatte reingestopft.
    Wollte ein aktuelles SUSE draufhaben, wegen saulangsamem Internet ab zum Zeitschriftenhändler, gesucht nach leap, gefunden:tumbleweed. OK. Leider Fehlgriff, der Installer startet die Installation nicht von der DVD, sondern macht ne Internet-Install. ÄCHZ. Bei meinem dünnen Netzchen also fast 24 Stunden später: Installiert.
    Auf nix geachtet, System einfach machen lassen….
    Es entstand eine GPT – hd mit etlichen Partitionen: Nr 4 (sdb4)ist /
    Nach Neustart: Windows!
    ALLE (spärlichen) Bioseinstellungen versucht, 1000 tolle Tips aus dem Netzversucht … NO WAY
    SuperGrub2 … manuell … sdb4: Linux!
    ALLES MÖGLICHE getan und getutet:
    Neustart: Windows!
    Also sch… auf grub2 → Windows Bootloader benutzen:
    Nach 1000 tollen Tips und Tools: Auch noch Grub2 vom Linux zerschossen – ächz – neu gemacht: NIX!


    ...


    Momentan ist also immerhin wieder der lange Weg über SuperGrubmöglich, System ist auch schon fein eingerichtet. Will ich also auchnicht mehr anfassen...



    HILFE!

    2 Mal editiert, zuletzt von Mikesch ()

    Für den Inhalt des Beitrages 118009 haftet ausdrücklich der jeweilige Autor: Mikesch

  • Wenn du nicht hinlangen willst, bleibt es, wie es ist.


    Oder zeige hier die Partitionen (fdisk -l als root)
    Wird mit SecureBoot gestartet?

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 118010 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Kein SecureBoot,

    Benutze für Konsolenausgaben bitte Code-Tags

    Für den Inhalt des Beitrages 118012 haftet ausdrücklich der jeweilige Autor: Mikesch

  • Keiner 'ne Idee ??!
    Wie wär*s denn, wenn ich die Fat32-Partition zum Start benutze?
    Was passiert mit den Daten dort, wenn ich da was ändere/aktiv setzte?
    ...und nach wie vor: Mit welchem Loader ist denn das leidlich sicher möglich??

    Für den Inhalt des Beitrages 118054 haftet ausdrücklich der jeweilige Autor: Mikesch

  • Ich halte persönlich für keine gute Idee, Grub-Legacy und Grub2 zu mischen.
    Da du einen PC mit UEFI-Motherboard hast musst du auch GRUB2-EFI als Bootloader nutzen.
    Da muss der Bootloader in /dev/sdb4 installiert werden.


    Weiterhin möchte ich wissen ob dein Windows 7 64-bit ist.


    Poste bitte noch

    Code
    blkid
    ls /boot/grub2/

    LG SUSEDJAlex

  • ...jo, was die UEFI-Tauglichkeit des Mainboards betrifft -> bin ich mir gar nicht so sicher...
    Der Bootloader (also, grub2) ist derzeit dort (sdb4) zu Hause.
    Die Win7 ist (ich muß sicherheitshalber nachher nochmal gucken) ziemlich sicher 64bit.


    In sr0 liegt SuperGrub, ohne komm ich ja gar nicht rein....


    Code
    ls /boot/grub2/
    backgrounds device.map fonts grub.cfg grub.cfg.old grubenv i386-pc locale themes unicode.pf2 x86_64-efi


    Besten Dank schonmal für's kümmern, Gruß, mk

    Für den Inhalt des Beitrages 118070 haftet ausdrücklich der jeweilige Autor: Mikesch

  • Ja, ich denke thats the problem -> Windows ist MBR, kein UEFI.
    Was die Fähigkeiten des Mainboards betrifft, ich bin mir da auch nicht sicher wie EFI/GPT-fähig die Kiste ist, denn wenn ich über bios-boot-menü explizit über die GPT-Platte starten möchte, sagt er schlicht NÖ und greift sich wieder die Windose.


    Für den Inhalt des Beitrages 118072 haftet ausdrücklich der jeweilige Autor: Mikesch

  • Nach kurzem Ausflug zurück: Ja, positiv: Win7pro 64 bit
    Allerdings schnelle Richtigstellung: Rechner heißt: HP Compaq Pro 6300MT (und nicht hp pro 3500, wie oben fälschlich angegeben).

    Für den Inhalt des Beitrages 118079 haftet ausdrücklich der jeweilige Autor: Mikesch

  • Das sieht nicht gut aus.
    Normalerweise müsstest du windows komplett im UEFI installieren. Danach kannst du openSUSE ebenfalls im UEFI installieren.


    Dann findet GRUB auch die Windows-Partition....


    LG SUSEDJAlex