Webserver (apache2) einrichten

Hinweis: In dem Thema Webserver (apache2) einrichten gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Weil ich hier neu bin: Ich habe seit vielen Jahren immer wieder Kontakt mit Linux, bin aber nie ein Guru geworden. Mein tagtägliches EDV-Leben findet unter Windows statt.


    Für ein technisches Projekt habe ich mir einen gebrauchten Server gekauft (Xeon-Prozessor, 16 GB RAM). Zunächst als Experimentierfeld daheim, aber wenn es läuft, möchte ich später eine Verbindung nach draußen legen – aber soweit bin ich noch nicht.


    Die Wahl der Distribution war schon schwierig. Fedora hängt sich bei der Installation immer auf, Debian und CentrOS habe ich gar nicht erst zum Booten bringen können und bei Ubuntu fehlte die Hälfte, was sich z.B. darin zeigte, dass keine Internetverbindung bestand. Die erste Distribution, bei der die Installation klappte, war openSuse Leap. Ich habe die Serverinstallation durchgeführt ohne Desktop. Weil ich von ca. 20 Jahren schon mal Suse auf einem Rechner hatte, wusste ich, zentrale Konfigurationsstelle ist Yast. Der Rest war im Web schnell zusammengeklickt und so gelang es mir, apache2 zu installieren, MariaDB und php7; war man eben heutzutage so benötigt.


    Mit Yast gelang es mir auch, den apache standardmäßig starten zu lassen. Yast ist sehr logisch aufgebaut und ich finde mich da schnell zurecht.


    Mit lynx localhost kann ich auch die Index-Seite aufrufen, aber php-Seiten werden nicht interpretiert; da sieht man dann den Source. Aber dies ist schon das 2. Problem.


    Das erste Problem besteht bereits darin, dass ich aus meinem Heimnetz den Webserver nicht erreichen kann. Also von Windows aus im Browser aufgerufen: 192.168.188.55 führt zur Browser-Meldung "Seite nicht erreichbar".


    In einem Posting hier im Forum las ich, dass das an der Firewall (zypper) liegen könnte. Von der habe ich aber leider überhaupt keine Ahnung und ich wollte nicht einfach ahnungslos irgnd welche Befehle abtippen. Das LAMP-Paket habe ich nicht installiert. Damit wäre es vermutlich einfacher.


    Ziel der Sache ist, Apache solr zu installieren. Wenn es entgegen dem von mir gewählten Weg bessere Verwirklichugnschancen gibt, bin ich da aufgeschlossen, es gleich anders zu machen. Ich bin kein EDV-Profi.


    Vielen Dank für hoffentlich rettende Tipps oder gar Erleuchtung ;-)


    Gruß
    Martin



    solr: Apache Solr -


    p.s.: Eure sehr gute Forensoftware blendet mir ein ähliches Thema ein. Das darin herrschende Niveau übersteigt leider meine Kenntnisse, sodass ich nicht folgen kann.

    --
    Server Intel Xeon 16 GB Ram, openSuse Leap 15.1 Serverinstallation ohne Desktop

    3 Mal editiert, zuletzt von Martin Lemke () aus folgendem Grund: Ergänzung zum eingeblendeten ähnlichen Thema

    Für den Inhalt des Beitrages 137826 haftet ausdrücklich der jeweilige Autor: Martin Lemke

  • Meistens bekomme ich rettende Ideen, sobald ich ich frage. Ich habe in Yast die Firewalleinstellungen gefunden und http & https freigegeben. Jetzt kplappt es mit dem Zugriff im Netzwerk.


    Bleibt Problem 2: PHP-Dateien werden nciht interpretiert.


    Ich danke aber dennoch für die so schnelle Antwort.


    Gruß
    Martin

    --
    Server Intel Xeon 16 GB Ram, openSuse Leap 15.1 Serverinstallation ohne Desktop

    Für den Inhalt des Beitrages 137829 haftet ausdrücklich der jeweilige Autor: Martin Lemke

  • PHP7 läuft auch. Es war ein dummer Fehler in der PHP-Datei; sowas passiert, wenn man nicht in Übung ist.


    korrekt muss es lauten:
    <?php phpinfo();


    MariaDB läuft korrekt, wie es aussieht:


    mlemke@linux-ku9m:~> systemctl status mysql
    ● mariadb.service - MySQL server
    Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor pre>
    Active: active (running) since Sat 2019-12-21 19:13:23 CET; 3h 42min ago
    Main PID: 2137 (mysqld)
    Status: "Taking your SQL requests now..."
    Tasks: 30 (limit: 11059)
    CGroup: /system.slice/mariadb.service
    └─2137 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --user=mysql


    Leider weiß ich das Passwort von phpMyAdmin nicht. Wo immer ich suche, was default ist, heißt es, Username='root' und Passwort=leer, aber das funktioniert nicht. Dann bekomme ich die Meldung: "Login ohne Passwort ist verboten (siehe AllowNoPassword) in der Konfiguration" – Preisfrage: Welche Konfiguration? Im Verzeichnis von phpMyAdmin habe ich keine Konfiguratinsdatei gefunden.


    Martin

    --
    Server Intel Xeon 16 GB Ram, openSuse Leap 15.1 Serverinstallation ohne Desktop

    Für den Inhalt des Beitrages 137833 haftet ausdrücklich der jeweilige Autor: Martin Lemke


  • Für den Inhalt des Beitrages 137834 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Herzlich lieben Dank! Das funktioniert alles sehr gut, obwohl ich nicht LAMP installiert habe, sondern apache2, PHP7 und MariaDB einzeln von Hand, bzw. mittels Yast.


    Wenn ich an die ganzen erfolglosen Mühen mit den anderen Linux-Distributionen (Fedora, Debian, CentrOS und Ubuntu) denke, erscheint mir openSuse als richtiges Highlight. Und dieses Forum ebenso, weil man hier nicht angeflaumt wird, man sei zu doof die FAQ zu lesen, wie es früher im Usenet der übliche Umgangston war.


    Martin

    --
    Server Intel Xeon 16 GB Ram, openSuse Leap 15.1 Serverinstallation ohne Desktop

    Für den Inhalt des Beitrages 137844 haftet ausdrücklich der jeweilige Autor: Martin Lemke

  • Bitte noch auf gelöst setzen:
    zum 1. Beitrag scrollen und neben der Überschrift das kleine Kästchen doppelklicken.

    Für den Inhalt des Beitrages 137849 haftet ausdrücklich der jeweilige Autor: Sauerland