Leap 15.1 und Secure Boot

Hinweis: In dem Thema Leap 15.1 und Secure Boot gibt es 8 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo,
    ich habe mir ein Notfallsystem (Leap 15.1) auf einer USB Festplatte erstellt. Nach der Installation funktioniert das System problemlos trotz aktiviertem Secure Boot. Nach der Installation meiner nVidia Grafikkarte, bzw. VMware Player (Kernel-devel Installation) funktioniert das booten allerdings nicht mehr. Ich habe zwei Beiträge gelesen und angewendet. Der eine Beitrag befasste sich mit dem Windows 10 Bootloader, bei dem ich Shim eintragen lassen habe. Der andere, etwas älter Beitrag, befasste sich direkt mit Shim und den notwendigen Dateien. Ich habe nach Anleitung und bestem wissen beides ausgeführt, aber es funktioniert leider nicht. Für mich wäre es schön, wenn ich die Festplatte einfach nur anstecken müsste ohne im BIOS (UEFI) etwas umstellen zu müssen. Sollte es eine Lösung geben, bitte für Dummies beschreiben.


    Danke schon mal im Vorraus.


    Viele Grüße Alex

    Für den Inhalt des Beitrages 140924 haftet ausdrücklich der jeweilige Autor: Alex79

  • Dann vielleicht doch einen etwas aufwändigeren Weg. Denn wie gesagt, ich würde gerne ohne BIOS Änderung das ganze haben wollen. Notfalls muss ich mir das notwendige über Google zusammen suchen. Und ein wenig bekomme ich ja schon hin. :)

    Für den Inhalt des Beitrages 140953 haftet ausdrücklich der jeweilige Autor: Alex79

  • Nachdem ich jetzt tagelang versucht habe einen zertifizierten Key zu erstellen und jedes mal an der Zertifizierung gescheitert bin, bin ich dann dem gefolgt was du gepostet hattest und dachte schon ich hätte das Problem gelöst. Mit dem Befehl efibootmgr -v habe ich festgestellt, dass der Eintrag für Scure Boot fehlt und ich habe gemäß der Anleitung diesen eingefügt. Nach mehreren Versuchen war die Erkenntnis, dass der entsprechende Ordner under firmware/*/vars gar nicht vorhanden war. Jetzt ist mir bei dem rum probieren noch eine Möglichkeit aufgefallen. Im visuellen Bootmanger habe ich neben dem Feld "Secure Boot" (aktiviert) auch noch die Möglichkeit eine Flagge (?) zu setzten. Da ich jetzt nicht mehr weiter weiß wäre meine Frage, ob das ganze mit dem "Flagge setzt" gelöst wäre. Bzw. Was ich machen muss um den /vars Eintrag einzufügen.

    Für den Inhalt des Beitrages 141037 haftet ausdrücklich der jeweilige Autor: Alex79

  • Ich verstehe irgendwie bei deinem letzten Thread kein Wort mehr.
    Sauerland sagte bereits alles, poste es und man kann danach weiter suchen !

  • Anleitung Sauerland:
    Konsole 1.txt


    Weiterer Versuch (https://en.opensuse.org/openSU…eate_Your_Own_Certificate)


    Konsole 2.txt


    Den letzten Befehl habe ich nicht ausführen brauchen. Mir ist inzwischen aufgefallen das die sample.efi nicht existiert. Allerdings weiß ich nicht welche efi Datei da nun geändert werden müsste.


    Edit: Dateianhänge endeckt

    Einmal editiert, zuletzt von Alex79 ()

    Für den Inhalt des Beitrages 141072 haftet ausdrücklich der jeweilige Autor: Alex79

  • Hallo,
    das andere was ich meinte:


    Bei dem zweiten Versuch stand "Notice: Trust flag u is set automatically if the private key is present.". Ich schätze, dass es sich hierbei um das booten über Grub2 handelt.


    Bei einem früheren Versuch hatte ich Trustedboot eingeschalten und danch funktionierte der Bootvorgang gar nicht mehr. Von daher könnte ich mir vorstellen, dass ich bei der Erstellung, das Trustedboot (Trust flag) weg lassen müsste.


    Bleibt gesund...

    Für den Inhalt des Beitrages 141077 haftet ausdrücklich der jeweilige Autor: Alex79

  • Hallo,
    ich habe keine Ahnung was bei der letzten Installation falsch gelaufen ist. Ich vermute mal die Installationsreinfolge der Programme, denn ich habe das System neu aufgesetzt und alles funktioniert. Auch der secure boot Eintrag ist samt Ordner vorhanden. Anscheinend ist die nVidia Kernel zertifiziert und was bei dem Komplettpaket Kernel-Devel schief gegangen ist, war eventuell die manuelle Auswahl.


    Ich danke euch für eure Geduld und Mühe.


    vG Alexander

    Für den Inhalt des Beitrages 141322 haftet ausdrücklich der jeweilige Autor: Alex79