Probleme mit fstab und Netzwerk

Hinweis: In dem Thema Probleme mit fstab und Netzwerk gibt es 4 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Moin moin,

    ich habe ein kleines Problem mit dem Rechner meiner Tochter.

    Folgendes: Ich habe den Rechner im Erdgeschoss mit openSUSE bespielt und dann in der fstab einige Verzeichnisse als nfs Freigaben von unserem NAS eingebunden. Rechner mehrmals neugestartet und auch einige Zeit damit gearbeitet. Läuft alles so wie gewünscht.

    Nun habe ich den Rechner genommen und ihn ins Zimmer meiner Tochter gestellt. Gleiche Netzwerk, ebenfalls über LAN ans Hausnetz angebunden und sonst nix geändert.

    Was aber jetzt passiert ist, dass der Rechner bootet, dann die Netzfreigaben nicht findet und entsprechend nicht einbindet. erst wenn ich als root ein mount -a ausführe, klappt es. Woran kann das liegen???? :smilie_pc_057:

    Mir würde es ja schon reichen, wenn ein Script dieses mount -a ausführen würde, sobald sich meine Tochter anmeldet bei KDE.

    Bin im Moment echt ratlos.

    Ach so, Rechner wieder unten angeschlossen und alles klappt wie es sollte!


    Bin für jede konstruktive Hilfe dankbar


    Tobias

  • Zitat

    Was aber jetzt passiert ist, dass der Rechner bootet, dann die Netzfreigaben nicht findet und entsprechend nicht einbindet. erst wenn ich als root ein mount -a ausführe, klappt es. Woran kann das liegen????

    Unten steht der Rechner "direkt" neben dem NAS, oben sind erst 20 m Kabel zu überwinden?

    Falsches Kabel? (zu langsam)? CAT 5?

  • Ja, das stimmt. Unten war ich direkt neben dem NAS und oben sind die Wege länger und halt eine etwas ältere Netzwerkinstallation.

    Wie aber bekomme ich das trotzdem in den Griff.

    Ungern möchte ich meiner Tochter zumuten irgendwelche Befehle eintippen zu müssen. Das sollte für sie alles im Hintergrund und automatisch ablaufen.

  • ..oder schau mal hier:

    https://forums.opensuse.org/sh…-external-drive-partition


    beachte die Option:

    Code
    x-systemd.device-timeout=
    Configure how long systemd should wait for a device to show up before giving up on an entry from /etc/fstab. Specify a time in seconds or explicitly
    append a unit such as "s", "min", "h", "ms".
    Note that this option can only be used in /etc/fstab, and will be ignored when part of the Options= setting in a unit file.