Leap 15.2 und Nvidia G05 450.66 Auflösung fest bei 1024x768

Hinweis: In dem Thema Leap 15.2 und Nvidia G05 450.66 Auflösung fest bei 1024x768 gibt es 9 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Guten Abend miteinander!


    Ich habe die Tage von Leap 15.1 auf Leap 15.2 upgedatet und habe folgendes Problem:

    Als Grafikkarte ist eine GeForce GTX 1060 hier verbaut. Nach der Neuinstallation von

    15.2 hab ich das nvidia-repository angelegt und den Treiber G05-450.66 installiert. Beim

    anschließenden Reboot artig den MOK enrollt, wieder Reboot und dann startet der X-Server

    mit 1024x768 statt der gewünschten 1920x1080. Über Nvidia-Settings lässt sich die

    Auflösung nicht ändern, den es lässt sich erst gar nicht starten. Auch in den Systemeinstellungen

    ist nur 1024x768 wählbar. Mit dem Nouveau-Treiber funktioniert es ohne Probleme, es friert nur

    ab und zu der Desktop ein. Ich würde gerne den Nvidia-Treiber benutzen. Unter Leap 15.1

    hatte ich in dieser Richtung absolut keine Probleme.

    Any Hints?


    Für Antworten vielen dank im Voraus.


    VG Draftman

    Für den Inhalt des Beitrages 283652 haftet ausdrücklich der jeweilige Autor: draftman

  • Über Nvidia-Settings lässt sich die

    Auflösung nicht ändern, den es lässt sich erst gar nicht starten. Auch in den Systemeinstellungen

    ist nur 1024x768 wählbar.

    Das zeugt dann davon, das der Nvidia Treiber nicht läuft, der nouveau geblockt ist und somit ein generischer Treiber (fbev) mit niedriger Auflösung läuft.


    Poste:

    Code
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    Code
    zypper se -si nvidia
    Code
    zypper lr -d

    Sowie füge als Anhang die /var/log/Xorg.0.log an.

  • Hallo Herr Sauerland,

    hier die Ausgaben der Konsole:


    localhost:~ # /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'

    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)

    Subsystem: ASUSTeK Computer Inc. Device [1043:85b6]

    Kernel driver in use: nvidia

    Kernel modules: nouveau, nvidia_drm, nvidia


    localhost:~ # zypper se -si nvidia

    Loading repository data...

    Reading installed packages...


    S | Name | Type | Version | Arch | Repository

    ---+---------------------------+---------+------------------------------------+--------+------------------------

    i+ | nvidia-computeG05 | package | 450.66-lp152.28.1 | x86_64 | nVidia Graphics Drivers

    i | nvidia-gfxG05-kmp-default | package | 450.66_k5.3.18_lp152.19-lp152.28.1 | x86_64 | nVidia Graphics Drivers

    i | nvidia-glG05 | package | 450.66-lp152.28.1 | x86_64 | nVidia Graphics Drivers

    i | x11-video-nvidiaG05 | package | 450.66-lp152.28.1 | x86_64 | nVidia Graphics Drivers


    localhost:~ # zypper lr -d

    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service

    ---+---------------------------+----------------------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------

    1 | Printing | Printing System Development Project (openSUSE_Leap_15.2) | Yes | (r ) Yes | No | 99 | rpm-md | https://download.opensuse.org/…nting/openSUSE_Leap_15.2/ |

    2 | download.nvidia.com-leap | nVidia Graphics Drivers | Yes | (r ) Yes | Yes | 99 | rpm-md | https://download.nvidia.com/opensuse/leap/15.2 |

    3 | dvd | dvd | Yes | (r ) Yes | Yes | 99 | NONE | http://opensuse-guide.org/repo/openSUSE_Leap_15.2/ |

    4 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1 | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/d…ution/leap/15.2/repo/oss/ |

    5 | packman | packman | Yes | (r ) Yes | Yes | 99 | NONE | http://packman.inode.at/suse/openSUSE_Leap_15.2/ |

    6 | repo-debug | Debug Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/d…ution/leap/15.2/repo/oss/ |

    7 | repo-debug-non-oss | Debug Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/d…n/leap/15.2/repo/non-oss/ |

    8 | repo-debug-update | Update Repository (Debug) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.2/oss/ |

    9 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.2/non-oss/ |

    10 | repo-non-oss | Non-OSS Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/d…n/leap/15.2/repo/non-oss/ |

    11 | repo-oss | Haupt-Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/d…ution/leap/15.2/repo/oss/ |

    12 | repo-source | Source Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/s…ution/leap/15.2/repo/oss/ |

    13 | repo-source-non-oss | Source Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/s…n/leap/15.2/repo/non-oss/ |

    14 | repo-update | Hauptaktualisierungs-Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.2/oss |

    15 | repo-update-non-oss | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/ |

    localhost:~ #


    Danke fürs Ansehen.


    VG

    draftman

    Dateien

    • Xorg.0.log.txt

      (27,47 kB, 11 Mal heruntergeladen, zuletzt: )

    Für den Inhalt des Beitrages 283655 haftet ausdrücklich der jeweilige Autor: draftman

  • In der Xorg.log keine Ausgabe zu Nvidia und Nouveau, installiere alle 4 Nvidia Treiber noch einmal neu, dann in der Konsole als root:

    Code
    mkinitrd

    Neustart.


    PS:

    Du siehst bei mir den Kasten mit dem Code, bitte demnächst die Konsolenausgaben jeweils in einem separaten Code-Tag posten, siehe die Links hier unter diesem Text in meiner Signatur.

    Ausserdem hat sich in Foren das du eingebürgert.....


    Gruß

  • Hi Sauerland,


    danke für die Infos, ich werd’s mir hinter die Ohren schreiben. ;)

    Nochmal zum richtigen Verständnis, da die NVIDIA-Treiber noch installiert sind:

    Zuerst Deinstallation und Neustart.

    Dann die 4 Packages erneut installieren und mkinitrd ausführen.

    Neustart und MOK enrollen und nochmals Neustart, dann sollte es laufen.

    Hab ich das so richtig verstanden?


    VG

    draftman


    BTW, beim „Du -Sie“ bin ich wegen Deines Alias‘ etwas ins Schleudern gekommen.

    Er hörte sich für mich nach Nachnamen an, deswegen reflexartig gesiezt.

    Sorry nochmal. ;)

    Für den Inhalt des Beitrages 283657 haftet ausdrücklich der jeweilige Autor: draftman

  • Zuerst Deinstallation und Neustart.

    Dann die 4 Packages erneut installieren und mkinitrd ausführen.

    Nö, einfach als root:

    Code
    zypper in -f nvidia-computeG05 nvidia-gfxG05-kmp-default nvidia-glG05 x11-video-nvidiaG05

    dann weiterhin als root:

    Code
    mkinitrd

    Danach neu starten

  • Hi Sauerland,


    Dein Tip mit der Treiber-reinstallation und anschließendem mkinitrd hat nicht funktioniert,

    keine Änderung. Was könnte man sonst noch tun?


    Für Antworten Danke im Voraus.


    VG

    draftman

    Für den Inhalt des Beitrages 283668 haftet ausdrücklich der jeweilige Autor: draftman

  • Dein Tip mit der Treiber-reinstallation und anschließendem mkinitrd hat nicht funktioniert,

    keine Änderung. Was könnte man sonst noch tun?

    Repo raus, Treiber deinstallieren, Treiber von der Homepage herunterladen und diesen installieren.

    Läuft hier mit Kernel aus Kernel:stable und auch ner GTX 1060.

    Code
    uname -a && nvidia-settings -v
    Linux linux64 5.8.10-3.g4ea78e8-default #1 SMP Tue Sep 22 11:01:27 UTC 2020 (4ea78e8) x86_64 x86_64 x86_64 GNU/Linux
    nvidia-settings: version 455.23.04
    The NVIDIA X Server Settings tool.
    This program is used to configure the NVIDIA Linux graphics driver.
    For more detail, please see the nvidia-settings(1) man page.
    Code
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)
    Subsystem: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03]
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia_drm, nvidia
  • Vielen Dank für den Tip. Das wäre auch noch eine Möglichkeit gewesen, aber ich hab jetzt kurzen Prozess gemacht und Leap 15.2 neu installiert. Als erstes nach dem Neustart auf dem sauberen System die Nvidia-Repos hinzugefügt, den Treiber installiert, Reboot, MOK enrollen, Reboot und alles funktioniert wunderbar. Irgendwas war nach der ersten Installation nicht in Ordnung, aber was? Nun denn, es läuft jetzt. Vielen Dank nochmals für Delne Lösungsvorschläge, schön das es die Community gibt. :)

    VG draftman

    Für den Inhalt des Beitrages 283677 haftet ausdrücklich der jeweilige Autor: draftman