Kein Multithreading mehr? Imagemagick 7.0.7, Leap15.2

Hinweis: In dem Thema Kein Multithreading mehr? Imagemagick 7.0.7, Leap15.2 gibt es 5 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo Forum,


    guten Tag allerseits! Mein Name ist Michael. Ich bin zwar neu hier, aber "bei Linux" schon seit 1992... Und nun habe ich mal ein Problem, für das ich trotz mehrmaliger Suche bisher keine Lösung finden konnte.


    Auf einem frisch Installierten Leap 15.2 mit der dazugehörigen Imagemagick-Version 7.0.7.34 verwendet "convert" stur nur noch einen CPU-Kern. Bei der Version 6.x (von 42.3?) und jahrelang davor hat es, wenn möglich, immer alle Kerne verwendet. Meine Hardware ist seit Jahren dieselbe (Core i5-3470 mit 4 Kernen.)


    Kann man das Multithreading irgendwie wieder aktivieren?


    In /etc/ImageMagick-7/profile.xml habe ich bei der Zeile <!-- <policy domain="resource" name="thread" value="4"/> --> die Kommentarzeichen entfernt - keine Wirkung.


    Irgendwo habe ich gefunden, dass convert zur Verwendung mit openmp kompiliert sein müsse, gilt das auch für Leap 15.2? convert -version zeigt openmp jedenfalls nicht als Feature:

    Code
    $ convert -version
    Version: ImageMagick 7.0.7-34 Q16 x86_64 20180520 https://www.imagemagick.org
    Copyright: © 1999-2018 ImageMagick Studio LLC
    License: https://www.imagemagick.org/script/license.php
    Features: Cipher DPC HDRI Modules
    Delegates (built-in): bzlib cairo djvu fftw fontconfig freetype jbig jng jp2 jpeg lcms lqr ltdl lzma openexr pangocairo png rsvg tiff webp wmf x xml zlib


    Besten Dank schon mal für eure Tips!

    Michael

    Für den Inhalt des Beitrages 284457 haftet ausdrücklich der jeweilige Autor: micha_bee

  • Das sieht doch eher nach einem Fehler im distributionseigenen Imagemagick aus. Vielleicht will man auf einem Server nicht, dass jedes Bild mit allen Kernen gleichzeitig gerechnet wird, aber auf meinem Einzelrechner möchte ich das. Die anscheinende Konfigurationsmöglichkeit funktioniert nicht. Muss ich wohl einen Bugreport draus machen.


    Ich habe jetzt imagemick 6.x von

    https://download.opensuse.org/repositories/home:/mrbadguy:/1C/openSUSE_Leap_15.2/

    installiert, das rechnet mit allen 4 Kernen.

    Für den Inhalt des Beitrages 284606 haftet ausdrücklich der jeweilige Autor: micha_bee

  • Nachtrag: Ich habe testhalber das aktuelle Source-rpm installiert, die Pakete bauen lassen und installiert. Wenn man im Spec-File --disable-openmp deaktiviert, verwendet convert auch mehrere Threads:

    Code
    ...
    --enable-reproducible-build=yes
    # \
    # --disable-openmp
    ...

    Dann greift auch die Einstellung in /etc/ImageMagick-7/policy.xml (nicht .../profile.xml, wie ich oben irrtümlich geschrieben habe.)

    Für den Inhalt des Beitrages 284628 haftet ausdrücklich der jeweilige Autor: micha_bee

  • Siehste, geht doch.


    Aber: