[gelöst] Netzwerkkarte installieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [gelöst] Netzwerkkarte installieren gibt es 13 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • [gelöst] Netzwerkkarte installieren

    Hallo,

    ich verzweifel seit 2 Tagen an meinem neuen PC :cursing: . Ich versuche das Netzwerk zu konfigurieren und es geht einfach nicht. Also ich habe suse 13 mit KDE. Mit yast habe ich die konfiguration mithilfe des networkmanagers eingestellt aber im networkmanager wird unter interfaces nichts angezeigt und ausserdem ist der Karteireiter "wired" ausgegraut lediglich der Reiter "vpn" ist anwählbar. Ich habe bereits versucht den passenden Treiber von der Intelseite zu installieren aber da bekomme ich beim make befehl nur fehlermeldungen.
    Irgendjemand ne Idee was ich machen könnte?

    hier meine hwinfo --netcard

    :

    Quellcode

    1. 13:PCI 19.0: 0200 Ethernet controller
    2. [Created at pci.319]
    3. SysFS ID: /devices/pci/0000:00/0000:00:19.0
    4. SysFS BusID: 0000:00:19.0
    5. Hardware Class: network
    6. Model: "Intel Ethernet controller"
    7. Vendor: pci 0x8086 "Intel Corparation"
    8. Device: pci 0x15a1
    9. IRQ: 3 (no events)
    10. Module Alias: "pci:v00008086d000015A1sv00001849sd000015A1bc02sc00i00"
    11. Config Status: cfg=no, avail=yes, need=no, active=unknown
    Alles anzeigen


    Quellcode

    1. lspci -nnk
    2. Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I2l8-V [8086:15a1]
    3. Subsystem: ASRock Incorporation Device [1849:8cba]


    Konsolenausgaben in Code-Tags.

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von Alen ()

    Für den Inhalt des Beitrages 68896 haftet ausdrücklich der jeweilige Autor: Alen

  • Die Netzwerkkarte ist zu neu und nur in aktuellen Kerneln.

    Unter Kernel 3.11 (aktueller Kernel der openSUSE 13.1) als root:

    Quellcode

    1. /sbin/modprobe -c | grep -i "8086.*15a1"

    ergibt keine Ausgabe.

    Unter Kernel 3.14:

    Quellcode

    1. /sbin/modprobe -c | grep -i "8086.*15a1"
    2. alias pci:v00008086d000015A1sv*sd*bc*sc*i* e1000e


    Poste bitte noch:

    Quellcode

    1. uname -a
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 68898 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Bei 12.3 habe ich in ein Csl System eine Netzwerkkarte eingebaut.

    Nach dem Update (keine Neuinstallation) auf 13.1 konnte ich die Karte wieder ausbauen.
    Ich denke es war ein Attansic Chip oder einer mit einem ähnlichen Namen.
    Das war für einen Freund, und er staunte, wie schnell das ging.

    Für den Inhalt des Beitrages 68907 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Kanonentux schrieb:

    Ich denke es war ein Attansic Chip oder einer mit einem ähnlichen Namen.

    Alen schrieb:

    Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I2l8-V [8086:15a1]

    Naja, ähnlich.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 68908 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Okay danke für die Antwort! Also uname spuckt folgendes aus:

    Quellcode

    1. Linux linux-iqrq 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64 x86_64 x86_64 GNU/Linux


    Meinst du ich sollte einen neuen Kernel installieren oder lieber versuchen die richtigen treiber zu installieren?

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Alen ()

    Für den Inhalt des Beitrages 68909 haftet ausdrücklich der jeweilige Autor: Alen

  • Alen schrieb:

    Meinst du ich sollte einen neuen Kernel installieren oder lieber versuchen die richtigen treiber zu installieren?

    Ich würde einen neuen Kernel installieren, allerdings kannst Du danach dann keine normalen Repos mit Kernel-Modulen einbinden (z.B. Nvidia / ATI).

    Funktioniert dann nur per Hand (z.B. ATI mit Script von Sebastian Siebert, Nvidia mit der run-Datei).

    Kernel Repo einbinden:
    Als root:

    Quellcode

    1. zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard/ Kernel

    Installieren:

    Quellcode

    1. zypper in -f kernel-desktop-3.14.4-1.1.gbebeb6f
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 68911 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich habe keine Grafikkarte im PC ich nutze die interne Grafikkarte der CPU also dafür werde ich wohl keine "normalen repos einbinden" <---keine Ahnung was das bedeutet :) ist mein erstes mal Linux...

    Leider kann ich den ersten zypper Befehl so nicht ausführen da der Rechner ja offline ist. Kann ich das auch offline machen?

    Für den Inhalt des Beitrages 68913 haftet ausdrücklich der jeweilige Autor: Alen

  • Alen schrieb:

    Kann ich das auch offline machen?

    Ja.

    Diesen mit anderem Rechner herunterladen, auf USB-Stick schieben und dann auf dem anderen Rechner in Deinem /home/Benutzername/Downloads speichern. (Benutzername ist mit Deinem Benutzernamen zu ersetzen).
    download.opensuse.org/reposito…4-1.1.gbebeb6f.x86_64.rpm

    Danach als root auf dem Rechner:

    Quellcode

    1. zypper in -f /home/Benutzername/Downloads/kernel-desktop-3.14.4-1.1.gbebeb6f.x86_64.rpm

    Benutzername mit Deinem Benutzernamen ersetzen.

    Neustart.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 68914 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Okay ich probiere es sofort aus...
    ...leider bekomme ich folgenden Fehler:

    Quellcode

    1. Fehler beim Herunterladen (curl) für 'http://download.opensuse.org/distribution/13.1/repo/non-oss/repodata/repomd.xml':Fehlerkode: Connection failed Fehlernachricht: Could not resolve host: download.opensuse.org


    scheinbar will er irgendeine repomd.xml Datei runterladen....

    Ich kann jetzt Abbrechen, wiederholen oder ignorieren. Soll ich ignorieren?

    Ich habe festgestellt dass unter download.opensuse.org/distribution/13.1/repo/non-oss/ garkeine repomd.xml liegt!? Aber unter download.opensuse.org/update/13.1-non-oss/repodata/ gibt es eine solche Datei. ?(

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von Alen ()

    Für den Inhalt des Beitrages 68915 haftet ausdrücklich der jeweilige Autor: Alen