Problem mit Samba

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Problem mit Samba gibt es 4 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Problem mit Samba

    Hallo liebe Forenmitglieder,
    ich benutze jetzt seit 4 Tagen OpenSUSE 13.1 und wollte den Rechner unter dem es läuft in das bestehende Windows Netzwerk integrieren. Dies klappte beim ersten Mal auch wunderbar, jedoch war er nach einem Neustart wieder aus dem Netzwerk raus und ich konnte von keinem anderen PC auf ihn zugreifen, noch kann ich von ihm einen PC im Netzwerk anpingen... Weiß jemand eine Lösung für dieses Problem?

    Ich würde OpenSUSE echt gerne weiter benutzen, aber wenn es keine Lösung gibt es richtig in Netzwerk zu integrieren, dann steige ich wieder auf Windows um...

    Für den Inhalt des Beitrages 69063 haftet ausdrücklich der jeweilige Autor: ElGee420

  • ElGee420 schrieb:

    jedoch war er nach einem Neustart wieder aus dem Netzwerk raus und ich konnte von keinem anderen PC auf ihn zugreifen, noch kann ich von ihm einen PC im Netzwerk anpingen

    Dann stimmt etwas mit dem Netzwerk nicht?

    Ist das Netzwerk mit Netzwerkmanager oder Yast/ifup eingerichtet?

    Quellcode

    1. /sbin/lspci -.nnk | grep -iA3 net

    Quellcode

    1. /sbin/ifconfig

    Quellcode

    1. systemctl status network.service


    Firewall auf der openSUSE ist vorübergehend ausgeschaltet?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 69064 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich glaube, ich habe mich etwas undeutlich ausgedrückt... Also mit dem Router bin ich verbunden, aber ich muss eben bei jedem Start Samba neu starten un die Freigaben neu einstellen...

    Für den Inhalt des Beitrages 69070 haftet ausdrücklich der jeweilige Autor: ElGee420

  • ElGee420 schrieb:

    Ich glaube, ich habe mich etwas undeutlich ausgedrückt... Also mit dem Router bin ich verbunden, aber ich muss eben bei jedem Start Samba neu starten un die Freigaben neu einstellen...
    Aber die Freigaben sind in der /etc/samba/smb.conf eingetragen?

    Um zu prüfen ob Samba dauerhaft eingeschaltet ist kannst Du diesen Befehl nutzen:

    # systemctl is-enabled samba.service

    Falls dieser ein "disabled" ausgibt musst Du folgendes eingeben:

    # systemctl enable smb.service

    Das schaltet den Samba Dienst ein, aktiviert ihn aber erst nach dem nächsten Restart - falls Du ihn sofort auch starten willst, geht das mit:

    # systemctl start smb.service

    der Samba Dienst muss aber zusätzlich noch in der Firewall freigeschaltet werden. Das mache ich in der Regel mit YaST:
    YaST -> Security and Users -> Firewall
    Dort bei "Allowed Services" in der "External Zone" den "Samba Server" hinzufügen.

    Für den Inhalt des Beitrages 69073 haftet ausdrücklich der jeweilige Autor: wn48z